Community discussions

MUM Europe 2020
 
phuketmymac
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 50
Joined: Thu Jun 05, 2014 7:56 pm

No Audio to FreePBX Extension - 2 sites on IPsec tunnel

Fri Feb 14, 2020 1:00 pm

Hello,

I am scratching my head on this.
Let me be honest I am complete newbie when it comes to VOIP and FreePBX.

I have managed to install FreePBX as a VM on my Proxmox server and set up an inbound/outbound SIP trunk to it.
I can call from the outside and leave a message which works. Voicemail is recorded and I can hear myself talking.

I have 2 small offices connected using an IPsec tunnel with 2 Mikrotik routers.
Please don’t ask me why but I have at the moment the Server in one office and a Digium D60 IP phone into the other network.
And that’s the only phone I have so far. The 2nd phone has been ordered and will arrive soon. Though I am staying in the 2nd office ATM so the only phone is with me for testing.

The phone can register properly to the Server and ringing, picking up or hanging up the phone works.
However no sound whatsoever.

Since the SIP trunk is working fine and I can record audio from incoming phone calls, I believe the issue is only related to the Digium D60 not being able to send audio Data to the Server and vice-versa.
I guess you will tell me to bring that phone to the other office and try in the same network to rule out an issue with the phone itself and its setup.

It might be a simple config problem as this seems to be a very common problem, apparently mostly related to NAT traversal. But I am using an IPsec tunnel which should use routing only. Aren’t I right?!

I have btw followed a mikrotik forum post to disable the SIP helper on both Mikrotik firewalls. That did help with phone calls not terminating after someone would hang up.

I have played for hours if not days with the settings of the phone, directly from its Web UI or through the Digium Addon with no success.

So any idea guys?
Thanks!
Last edited by phuketmymac on Fri Feb 14, 2020 1:10 pm, edited 2 times in total.
 
phuketmymac
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 50
Joined: Thu Jun 05, 2014 7:56 pm

Re: No Audio to FreePBX Extension - 2 sites on IPsec tunnel  [SOLVED]

Fri Feb 14, 2020 1:09 pm

My bad it's now fixed.
It was a Server side setup mistake.
I should have added the 2nd network in the SIP settings.

Now it's working perfectly with this added.

Who is online

Users browsing this forum: Bing [Bot], CZFan, InoX, Zamtron and 116 guests