Community discussions

MikroTik App
 
BogaBY
just joined
Topic Author
Posts: 2
Joined: Wed Jul 17, 2019 1:50 pm

WinBox Connection error

Tue Mar 24, 2020 5:02 pm

winbox error : router does not support secure connection, please enable legacy mode if you want to connect anyway.
Winbox - 3.22
RB1100AHx4 - 6.46.4

And see attachment.

Any idea?
You do not have the required permissions to view the files attached to this post.
 
MrDAnderson
just joined
Posts: 2
Joined: Wed Mar 25, 2020 5:38 pm
Location: San Pedro Sula, Cortes, HN

Re: WinBox Connection error

Wed Mar 25, 2020 8:03 pm

I had the same problem, the best you go back to the previous version
 
User avatar
pukkita
Trainer
Trainer
Posts: 3013
Joined: Wed Dec 04, 2013 11:09 am
Location: Spain

Re: WinBox Connection error

Wed Mar 25, 2020 9:19 pm

You need to enable set Tools > Legacy Mode in WinBox

Once you log on, Make sure System > Routerboard Current vs Upgrade Firmware is the same, otherwise click on Upgrade and reboot.
Simplicity is the Ultimate Sophistication - Da Vinci
Getting the most out of this forum
 
Kindis
Member Candidate
Member Candidate
Posts: 275
Joined: Tue Nov 01, 2011 6:54 pm

Re: WinBox Connection error

Wed Mar 25, 2020 11:11 pm

So I wonder if the new secure winbox connection cannot handle NAT.
Was setting up a new router that I pre configured but managed to frogg up the OSPF config on the new one.
GRE connected but I had to NAT my connection to get route back and Winbox did not want to connect with legacy mode on or off.
Used SSH to fix my config and once NAT was off Winbox worked again.
Just a guess but this might be how they solve man in the middle attacks but this creates the issue that I cannot force my router to use legacy mode if all this is true.

Edit: What I mean is that I think new Winbox security cannot handle stuff like NAT that "tamper" with the header of the package. Once again just a guess and I have not tested.
 
BogaBY
just joined
Topic Author
Posts: 2
Joined: Wed Jul 17, 2019 1:50 pm

Re: WinBox Connection error

Thu Mar 26, 2020 9:40 am

You need to enable set Tools > Legacy Mode in WinBox

Once you log on, Make sure System > Routerboard Current vs Upgrade Firmware is the same, otherwise click on Upgrade and reboot.
Current Firmware and Upgrade Firmware is the same = 6.46.4

https://prnt.sc/rmzrdn

Who is online

Users browsing this forum: Guntis and 174 guests