Community discussions

MUM Europe 2020
 
g.tusa
just joined
Topic Author
Posts: 8
Joined: Mon May 07, 2007 6:13 pm

Problem with queue download/upload configuration

Tue May 29, 2007 1:32 pm

Hello guys, I want to control download and upload traffic for pppoe users connected with Mikrotik as pppoe-concentrator, by limiting the bandwidth based on group of users (users profiles), and at the same time equalize the bandwidth usage among users with the same profile. As an example, having some users with profile A, and other with profile B, and for the download side, I follow the following steps:
1) Create an IP address list of the users belonging to profile A and of the users belonging to profile B
2) Create the mangle rules to mark their packets:
Profile A
- /ip firewall mangle add chain=prerouting dst-address-list=A_list action=mark-connection new-connection-mark=A_conn passthrough=yes
- /ip firewall mangle add connection-mark=A_conn action=mark-packet new-packet-mark=A_mark chain=prerouting passthrough=no
Profile B
- /ip firewall mangle add chain=prerouting dst-address-list=B_list action=mark-connection new-connection-mark=B_conn passthrough=yes
- /ip firewall mangle add connection-mark=B_conn action=mark-packet new-packet-mark=B_mark chain=prerouting passthrough=no
3) Define new pcq queue types for A and B:
- /queue type add name=pcq_A kind=pcq pcq-classifier=dst-address
- /queue type add name=pcq_B kind=pcq pcq-classifier=dst-address
4) Define the download queue:
- /queue tree add name=Download parent=Local max-limit=total_available_dowload_bandwidth
5) Define the child queues:
- /queue tree add parent=Download limit-at=128K max-limit=1M queue=pcq_A packet-mark=A_mark
- /queue tree add parent=Download limit-at=256K max-limit=2M queue=pcq_B packet-mark=B_mark
The problem is that, while packets of a given address-list appears to be market correctly, I cannot see any packet in both the parent (Download) and the child queues (it is like the above controls doesn't make place). If, on the other hand, I set "global-in" virtual interface as parent of the "Download" queue, instead of "Local", I can see packet enqueued (but I wish to make the download control on the Local interface...).
Where I'm wrong? Anyone has some advice, correction or suggestion?

Thank you
-- gio
 
User avatar
111111
Member Candidate
Member Candidate
Posts: 194
Joined: Thu Oct 05, 2006 1:39 am
Location: BG,SOFIA

Re: Problem with queue download/upload configuration

Tue May 29, 2007 1:50 pm

same problem with me too
evrithing marked correct but queues do't work
if use static ip not PPPoE work and queues show trafik
 
g.tusa
just joined
Topic Author
Posts: 8
Joined: Mon May 07, 2007 6:13 pm

Re: Problem with queue download/upload configuration

Tue May 29, 2007 2:00 pm

... so, I must think there could be problems due to the dynamic pppoe queues created in the Local interface for each connected pppoe user?
The dinamically created queues and the custom ones cannot coexist?

--gio
 
rgpmikrotik
Frequent Visitor
Frequent Visitor
Posts: 51
Joined: Mon May 14, 2007 5:45 pm

Re: Problem with queue download/upload configuration

Tue May 29, 2007 2:55 pm

yoy can do queue tree and they work together with the simle queue dinamically created by pppoe server. I think you are putting the queue in the wrong interface or you are marking the packets in a wrong place, please see the way wich follows the packets when enters to your MT:

http://www.mikrotik.com/testdocs/ros/2.9/ip/flow.php

I had problems like those, but i could understand the graffic wich is in this url and now it´s all working, I trtied to helped you.
 
g.tusa
just joined
Topic Author
Posts: 8
Joined: Mon May 07, 2007 6:13 pm

Re: Problem with queue download/upload configuration

Tue May 29, 2007 3:10 pm

Ok, many thanks for the suggestion rgpmikrotik.
I'm going to read more carefully this documentation page! If you have a working example and want to post it, it would be very appreciated.
Anyway I'll post my solution, if I'll be able to make it working!

Thanks
--gio

Who is online

Users browsing this forum: No registered users and 70 guests