Community discussions

MikroTik App
 
samyil
just joined
Topic Author
Posts: 14
Joined: Thu Mar 18, 2010 1:38 pm
Location: Bulgaria

CRS354-48P-4S+2Q+ traffic problem on ports 1 to 8

Wed Apr 29, 2020 6:50 pm

Hi, I have a problem with CRS354-48P-4S + 2Q +. The ports work from ether1 to ether8 but no traffic passes through them. Interfaces are lit, active but no traffic
[admin@SW48P4S2Q] > interface ethernet print 
Flags: X - disabled, R - running, S - slave 
 #    NAME              MTU MAC-ADDRESS       ARP             SWITCH           
 0 RS ether1           1500 C4:AD:34:BD:45:CC enabled         switch1          
 1  S ether2           1500 C4:AD:34:BD:45:CD enabled         switch1          
 2 RS ether3           1500 C4:AD:34:BD:45:CE enabled         switch1          
 3 RS ether4           1500 C4:AD:34:BD:45:CF enabled         switch1          
 4  S ether5           1500 C4:AD:34:BD:45:D0 enabled         switch1          
 5  S ether6           1500 C4:AD:34:BD:45:D1 enabled         switch1          
 6  S ether7           1500 C4:AD:34:BD:45:D2 enabled         switch1          
 7  S ether8           1500 C4:AD:34:BD:45:D3 enabled         switch1          
 8 RS ether9           1500 C4:AD:34:BD:45:D4 enabled         switch1          
 9 RS ether10          1500 C4:AD:34:BD:45:D5 enabled         switch1          
What I noticed is that there are no 1 to 8 ports in the switch.
[admin@SW48P4S2Q] > interface ethernet switch host print where ports=ether1
Flags: D - dynamic, I - invalid 
 #   SWITCH         MAC-ADDRESS       PORTS         TIMEOUT DROP MIRROR VLAN-ID
And if I look for port 9 it finds it.
[admin@SW48P4S2Q] > interface ethernet switch host print where ports=ether9
Flags: D - dynamic, I - invalid 
 #   SWITCH         MAC-ADDRESS       PORTS         TIMEOUT DROP MIRROR VLAN-ID
 0 D switch1        00:12:15:3A:79:16 ether9        0s      no   no         250
 
Where could the problem be?
 
Zacharias
Forum Guru
Forum Guru
Posts: 2309
Joined: Tue Dec 12, 2017 12:58 am
Location: Greece

Re: CRS354-48P-4S+2Q+ traffic problem on ports 1 to 8

Wed Apr 29, 2020 7:06 pm

Here is a related problem with CRS354, you can check the solution viewtopic.php?f=3&t=159176&p=787552&hil ... 54#p788593 and let us know if it fixes your problem...
 
samyil
just joined
Topic Author
Posts: 14
Joined: Thu Mar 18, 2010 1:38 pm
Location: Bulgaria

Re: CRS354-48P-4S+2Q+ traffic problem on ports 1 to 8

Wed Apr 29, 2020 7:40 pm

My problem is not that my traffic is low, my problem is that there is no traffic and the ports are behaving as if everything is fine - they are recognized.

Image
 
Zacharias
Forum Guru
Forum Guru
Posts: 2309
Joined: Tue Dec 12, 2017 12:58 am
Location: Greece

Re: CRS354-48P-4S+2Q+ traffic problem on ports 1 to 8

Wed Apr 29, 2020 7:58 pm

I don't think it would harm your device trying the update.
Ports 1-8 is the first Group of ports and since those specific ports do not work maybe you have made any changes in the Switch menu or anything ?
 
samyil
just joined
Topic Author
Posts: 14
Joined: Thu Mar 18, 2010 1:38 pm
Location: Bulgaria

Re: CRS354-48P-4S+2Q+ traffic problem on ports 1 to 8

Wed Apr 29, 2020 8:28 pm

This is my simple configuration, I bought the device yesterday, I'm sure the ports worked yesterday. I don't want to return it to the dealer without being sure the reason is not in me!
[admin@SW48P4S2Q] > export compact 
# apr/29/2020 20:21:29 by RouterOS 6.46.5
# software id = LEE3-4B2Q
#
# model = CRS354-48P-4S+2Q+
# serial number = B8440BF5F2B7
/interface bridge
add name=bridge1 vlan-filtering=yes
/interface ethernet
set [ find default-name=sfp-sfpplus1 ] comment=SW10G
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip hotspot profile
set [ find default=yes ] html-directory=flash/hotspot
/user group
set full policy=local,telnet,ssh,ftp,reboot,read,write,policy,test,winbox,password,web,sniff,sensitive,api,romon,dude,tikapp
/interface bridge port
add bridge=bridge1 interface=ether1 pvid=250
add bridge=bridge1 interface=ether2 pvid=250
add bridge=bridge1 interface=ether3 pvid=250
add bridge=bridge1 interface=ether4 pvid=250
add bridge=bridge1 interface=ether5 pvid=250
add bridge=bridge1 interface=ether6 pvid=250
add bridge=bridge1 interface=ether7 pvid=250
add bridge=bridge1 interface=ether8 pvid=250
add bridge=bridge1 interface=ether9 pvid=250
add bridge=bridge1 interface=ether10 pvid=250
add bridge=bridge1 interface=ether11 pvid=70
add bridge=bridge1 interface=ether12 pvid=70
add bridge=bridge1 interface=ether13 pvid=70
add bridge=bridge1 interface=ether14 pvid=70
add bridge=bridge1 interface=ether15 pvid=70
add bridge=bridge1 interface=ether16 pvid=70
add bridge=bridge1 interface=ether17 pvid=70
add bridge=bridge1 interface=ether18 pvid=70
add bridge=bridge1 interface=ether19 pvid=70
add bridge=bridge1 interface=ether20 pvid=70
add bridge=bridge1 interface=ether21 pvid=70
add bridge=bridge1 interface=ether22 pvid=70
add bridge=bridge1 interface=ether23 pvid=70
add bridge=bridge1 interface=ether24 pvid=70
add bridge=bridge1 interface=ether25 pvid=250
add bridge=bridge1 interface=ether26 pvid=250
add bridge=bridge1 interface=ether27 pvid=250
add bridge=bridge1 interface=ether28
add bridge=bridge1 interface=ether29
add bridge=bridge1 interface=ether30
add bridge=bridge1 interface=ether31 pvid=250
add bridge=bridge1 interface=ether32 pvid=250
add bridge=bridge1 interface=ether33 pvid=250
add bridge=bridge1 interface=ether34
add bridge=bridge1 interface=ether35 pvid=4
add bridge=bridge1 interface=ether36 pvid=4
add bridge=bridge1 interface=ether37
add bridge=bridge1 interface=ether38
add bridge=bridge1 interface=ether39
add bridge=bridge1 interface=ether40
add bridge=bridge1 interface=ether41
add bridge=bridge1 interface=ether42
add bridge=bridge1 interface=ether43
add bridge=bridge1 interface=ether44
add bridge=bridge1 interface=ether45 pvid=250
add bridge=bridge1 interface=ether46 pvid=250
add bridge=bridge1 interface=ether47
add bridge=bridge1 interface=ether48 pvid=602
add bridge=bridge1 interface=ether49
add bridge=bridge1 interface=qsfpplus1-1
add bridge=bridge1 interface=qsfpplus1-2
add bridge=bridge1 interface=qsfpplus1-3
add bridge=bridge1 interface=qsfpplus1-4
add bridge=bridge1 interface=qsfpplus2-1
add bridge=bridge1 interface=qsfpplus2-2
add bridge=bridge1 interface=qsfpplus2-3
add bridge=bridge1 interface=qsfpplus2-4
add bridge=bridge1 interface=sfp-sfpplus1
add bridge=bridge1 interface=sfp-sfpplus2
add bridge=bridge1 interface=sfp-sfpplus3
add bridge=bridge1 interface=sfp-sfpplus4
/interface bridge vlan
add bridge=bridge1 tagged=sfp-sfpplus1 vlan-ids=70
add bridge=bridge1 tagged=sfp-sfpplus1 vlan-ids=250
add bridge=bridge1 tagged=sfp-sfpplus1 vlan-ids=4
add bridge=bridge1 tagged=sfp-sfpplus1 vlan-ids=602
add bridge=bridge1 tagged=sfp-sfpplus1,sfp-sfpplus2 vlan-ids=61
/ip address
add address=172.16.20.4/24 interface=bridge1 network=172.16.20.0
/ip dns
set servers=93.155.130.11,93.155.130.14
/ip route
add distance=1 gateway=172.16.20.1
/ip service
set telnet disabled=yes
set ftp disabled=yes
set ssh port=2222
set api disabled=yes
set api-ssl disabled=yes
/system clock
set time-zone-name=Europe/Sofia
/system identity
set name=SW48P4S2Q
/system ntp client
set enabled=yes primary-ntp=93.155.130.11 secondary-ntp=93.155.130.14
/system routerboard settings
set boot-os=router-os
#error exporting /system swos
 
Zacharias
Forum Guru
Forum Guru
Posts: 2309
Joined: Tue Dec 12, 2017 12:58 am
Location: Greece

Re: CRS354-48P-4S+2Q+ traffic problem on ports 1 to 8

Wed Apr 29, 2020 9:04 pm

I can't take a look at your config right now...
Since it is new, in case you have no important config on it, just reset it to its default settings...
Or make a backup and then reset...
After that, remove all cables from every ethernet port and test them one by one ...
 
planetcoop
Member Candidate
Member Candidate
Posts: 136
Joined: Thu May 15, 2014 2:32 pm
Location: Sacramento, CA

Re: CRS354-48P-4S+2Q+ traffic problem on ports 1 to 8

Thu Apr 30, 2020 12:59 am

I have run into a similar issue on my device. What i have noticed and am waiting feedback from support for is a simple supported vlan filtering configuration. I assign the first few ports (ether1-6) to vlan=10 and within a few hours or a day, but the vlan is un-reachable randomly. If i reboot the switch it will resume working for some amount of time. The vlan does continue to trunk and work on the sfp+ and qsfp+ ports during the un-reach-ability.

I also have noticed some 100 and gigabit enabled devices flapping port speed and link without cause (ether1-16).

I am waiting for support feedback.
 
samyil
just joined
Topic Author
Posts: 14
Joined: Thu Mar 18, 2010 1:38 pm
Location: Bulgaria

Re: CRS354-48P-4S+2Q+ traffic problem on ports 1 to 8

Thu Apr 30, 2020 1:24 am

I have run into a similar issue on my device. What i have noticed and am waiting feedback from support for is a simple supported vlan filtering configuration. I assign the first few ports (ether1-6) to vlan=10 and within a few hours or a day, but the vlan is un-reachable randomly. If i reboot the switch it will resume working for some amount of time. The vlan does continue to trunk and work on the sfp+ and qsfp+ ports during the un-reach-ability.

I also have noticed some 100 and gigabit enabled devices flapping port speed and link without cause (ether1-16).

I am waiting for support feedback.
I think we have the same problem, after reboot the traffic is run, but how long will it work ?
 
planetcoop
Member Candidate
Member Candidate
Posts: 136
Joined: Thu May 15, 2014 2:32 pm
Location: Sacramento, CA

Re: CRS354-48P-4S+2Q+ traffic problem on ports 1 to 8

Thu Apr 30, 2020 2:44 am

My traffic works for 1 minute or sometimes 3-4 days. I have been working on two support cases on the vlan traffic and the flapping port speed/link issue. Separately, i have added a fourth fan to the CPU cooler than 68C more like 48-56C. As a side note, that has not changes the operation, but seems more reasonable for device health. i have used a Noctua 40mm fan with the rubber grommets to secure it to the CPU heat sink.

In case it helps i will post my config in a bit.
 
planetcoop
Member Candidate
Member Candidate
Posts: 136
Joined: Thu May 15, 2014 2:32 pm
Location: Sacramento, CA

Re: CRS354-48P-4S+2Q+ traffic problem on ports 1 to 8

Thu Apr 30, 2020 5:16 am

# model = CRS354-48G-4S+2Q+
/interface bridge
add admin-mac=C4:AD:34:XX:XX:XX auto-mac=no name=bridge protocol-mode=none vlan-filtering=yes
/interface ethernet
set [ find default-name=ether20 ] auto-negotiation=no speed=100Mbps
set [ find default-name=qsfpplus1-1 ] arp-timeout=30s l2mtu=9128 mtu=9000
set [ find default-name=qsfpplus1-2 ] arp-timeout=30s l2mtu=9128 mtu=9000
set [ find default-name=qsfpplus1-3 ] arp-timeout=30s l2mtu=9128 mtu=9000
set [ find default-name=qsfpplus1-4 ] arp-timeout=30s l2mtu=9128 mtu=9000
set [ find default-name=qsfpplus2-1 ] arp-timeout=30s l2mtu=9128 mtu=9000
set [ find default-name=qsfpplus2-2 ] arp-timeout=30s l2mtu=9128 mtu=9000
set [ find default-name=qsfpplus2-3 ] arp-timeout=30s l2mtu=9128 mtu=9000
set [ find default-name=qsfpplus2-4 ] arp-timeout=30s l2mtu=9128 mtu=9000
set [ find default-name=sfp-sfpplus1 ] arp-timeout=30s l2mtu=9128 mtu=9000
set [ find default-name=sfp-sfpplus2 ] arp-timeout=30s l2mtu=9128 mtu=9000
set [ find default-name=sfp-sfpplus3 ] arp-timeout=30s l2mtu=9128 mtu=9000
set [ find default-name=sfp-sfpplus4 ] arp-timeout=30s l2mtu=9128 mtu=9000
/system logging action
add name=syslog remote=192.168.0.62 remote-port=51402 src-address=192.168.0.3 target=remote
/interface bridge port
add bridge=bridge interface=ether1 pvid=10
add bridge=bridge interface=ether2 pvid=10
add bridge=bridge interface=ether3 pvid=10
add bridge=bridge interface=ether4 pvid=10
add bridge=bridge interface=ether5 pvid=11
add bridge=bridge interface=ether6 pvid=11
add bridge=bridge interface=ether7 pvid=11
add bridge=bridge interface=ether8 pvid=11
add bridge=bridge interface=ether9 pvid=11
add bridge=bridge interface=ether10 pvid=11
add bridge=bridge interface=ether11 pvid=11
add bridge=bridge interface=ether12 pvid=11
add bridge=bridge interface=ether13 pvid=11
add bridge=bridge interface=ether14 pvid=11
add bridge=bridge interface=ether15 pvid=11
add bridge=bridge interface=ether16 pvid=11
add bridge=bridge interface=ether17 pvid=11
add bridge=bridge interface=ether18 pvid=11
add bridge=bridge interface=ether19 pvid=11
add bridge=bridge interface=ether20 pvid=11
add bridge=bridge interface=ether21 pvid=11
add bridge=bridge interface=ether22 pvid=11
add bridge=bridge interface=ether23 pvid=11
add bridge=bridge interface=ether24 pvid=11
add bridge=bridge interface=ether25 pvid=11
add bridge=bridge interface=ether26 pvid=11
add bridge=bridge interface=ether27 pvid=11
add bridge=bridge interface=ether28 pvid=11
add bridge=bridge interface=ether29 pvid=11
add bridge=bridge interface=ether30 pvid=11
add bridge=bridge interface=ether31 pvid=11
add bridge=bridge interface=ether32 pvid=11
add bridge=bridge interface=ether33 pvid=11
add bridge=bridge interface=ether34 pvid=11
add bridge=bridge interface=ether35 pvid=11
add bridge=bridge interface=ether36 pvid=11
add bridge=bridge interface=ether37 pvid=11
add bridge=bridge interface=ether38 pvid=11
add bridge=bridge interface=ether39 pvid=11
add bridge=bridge interface=ether40 pvid=11
add bridge=bridge interface=ether41 pvid=11
add bridge=bridge interface=ether42 pvid=11
add bridge=bridge interface=ether43 pvid=11
add bridge=bridge interface=ether44 pvid=11
add bridge=bridge interface=ether45 pvid=11
add bridge=bridge interface=ether46 pvid=11
add bridge=bridge interface=ether47 pvid=11
add bridge=bridge interface=ether48 pvid=11
add bridge=bridge interface=qsfpplus1-1 pvid=11
add bridge=bridge interface=qsfpplus1-2 pvid=11
add bridge=bridge interface=qsfpplus1-3 pvid=11
add bridge=bridge interface=qsfpplus1-4 pvid=11
add bridge=bridge interface=qsfpplus2-1 pvid=11
add bridge=bridge interface=qsfpplus2-2 pvid=11
add bridge=bridge interface=qsfpplus2-3 pvid=11
add bridge=bridge interface=qsfpplus2-4 pvid=11
add bridge=bridge interface=sfp-sfpplus1 pvid=11
add bridge=bridge interface=sfp-sfpplus2 pvid=11
add bridge=bridge interface=sfp-sfpplus3 pvid=11
add bridge=bridge interface=sfp-sfpplus4 pvid=11
/interface bridge vlan
add bridge=bridge tagged=qsfpplus1-1,qsfpplus2-1 vlan-ids=12-20
add bridge=bridge tagged=qsfpplus1-1,qsfpplus2-1 vlan-ids=65-94
add bridge=bridge tagged=qsfpplus1-1,qsfpplus2-1 vlan-ids=165-194
add bridge=bridge tagged=qsfpplus1-1,qsfpplus2-1 vlan-ids=11
add bridge=bridge tagged=qsfpplus1-1,qsfpplus2-1 vlan-ids=10
add bridge=bridge vlan-ids=1
/ip address
add address=192.168.0.3/24 interface=ether49 network=192.168.0.0
/ip dns
set servers=192.168.0.5,192.168.0.8
/ip route
add distance=1 gateway=192.168.0.1
/ip service
set telnet address=192.168.0.0/24 disabled=yes port=10023
set ftp address=192.168.0.0/24 disabled=yes port=10021
set www address=192.168.0.0/24 port=10080
set ssh address=192.168.0.0/24 port=10022
set www-ssl address=192.168.0.0/24 disabled=no port=10443
set api address=192.168.0.0/24
set winbox address=192.168.0.0/24
set api-ssl address=192.168.0.0/24
/snmp
set enabled=yes trap-version=2
/system clock
set time-zone-name=America/Los_Angeles
/system identity
set name=switch-dist
/system logging
add action=syslog topics=info
add action=syslog topics=debug
add action=syslog topics=dhcp
add action=syslog topics=error
add action=syslog topics=event
add action=syslog topics=health
add action=syslog topics=interface
add action=syslog topics=ntp
add action=syslog topics=route
add action=syslog topics=script
add action=syslog topics=ssh
add action=syslog topics=system
add action=syslog topics=warning
add action=syslog topics=wireless
add action=syslog topics=account
/system ntp client
set enabled=yes primary-ntp=192.168.0.254
/system package update
set channel=testing
/system routerboard settings
set boot-os=router-os
#error exporting /system swos
 
gvw1980
just joined
Posts: 1
Joined: Mon Apr 27, 2020 9:48 am

Re: CRS354-48P-4S+2Q+ traffic problem on ports 1 to 8

Fri May 08, 2020 8:45 am

I have the exact same problem any feedback from support on this ?

Gys
 
aeichhorn
just joined
Posts: 9
Joined: Tue May 12, 2020 9:52 am

Re: CRS354-48P-4S+2Q+ traffic problem on ports 1 to 8

Tue May 12, 2020 10:07 am

I have the same problem. I've just fallen in love with Mikrotik and the first device I installed at a customer is a CRS354-48P-4S+2Q+.
Configuration is only a simple bridge over all ports with activated vlan filtering and 4 VLANs.
Everything seemed to work fine. Port 1 is our uplink port to the router.
Yesterday randomly the network stopped to work. First we thought the firewall was the problem because we could still ping the servers on SFP+1 - SFP+3.
After some investigation we saw that it was a problem of the ether ports on the Mikrotik. Like OP the ether ports just showed up as normal but absolutely not a single packet was passing through.

I need a solution for this, really quick. It's one important customer for me. I installed this switch because I only heard good things about Mikrotik.
But this experience is very bad for me. Please help!

Edit: We could validate this problem is also for us only on port 1-8. All other ports seem to be intact.
Last edited by aeichhorn on Tue May 12, 2020 11:45 am, edited 1 time in total.
 
hostclub
newbie
Posts: 27
Joined: Tue May 12, 2020 2:23 am

Re: CRS354-48P-4S+2Q+ traffic problem on ports 1 to 8

Tue May 12, 2020 6:29 pm

I have the same problem. I've just fallen in love with Mikrotik and the first device I installed at a customer is a CRS354-48P-4S+2Q+.
Configuration is only a simple bridge over all ports with activated vlan filtering and 4 VLANs.
Everything seemed to work fine. Port 1 is our uplink port to the router.
Yesterday randomly the network stopped to work. First we thought the firewall was the problem because we could still ping the servers on SFP+1 - SFP+3.
After some investigation we saw that it was a problem of the ether ports on the Mikrotik. Like OP the ether ports just showed up as normal but absolutely not a single packet was passing through.

I need a solution for this, really quick. It's one important customer for me. I installed this switch because I only heard good things about Mikrotik.
But this experience is very bad for me. Please help!

Edit: We could validate this problem is also for us only on port 1-8. All other ports seem to be intact.
Did you update RouterOS to the final release 6.46.6 ?
 
aeichhorn
just joined
Posts: 9
Joined: Tue May 12, 2020 9:52 am

Re: CRS354-48P-4S+2Q+ traffic problem on ports 1 to 8

Tue May 12, 2020 10:18 pm

Did you update RouterOS to the final release 6.46.6 ?
Yeah when I installed the switch I updated it to the latest stable.
I just updated to 6.47beta60 in hope that this changes something.

Edit: I just saw that I could update firmware separately? System -> RouterBOARD.
Does this also have something to do with system stability? It says current firmware / factory firmware version is 6.46.1

Whats the difference between the firmware and the normal RouterOS?

Edit2: Problem still there with 6.47beta60. Haven't updated the router board firmware yet.
 
MarcDE
just joined
Posts: 2
Joined: Mon May 07, 2018 1:10 am

Re: CRS354-48P-4S+2Q+ traffic problem on ports 1 to 8

Wed May 20, 2020 12:16 am

We have the same issue at a customer location. Port 1-8 is just stopping traffic forwarding. Also opened a support ticket, hope mtik will have a solution for this since its in the middle of a larger hardware-renewal at that customer, now stopped because of this issue. :'-(
 
aeichhorn
just joined
Posts: 9
Joined: Tue May 12, 2020 9:52 am

Re: CRS354-48P-4S+2Q+ traffic problem on ports 1 to 8

Thu May 21, 2020 4:01 pm

I told my distributor about this problem with reference to this thread here.
He forwarded this problem to his Mikrotik contact person on Monday.

I ordered another 4 of this model for a complete network redesign at a customer.
I just hope this is a software problem that gets fixed quick...

If this is a hardware problem with the first switch chip, then I will get into big trouble, because my distributor said that inplace exchanges are not possible...
This would mean I have to buy multiple replacement switches, otherwise the complete network at my customer would be offline...

I hope Mikrotik will respond to this problem... this switch is cheap for the capabilities it has, but for broken hardware its too much...
 
aeichhorn
just joined
Posts: 9
Joined: Tue May 12, 2020 9:52 am

Re: CRS354-48P-4S+2Q+ traffic problem on ports 1 to 8

Mon May 25, 2020 4:48 pm

My distributor got a response by Mikrotik:
We are aware of these complaints about Ethernet port group problem on CRS354 switches and actively investigate it.
Although the solution have not been found yet, we plan to provide it soon.
 
vortex
Forum Guru
Forum Guru
Posts: 1097
Joined: Sat Feb 16, 2013 6:10 pm

Re: CRS354-48P-4S+2Q+ traffic problem on ports 1 to 8

Mon May 25, 2020 5:19 pm

Is this problem present only on the PoE version?
 
nexusds
just joined
Posts: 18
Joined: Fri Aug 16, 2019 6:51 am

Re: CRS354-48P-4S+2Q+ traffic problem on ports 1 to 8

Mon May 25, 2020 9:26 pm

Is this problem present only on the PoE version?
same issue on non-poe version
 
nexusds
just joined
Posts: 18
Joined: Fri Aug 16, 2019 6:51 am

Re: CRS354-48P-4S+2Q+ traffic problem on ports 1 to 8

Mon May 25, 2020 9:47 pm

Has anyone confirmed if cooling the device more helps and/or if the fans are installed the wrong way and/or the CPU heat sink is poorly mounted? just wondering if software vs hardware fix is needed. never opened up the chassis, but maybe part of the controllers for ports 1-8 are close to the CPU and affected by heat?
 
gotsprings
Forum Veteran
Forum Veteran
Posts: 902
Joined: Mon May 14, 2012 9:30 pm

Re: CRS354-48P-4S+2Q+ traffic problem on ports 1 to 8

Thu May 28, 2020 10:12 pm


this switch is cheap for the capabilities it has, but for broken hardware its too much...
If it doesn't work... it doesn't mater what it costs.

Also... they finally admitted there is "just nothing they can do about" busy airtime. So I stopped using their wireless radios.

Routing... Love THEM. ANYTHING ELSE... going to a different vendor.
"It ain't what you don't know that gets you into trouble. It's what you know for sure that just ain't so."
Mark Twain
 
wtechlink
just joined
Posts: 4
Joined: Tue Mar 03, 2020 3:09 am

Re: CRS354-48P-4S+2Q+ traffic problem on ports 1 to 8

Fri May 29, 2020 12:57 am

Just logging in to say I have the same issues. It caused me 11 hours of downtime for 500 customers when I went out of cell range this last weekend... I guess I will go move the switches off of ports 1-8 until they can fix this.

It's pretty annoying because I also had issues with the 24 port 10 Gig switch that was just released. That switch would quit working once you put in the 18th SFP module while in SWOS...
 
User avatar
Onigma
just joined
Posts: 3
Joined: Sat Apr 07, 2018 12:52 pm
Location: Russia

Re: CRS354-48P-4S+2Q+ traffic problem on ports 1 to 8

Wed Jun 03, 2020 11:57 pm

I have the same problem. Is the issue resolved in new versions RouterOS?
 
kareztt
just joined
Posts: 1
Joined: Wed Jun 10, 2020 11:20 pm

Re: CRS354-48P-4S+2Q+ traffic problem on ports 1 to 8

Thu Jun 11, 2020 12:04 am

Wish I had checked this thread before I bought. Running 6.47. The ports 1-8 thing has been a tranwreck for me. Not having SWOS is also a PITA. Takes something that should be beyond simple and turns it into a mistake prone mess. Not being able to see everything laid out in a GUI is far from ideal. Ports 1 thru eight drop at random times. I thought I had a bad switch, got it replaced and same issue on the replacement. So now I had to buy a dfferent brand switch which I did not want because they did not sell anything else I really wanted and I had to use the credit, never mind the hassle of swappint out 3 switches. I started out saving a few bucks and ended up spening more than the SG3xx series switches which I should have stuck with. Tried to register for support and the website never worked. They are cheap but they do not have support either which can cost you. Not sure what support would have done in any case. Ugh..... As others have noted, great for routers but not so much for switches, at least this model.
 
User avatar
Onigma
just joined
Posts: 3
Joined: Sat Apr 07, 2018 12:52 pm
Location: Russia

Re: CRS354-48P-4S+2Q+ traffic problem on ports 1 to 8

Thu Jun 11, 2020 6:12 pm

6.48beta5 - 4 days - no problem
 
nexusds
just joined
Posts: 18
Joined: Fri Aug 16, 2019 6:51 am

Re: CRS354-48P-4S+2Q+ traffic problem on ports 1 to 8

Thu Jun 11, 2020 9:17 pm

agreed, although I moved more critical stuff off those ports I havent seen the issue with 6.48B5.

email support@mikrotik if you want to test the file.
 
Reinis
MikroTik Support
MikroTik Support
Posts: 77
Joined: Wed Jan 02, 2019 12:14 pm
Location: Latvia
Contact:

Re: CRS354-48P-4S+2Q+ traffic problem on ports 1 to 8

Wed Jun 17, 2020 7:28 am

Also... they finally admitted there is "just nothing they can do about" busy airtime. So I stopped using their wireless radios.
What do you mean by that? To improve stability in a high noise environment you can enable RTS/CTS. You can always fine-tune the wireless interface by adjusting hw-retries, disconnect-timeout, preamble, etc. Additionally, if your board uses Atheros wireless chip, adaptive-noise-immunity is also an option.


They are cheap but they do not have support either which can cost you. Not sure what support would have done in any case. Ugh..... As others have noted, great for routers but not so much for switches, at least this model.
If for some reason support form is not working, you can always write an e-mail to support@mikrotik.com
 
aeichhorn
just joined
Posts: 9
Joined: Tue May 12, 2020 9:52 am

Re: CRS354-48P-4S+2Q+ traffic problem on ports 1 to 8

Wed Jun 17, 2020 10:16 am

@Reinis thank you for your reply, but that's kind of off-topic.

Is there some qualified news on the port problem of the CRS354? Because this really gets a problem for me.
 
Guntis
MikroTik Support
MikroTik Support
Posts: 50
Joined: Fri Jul 20, 2018 1:40 pm

Re: CRS354-48P-4S+2Q+ traffic problem on ports 1 to 8

Wed Jun 17, 2020 1:29 pm

We have added a fix for this problem in 6.48beta5, it hasn't been released to the web yet, if you are experiencing this issue and want to test this version, please contact us at https://help.mikrotik.com/servicedesk/ or via e-mail support@mikrotik.com
 
User avatar
Onigma
just joined
Posts: 3
Joined: Sat Apr 07, 2018 12:52 pm
Location: Russia

Re: CRS354-48P-4S+2Q+ traffic problem on ports 1 to 8

Thu Jun 18, 2020 10:31 am

update: 6.48beta5 - problem 1-8 port exists :(
 
aeichhorn
just joined
Posts: 9
Joined: Tue May 12, 2020 9:52 am

Re: CRS354-48P-4S+2Q+ traffic problem on ports 1 to 8

Thu Jun 18, 2020 10:45 am

update: 6.48beta5 - problem 1-8 port exists :(
Oh no.... :/
Then I can't install this beta for my customers. I can't use my productive customers for beta testing.
I get into big trouble with this.

I need a stable fix for this issues asap :/
 
hostclub
newbie
Posts: 27
Joined: Tue May 12, 2020 2:23 am

Re: CRS354-48P-4S+2Q+ traffic problem on ports 1 to 8

Thu Jun 18, 2020 2:55 pm

I was going to build a small dataroom with some CRS326-24S+2Q+RM as backbone and CRS354-48G-4S+2Q+RM as access switches for servers...But taking into account the instability, some incompatibility between mikrotik devices, slow support, very slow issues fix, I am thinking to go with other vendor !

I strongly believe that for critical envoronments like datacenters, where uptime is very important, Mikrotik is NO GOOD !

For home users and amateurs, i think their items are great
 
aeichhorn
just joined
Posts: 9
Joined: Tue May 12, 2020 9:52 am

Re: CRS354-48P-4S+2Q+ traffic problem on ports 1 to 8

Thu Jun 18, 2020 4:24 pm

Support just wrote me:
We also received feedbacks from customers that the problem disappeared with beta versions.
Perhaps these people are encountered with a problem that relates specifically to the 6.48beta5 version.
In version 6.48beta7 added new improvements that also related to CRS354.
 
User avatar
rushlife
Member Candidate
Member Candidate
Posts: 120
Joined: Thu Nov 05, 2015 12:30 pm
Location: czech republic

Re: CRS354-48P-4S+2Q+ traffic problem on ports 1 to 8

Tue Jun 23, 2020 11:09 am

+1

i have about 15 pcs of crs354 (with / without POE - both variant ) and one of them have also this issue

no some special setting, just bridge all over interfaces and dhcp-client on that bridge

ros 6.47
 
User avatar
rushlife
Member Candidate
Member Candidate
Posts: 120
Joined: Thu Nov 05, 2015 12:30 pm
Location: czech republic

Re: CRS354-48P-4S+2Q+ traffic problem on ports 1 to 8

Tue Jun 23, 2020 1:04 pm

+2
another switch started doing that thing
OMG
I am running whole network on these switches, I will kill my self... :?
 
aeichhorn
just joined
Posts: 9
Joined: Tue May 12, 2020 9:52 am

Re: CRS354-48P-4S+2Q+ traffic problem on ports 1 to 8

Tue Jun 23, 2020 8:27 pm

+2
another switch started doing that thing
OMG
I am running whole network on these switches, I will kill my self... :?
I feel you :D I have not that much switches of that type, but the problem is very big :D
 
hostclub
newbie
Posts: 27
Joined: Tue May 12, 2020 2:23 am

Re: CRS354-48P-4S+2Q+ traffic problem on ports 1 to 8

Tue Jun 23, 2020 11:58 pm

I was going to build my network with CRS354....but seeing this issues, I am going for other vendor.

Arista refurbished, same price, 10 times better.
 
User avatar
rushlife
Member Candidate
Member Candidate
Posts: 120
Joined: Thu Nov 05, 2015 12:30 pm
Location: czech republic

Re: CRS354-48P-4S+2Q+ traffic problem on ports 1 to 8

Wed Jun 24, 2020 12:32 am

no biggie, on many units I can move client to ether 9 or higher
i will wait for fix and if sometime some unit fail again on ports 1-8, just will do restart and show must go on...

my trust on mikrotik is no broken, everyone make mistakes
 
hostclub
newbie
Posts: 27
Joined: Tue May 12, 2020 2:23 am

Re: CRS354-48P-4S+2Q+ traffic problem on ports 1 to 8

Wed Jun 24, 2020 12:50 am

There is more than a month since clients reported the issue and still no fix. They do not care about the switches. Routers are their priority.

The old series of switches still have issues, that were reported and no fix. Mikrotik decided to take the next step with the new generation.

Reboots are permited once in a while. On of my clients run a hosting business. How can I tell him to reboot every time the switch goes nuts ? :)

Yes, for offices and home users, reboots are not a problem.
 
nexusds
just joined
Posts: 18
Joined: Fri Aug 16, 2019 6:51 am

Re: CRS354-48P-4S+2Q+ traffic problem on ports 1 to 8

Thu Jun 25, 2020 9:42 pm

Update;
routeros-mipsbe-6.48beta5 does not fix issue
while ports are affected per controller (8 sequential ports), its not always ports 1-8, can be 9-16 or 16-24, etc

latest test beta routeros-mipsbe-6.48beta7 was handed out this morning.. will implement and test this evening
 
User avatar
rushlife
Member Candidate
Member Candidate
Posts: 120
Joined: Thu Nov 05, 2015 12:30 pm
Location: czech republic

Re: CRS354-48P-4S+2Q+ traffic problem on ports 1 to 8

Fri Jun 26, 2020 7:55 am

two of my units (I have around 15pcs totally) are affected with this issue and both are failing on ether1-8, I can confirm that, no any other port show problem...
 
nexusds
just joined
Posts: 18
Joined: Fri Aug 16, 2019 6:51 am

Re: CRS354-48P-4S+2Q+ traffic problem on ports 1 to 8

Fri Jun 26, 2020 7:16 pm

Beta 7 MAY be resolving the issue by automatically flapping the ports. by the time we had the issue it had corrected itself. although at the same time one device in the port group had rebooted which caused a flap of the one port.. so not sure which one made it work again. will report on any info.

also, do NOT apply beta 7 to CRS326-24S+2Q+ if you use Q+ ports.. they seem to stop connecting even if set non-auto neg after updating software and firmware to beta7. works fine in beta5
 
markwien
Frequent Visitor
Frequent Visitor
Posts: 50
Joined: Sun Jul 22, 2018 10:49 am

Re: CRS354-48P-4S+2Q+ traffic problem on ports 1 to 8

Sat Jun 27, 2020 9:18 am

two of my units (I have around 15pcs totally) are affected with this issue and both are failing on ether1-8, I can confirm that, no any other port show problem...
I have similar issue - how often do the port fail ? Can u reproduce it?

I get 2 groups failing on my 48 switch but can’t reproduce ...
Br
Mark
 
hostclub
newbie
Posts: 27
Joined: Tue May 12, 2020 2:23 am

Re: CRS354-48P-4S+2Q+ traffic problem on ports 1 to 8

Mon Jun 29, 2020 8:12 pm

2 months and still NO fix.

Good job mikrotik !!! True pro !
 
nexusds
just joined
Posts: 18
Joined: Fri Aug 16, 2019 6:51 am

Re: CRS354-48P-4S+2Q+ traffic problem on ports 1 to 8

Mon Jun 29, 2020 11:39 pm

today tried flapping ports one by one did not help.. had to flap all ports in the affected group and the same time to get it back working. this also throws out the auto-recover possibility. its just random at this point.
 
MBungalski
just joined
Posts: 2
Joined: Sat Oct 16, 2010 11:59 am

Re: CRS354-48P-4S+2Q+ traffic problem on ports 1 to 8

Fri Jul 03, 2020 2:13 am

Hello,

i have exact the same problem with two CRS354-48-4S+2Q+ on ports 1 to 8. Traffic stops forwarding sometimes for a few seconds, sometimes until i disable and re-enable the ports manually.
I have this on two units, today got from my dealer new exchange devices, but they have the same problem. So it looks like a hardware design problem.

Too bad because the devices are actually very nice :-(
 
nexusds
just joined
Posts: 18
Joined: Fri Aug 16, 2019 6:51 am

Re: CRS354-48P-4S+2Q+ traffic problem on ports 1 to 8

Fri Jul 03, 2020 5:30 am

Just curious, with anyone having the issue on ports 1-8, if you move those to 9-16 (swap the groups).. do you still see the issue on the first group or does it now move to the new group?
 
MarcDE
just joined
Posts: 2
Joined: Mon May 07, 2018 1:10 am

Re: CRS354-48P-4S+2Q+ traffic problem on ports 1 to 8

Fri Jul 03, 2020 9:08 am

My Customer told me that even with b7 the issue still occurs. i guess its less often, but still not resolved. mtik please advice...

Who is online

Users browsing this forum: deanz, DjM, Google [Bot], mbovenka, Miracle and 70 guests