Community discussions

MikroTik App
 
sessionip
just joined
Topic Author
Posts: 3
Joined: Thu Feb 27, 2020 8:51 pm

QoS + Simple Queues

Thu May 21, 2020 4:03 am

I'm limiting 3 pcs in bridge2 with simple queues, max limit is 2M each client. So i have one parent 5M and three childs of 2M, it works just fine.
Now i want to add QoS to prioritize pings over other traffic, so i added a queue tree, but pings are lost or delay increases as soon as i do a speed test.
If i disable the simple queue rules, then the queue tree works and pings have no delay and i don't lose any replies, it gets priority over other traffic.

How can i have both ? here is my config.
# may/20/2020 21:59:52 by RouterOS 6.46.6
# model = RouterBOARD 962UiGS-5HacT2HnT
/interface bridge
add name=bridge1 protocol-mode=none
add name=bridge2 protocol-mode=none
/ip pool
add name=dhcp_pool0 ranges=192.168.1.3-192.168.1.10
/ip dhcp-server
add address-pool=dhcp_pool0 disabled=no interface=bridge2 name=dhcp1
/queue type
add kind=pcq name=pcq-download-2M pcq-classifier=dst-address pcq-rate=2M
add kind=pcq name=pcq-upload-1M pcq-classifier=src-address pcq-rate=1M
/queue simple
add max-limit=2M/5M name="All Bandwidth" queue=\
    pcq-upload-default/pcq-download-default target=bridge2
add max-limit=1M/2M name=pc3 parent="All Bandwidth" queue=\
    pcq-upload-default/pcq-download-default target=192.168.1.3/32
add max-limit=1M/2M name=pc4 parent="All Bandwidth" queue=\
    pcq-upload-default/pcq-download-default target=192.168.1.4/32
add max-limit=1M/2M name=pc5 parent="All Bandwidth" queue=\
    pcq-upload-default/pcq-download-default target=192.168.1.5/32
/queue tree
add max-limit=5M name=DOWNLOAD parent=bridge2 queue=pcq-download-default
add max-limit=2M name=UPLOAD parent=bridge1 queue=pcq-upload-default
add limit-at=64k max-limit=1M name=icmp_down packet-mark=icmp_pk parent=\
    DOWNLOAD priority=1 queue=pcq-download-default
add limit-at=128k max-limit=5M name=dns_down packet-mark=dns_pk parent=\
    DOWNLOAD priority=2 queue=pcq-download-default
add limit-at=1M max-limit=5M name=web packet-mark=web_pk parent=DOWNLOAD \
    priority=4 queue=pcq-download-default
add limit-at=1M max-limit=5M name=other packet-mark=other parent=DOWNLOAD \
    queue=pcq-download-default
add limit-at=64k max-limit=1M name=icmp_up packet-mark=icmp_pk parent=UPLOAD \
    priority=1 queue=pcq-upload-default
add limit-at=128k max-limit=2M name=dns_up packet-mark=dns_pk parent=UPLOAD \
    priority=2 queue=pcq-upload-default
add limit-at=512k max-limit=2M name=web_up packet-mark=web_pk parent=UPLOAD \
    priority=4 queue=pcq-upload-default
add limit-at=512k max-limit=2M name=other_up packet-mark=other parent=UPLOAD \
    queue=pcq-upload-default
/interface bridge port
add bridge=bridge1 interface=ether1
add bridge=bridge1 interface=ether2
add bridge=bridge2 interface=ether3
add bridge=bridge2 interface=ether4
add bridge=bridge2 interface=ether5
/ip address
add address=192.168.1.1/24 interface=bridge2 network=192.168.1.0
/ip dhcp-client
add disabled=no interface=bridge1
/ip dhcp-server lease
add address=192.168.1.5 client-id=1:0:90:f5:f3:8a:4 comment="notebook 5" \
    mac-address=00:90:F5:F3:8A:04 server=dhcp1
add address=192.168.1.3 client-id=1:0:5:12:d:27:29 comment="notebook 3" \
    mac-address=00:05:12:0D:27:29 server=dhcp1
add address=192.168.1.4 client-id=1:48:2a:e3:8:b8:79 comment="notebook 4" \
    mac-address=48:2A:E3:08:B8:79 server=dhcp1
/ip dhcp-server network
add address=192.168.1.0/24 dns-server=8.8.8.8,8.8.4.4 gateway=192.168.1.1
/ip firewall mangle
add action=mark-connection chain=prerouting comment=ICMP new-connection-mark=\
    icmp_conn passthrough=yes protocol=icmp
add action=mark-packet chain=prerouting connection-mark=icmp_conn \
    new-packet-mark=icmp_pk passthrough=no
add action=mark-connection chain=prerouting comment=DNS new-connection-mark=\
    dns_conn passthrough=yes port=53 protocol=udp
add action=mark-packet chain=prerouting connection-mark=dns_conn \
    new-packet-mark=dns_pk passthrough=no
add action=mark-connection chain=prerouting comment=WEB new-connection-mark=\
    web_conn passthrough=yes port=80,443 protocol=tcp
add action=mark-packet chain=prerouting connection-mark=web_conn \
    new-packet-mark=web_pk passthrough=no
add action=mark-connection chain=prerouting comment=OTHER \
    new-connection-mark=other_conn passthrough=yes
add action=mark-packet chain=prerouting connection-mark=other_conn \
    new-packet-mark=other passthrough=no
/ip firewall nat
add action=masquerade chain=srcnat out-interface=bridge1

Who is online

Users browsing this forum: alexanwar, Bing [Bot], Jacka, petertosh, roe1974 and 119 guests