Community discussions

MikroTik App
 
User avatar
skv4ro
just joined
Topic Author
Posts: 1
Joined: Wed May 20, 2020 11:17 am

Cannot manage CRS326 over trunk port nor over vlan devide

Thu May 21, 2020 10:06 am

Hello folks,
now i am really depressed. I have read tons of tutorials and forums, studied lot about vlan bridge filtering but i cant get it working.
This is my situation:
I have CCR1036 router and CRS326 switch which has 2 vlans (10 and 20) with trunk port (sfp) connected to router. Vlans working fine but i can not get access to my switch over winbox. Only way for me is to connect via MAC from ether24 which i did not add to any vlan.
All ports are added to bridge, in have created 2 vlan interfaces (10 and 20) with interface spf (my trunk) and in bridge vlans i have created vlans 10 and 20 with tagged sfp. Bridge vlan 1 is added dynamicaly with untagged bridge, sfp and my management port 24.
My goal is to manage switch over device connected to vlan 10 or over sfp port (i will connect to router via vpn).
I think I have tested every possible situation: create vlan eg99 as management with tagged or untagged traffic, assign ip on router and swich on every possible interface (bridge, vlan, port) but not worked. I need to access switch with WinBox but it can not see ip nor mac.
Interesting for me is fact I can ping switch with assigned ip from router but not from any other device connected to switch or vlan or router (all firewalls are disabled).
I had many configurations but i will post my very first.
Thanks for replies.
#ROUTER
add interface=sfp3 name=vlan10 vlan-id=10
add interface=sfp3 name=vlan20 vlan-id=20

add address=10.100.0.1/24 interface=vlan10 network=10.100.0.0

#SWITCH
add address=10.100.0.2/24 interface=vlan10 network=10.100.0.0

/interface bridge
add name=master-bridge vlan-filtering=yes
/interface bridge port
add bridge=master-bridge interface=ether1 pvid=20
add bridge=master-bridge interface=ether2 pvid=20
add bridge=master-bridge interface=ether3 pvid=20
add bridge=master-bridge interface=ether4 pvid=20
add bridge=master-bridge interface=ether5 pvid=20
add bridge=master-bridge interface=ether6 pvid=20
add bridge=master-bridge interface=ether7 pvid=20
add bridge=master-bridge interface=ether8 pvid=20
add bridge=master-bridge interface=ether9 pvid=10
add bridge=master-bridge interface=ether10 pvid=10
add bridge=master-bridge interface=ether11 pvid=10
add bridge=master-bridge interface=ether12 pvid=10
add bridge=master-bridge interface=ether13 pvid=10
add bridge=master-bridge interface=ether14 pvid=10
add bridge=master-bridge interface=ether15 pvid=10
add bridge=master-bridge interface=ether16 pvid=10
add bridge=master-bridge interface=ether17 pvid=10
add bridge=master-bridge interface=ether18 pvid=10
add bridge=master-bridge interface=ether19 pvid=10
add bridge=master-bridge interface=ether20 pvid=10
add bridge=master-bridge interface=ether21 pvid=10
add bridge=master-bridge interface=ether22 pvid=10
add bridge=master-bridge interface=ether23 pvid=10
add bridge=master-bridge interface=ether24
add bridge=master-bridge interface=sfp-sfpplus1
/interface bridge vlan
add bridge=master-bridge tagged=sfp-sfpplus1 untagged=vlan10 vlan-ids=10
add bridge=master-bridge tagged=sfp-sfpplus1 untagged=vlan20 vlan-ids=20

/interface vlan
add interface=sfp-sfpplus1 name=vlan10 vlan-id=10
add interface=sfp-sfpplus1 name=vlan20 vlan-id=20
 
User avatar
mutluit
Long time Member
Long time Member
Posts: 505
Joined: Wed Mar 25, 2020 4:04 am

Re: Cannot manage CRS326 over trunk port nor over vlan devide

Fri May 22, 2020 2:12 pm

What is your IP, netmask and gateway on your PC?
Is the PC attached to the switch?
Is your PC multihomed (ie. does it have more than one network interface)?
How is the routing on the PC?
And a simple drawing of your network would help us to understand better.
And create the following file and post it:
/export hide-sensitive file=export-hs.rsc

I would have set-up first w/o any VLAN to simplify things.

Who is online

Users browsing this forum: almdandi, amt, Maggiore81, xvo and 97 guests