Community discussions

MikroTik App
 
MrSmersh
just joined
Topic Author
Posts: 3
Joined: Thu Jun 25, 2020 1:14 am

Sudden problem 2 routers (hEx S) SFP + POE

Thu Jun 25, 2020 1:43 am

Hi,
Have this configuration 2 hEX S routers (RB760iGS firmware 6.47) , are connected by a SFP copper cable S+DA0001 (disabled Auto Negotiation, 1 GB Full Duplex). A pretty typical configuration, the first router has the public addresses, the second one DHCP and the private ones, both have a public IP. On the second router on eth 5 is a TPLink AP (ddWRT) running on POE (disabled Auto Negotiation, 100 MPS, forced on).
This used to work. 2 days ago was a power outage, all is on UPS but after half an hour the computers shut down and rest remained on as long as the batteries still had juice.

After when the power kick back in, the first sign was the AP was turned off, did a couple of power cycles and nothing. Tried to power from the first router port 5, still nothing. Did MAC resets on the interface and so, still nothing. The AP is OK, since I put a power injector and works as before. Did double check if running on latest versions of firmware on the routers, rebooted all and so and nothing.

In the process discovered that the SFP communication between routers is off. Reseted the second router to factory defaults restored the configuration back, cold booted bot routers with SFP module in, changed in the second router in WinBox Quick Set to SFP1 did all the steps (of course the Ethernet cable in port 1 taken out). Tried 1 GB, 10 GB speeds still nothing. Always the SFP interface at cable test say No Link. As before all these tries.

The configuration now works with an Ethernet cable between routers (SFP is still physically connected), and AP on power injector... Is not quite optimal....

Any idea how to troubleshoot these issues? Have no idea where to look anymore.

Thank you!

Catalin
 
MrSmersh
just joined
Topic Author
Posts: 3
Joined: Thu Jun 25, 2020 1:14 am

Re: Sudden problem 2 routers (hEx S) SFP + POE

Sun Jun 28, 2020 3:50 am

Spend a week on it, and i'm annoyed.

Solution:
  • make all the good settings (forced on etc)
  • connect your poe client and or SFP cable
  • shutdown the router (maybe a reboot before )
  • unplug the router
  • drink a coffee/tea etc
  • plug the router
  • enjoy
Still Mikrotik peoples, improper shutdown should not do something like these.... Because even if possible at UPS shutdown signal to be notified the router to shutdown, when power on network should be the first up.
Ok, no WiFi since was POE, but SFP? And POE problem was on both routers, so its systemic. Improper shutdown messes something, and even in decent infrastructure (power surge protections and UPS) can happen. And target customers are not even having that much, so for products you should have some hardening on these.
And just recommended a big switch for POE capabilities to a friend, a Mikrotik one, hope the expensive range is tad more predictable and resilient.

Who is online

Users browsing this forum: BillyVan, eworm, Google [Bot], keithy, sindy and 61 guests