Community discussions

MikroTik App
 
Gombeen666
Member Candidate
Member Candidate
Topic Author
Posts: 149
Joined: Tue Jun 25, 2019 5:33 pm

Gateway issue?

Sun Jun 28, 2020 4:06 pm

I have one Radius Server which on its gateway is 192.168.1.1 but is connected to two routers, my question is how do i set gateway address on each router and if one router fails?
You do not have the required permissions to view the files attached to this post.
 
User avatar
mutluit
Forum Veteran
Forum Veteran
Posts: 743
Joined: Wed Mar 25, 2020 4:04 am

Re: Gateway issue?

Sun Jun 28, 2020 4:28 pm

How many LANs do you have?
Gateway functions upwards, not downwards.
Since according to your drawing your server is connected to both routers, then it already must use two gateways.
Just specify the IP of the router interface/bridge for each respective interface on the server.
Normally such two routers means at least 2 LANs. Ie. a multihomed server.
Last edited by mutluit on Sun Jun 28, 2020 4:35 pm, edited 1 time in total.
 
User avatar
bpwl
Long time Member
Long time Member
Posts: 681
Joined: Mon Apr 08, 2019 1:16 am

Re: Gateway issue?

Sun Jun 28, 2020 4:31 pm

 
Gombeen666
Member Candidate
Member Candidate
Topic Author
Posts: 149
Joined: Tue Jun 25, 2019 5:33 pm

Re: Gateway issue?

Sun Jun 28, 2020 5:51 pm

Many thanks for replies - in VRRP examples ( https://wiki.mikrotik.com/wiki/Manual:VRRP-examples ) load sharing looks promising but as the radius server has just one gateway ( 192.168.1.1) , Could I set in R1 and R2 the same gateway IP?

Configuration
R1 configuration:
/ip address add address=192.168.1.100/24 interface=ether1
/interface vrrp add interface=ether1 vrid=49 priority=254
/interface vrrp add interface=ether1 vrid=77
/ip address add address=192.168.1.1/32 interface=vrrp1
/ip address add address=192.168.1.1/32 interface=vrrp2

R2 configuration:
/ip address add address=192.168.1.200/24 interface=ether1
/interface vrrp add interface=ether1 vrid=49
/interface vrrp add interface=ether1 vrid=77 priority=254
/ip address add address=192.168.1.1/32 interface=vrrp1
/ip address add address=192.168.1.1/32 interface=vrrp2
 
Gombeen666
Member Candidate
Member Candidate
Topic Author
Posts: 149
Joined: Tue Jun 25, 2019 5:33 pm

Re: Gateway issue?

Sun Jun 28, 2020 8:00 pm

Just to add another question will VRRP work on VLAN interfaces

R1 configuration:
/ip address add address=192.168.1.100/24 interface=Vlan100-Ether1
/interface vrrp add interface=Vlan100-Ether1 vrid=49 priority=254
/interface vrrp add interface=Vlan100-Ether1 vrid=77
/ip address add address=192.168.1.1/32 interface=vrrp1
/ip address add address=192.168.1.1/32 interface=vrrp2

R2 configuration:
/ip address add address=192.168.1.200/24 interface=Vlan100-Ether1
/interface vrrp add interface=Vlan100-Ether1 vrid=49
/interface vrrp add interface=Vlan100-Ether1 vrid=77 priority=254
/ip address add address=192.168.1.1/32 interface=vrrp1
/ip address add address=192.168.1.1/32 interface=vrrp2

Who is online

Users browsing this forum: Baidu [Spider], Bing [Bot], meazz1, mohkhalifa and 111 guests