Community discussions

MikroTik App
 
azzuhaily
just joined
Topic Author
Posts: 1
Joined: Mon Jun 29, 2020 12:38 pm

MikroTik can't capture HTTP/3 protocol ?

Mon Jun 29, 2020 1:19 pm

Actually I want to limit YouTube videos, but when I create a mangle rule with chain=prerouting protocol=tcp dst-port=443 action=mark-connection and using layer7 protocol with its regexp, it turns out that there are a lot of youtube videos that can't be captured, it's because these videos apparently already use "HTTP/3" protocol (since June 2020), even though there are 1 or 2 videos can be captured because they still use "HTTP/1" protocol.

And then I try to use protocol=udp instead of tcp, because afaik http/3 using udp, but the result is the same.

My YouTube RegExp = r[0-9]---[a-z]+-[a-z0-9]+-[a-z0-9]+\.googlevideo\.com
It works when a youtube video that i stream is using HTTP/1.

Has anyone try it before?
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24605
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: MikroTik can't capture HTTP/3 protocol ?

Mon Jun 29, 2020 1:21 pm

Youtube uses HTTPS. You can't see anything inside encrypted connections. Layer2 is useless against HTTPS
No answer to your question? How to write posts
 
shiyiqiang08
Frequent Visitor
Frequent Visitor
Posts: 59
Joined: Wed Dec 05, 2018 7:35 am

Re: MikroTik can't capture HTTP/3 protocol ?

Mon Jun 29, 2020 1:45 pm

You can filter out YouTube DNS

Who is online

Users browsing this forum: prozak, sindy and 56 guests