Community discussions

MikroTik App
 
AndyBern
just joined
Topic Author
Posts: 12
Joined: Wed Dec 19, 2018 10:53 pm
Contact:

Bandwidth limiting Dropbox

Tue Jun 30, 2020 5:40 am

The Linux Dropbox client on my computer has a bandwidth limiting option, but it seems to ignore whatever I set and hog all my bandwidth. This interferes with my streaming TV's. So I figured, Mikrotik can handle this...

First, I used the IP firewall connections tab to find what addresses are used for Dropbox. They were in the 162.125.x.x range. So I added a Dropbox address list with that address range...

/ip firewall address-list
add address=162.125.0.0/16 list=Dropbox

Then I added some mangle rules to mark the Dropbox packets...

/ip firewall mangle
add action=mark-connection chain=prerouting comment="Dropbox outgoing" \
    dst-address-list=Dropbox new-connection-mark=dropbox_conn passthrough=yes
add action=mark-connection chain=prerouting comment="Dropbox incoming" \
    new-connection-mark=dropbox_conn passthrough=yes src-address-list=Dropbox
add action=mark-packet chain=prerouting comment="Dropbox packet mark" \
    connection-mark=dropbox_conn new-packet-mark=dropbox passthrough=no

I'm still very much a novice at RouterOS, so I don't know if I really need to separate the outgoing and incoming. It works, that's all that matters.

Then I added a simple queue to limit the Dropbox-marked packets...

/queue simple
add comment="Bandwidth limit Dropbox" max-limit=5M/10M name=Dropbox \
    packet-marks=dropbox target=192.168.0.0/24

If there are any non-Dropbox websites that match the Dropbox address list, they'll be bw limited too, but that's not a problem for me.

Any suggestions for improvement?
Andrew Bernhardt

Who is online

Users browsing this forum: Google [Bot], SiB and 66 guests