Page 1 of 1

Routing issue between two LANs

Posted: Tue Jun 30, 2020 5:43 pm
by mookins
Hi,

I have a Groove A-52HPn r2. I have a wireless LAN which is the network 10.10.202.0/24 and on the Groove's ethernet side, a network 10.10.108.0/24. I can ping the internet just fine from the wlan1 interface, but not from the ether1 interface. I can't ping the wlan1 address from the ether1 address or vice versa. I am at a complete loss as to what else is missing from my configuration.

My config is as followings:
[admin@machine03] > /export hide-sensitive
# jul/01/2020 00:24:30 by RouterOS 6.47
# software id = 1FUJ-3ATQ
#
# model = Groove A-52HPn r2
# serial number = 6F0506E194C4
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n disabled=no frequency=2412 installation=outdoor ssid=ib-factory
/interface list
add name=WAN
add name=LAN
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk eap-methods="" mode=dynamic-keys supplicant-identity=MikroTik
/ip settings
set accept-source-route=yes
/interface list member
add interface=wlan1 list=WAN
add interface=ether1 list=LAN
/ip address
add address=10.10.202.108/24 interface=wlan1 network=10.10.202.0
add address=10.10.108.1/24 interface=ether1 network=10.10.108.0
/ip dhcp-client
add comment=defconf disabled=no
/ip dns
set servers=10.10.10.10,10.10.10.11
/ip firewall filter
add action=accept chain=forward
/ip route
add distance=1 gateway=10.10.202.1
/system clock
set time-zone-name=Australia/Melbourne
/system identity
set name=machine03
/system ntp client
set enabled=yes primary-ntp=10.10.10.10 secondary-ntp=10.10.10.11
Ping results
[admin@machine03] > ping 10.10.202.1 interface=wlan1
  SEQ HOST                                     SIZE TTL TIME  STATUS
    0 10.10.202.1                                56 255 4ms
    1 10.10.202.1                                56 255 6ms
    2 10.10.202.1                                56 255 4ms
    sent=3 received=3 packet-loss=0% min-rtt=4ms avg-rtt=4ms max-rtt=6ms

[admin@machine03] > ping 1.1.1.1 interface=wlan1
  SEQ HOST                                     SIZE TTL TIME  STATUS
    0 1.1.1.1                                    56  60 2ms
    1 1.1.1.1                                    56  60 2ms
    2 1.1.1.1                                    56  60 2ms
    sent=3 received=3 packet-loss=0% min-rtt=2ms avg-rtt=2ms max-rtt=2ms

[admin@machine03] > ping 10.10.108.1 interface=wlan1
  SEQ HOST                                     SIZE TTL TIME  STATUS
    0 10.10.108.1                                             timeout
    1 10.10.108.1                                             timeout
    2 10.10.108.1                                             timeout
    sent=3 received=0 packet-loss=100%

[admin@machine03] > ping 10.10.202.108 interface=ether1
  SEQ HOST                                     SIZE TTL TIME  STATUS
    0 10.10.202.108                                           timeout
    1 10.10.202.108                                           timeout
    2 10.10.108.1                                84  64 989ms host unreachable
    sent=3 received=0 packet-loss=100%

[admin@machine03] > ping 10.10.202.1 interface=ether1
  SEQ HOST                                     SIZE TTL TIME  STATUS
    0 10.10.202.1                                             timeout
    1 10.10.202.1                                             timeout
    2 10.10.108.1                                84  64 977ms host unreachable
    sent=3 received=0 packet-loss=100%

[admin@machine03] > ping 1.1.1.1 interface=ether1
  SEQ HOST                                     SIZE TTL TIME  STATUS
    0 1.1.1.1                                                 timeout
    1 1.1.1.1                                                 timeout
    2 10.10.108.1                                84  64 978ms host unreachable
    sent=3 received=0 packet-loss=100%
And lastly, my IP settings
[admin@machine03] > /ip settings print
              ip-forward: yes
          send-redirects: yes
     accept-source-route: yes
        accept-redirects: no
        secure-redirects: yes
               rp-filter: no
          tcp-syncookies: no
    max-neighbor-entries: 8192
             arp-timeout: 30s
         icmp-rate-limit: 10
          icmp-rate-mask: 0x1818
             route-cache: yes
         allow-fast-path: yes
   ipv4-fast-path-active: no
  ipv4-fast-path-packets: 0
    ipv4-fast-path-bytes: 0
   ipv4-fasttrack-active: no
  ipv4-fasttrack-packets: 0
    ipv4-fasttrack-bytes: 0
As far as I am aware the firewall is essentially IP tables and doesn't require any rules to perform routing.

Any ideas would be greatly appreciated because I am stumped.

Re: Routing issue between two LANs

Posted: Wed Jul 01, 2020 1:26 am
by Sob
I think you don't understand what ping's interface parameter does. It's where it will send packets, so if you're trying to ping e.g. 10.10.108.1 on wlan1, it can't succeed, because it's not there. Your whole testing doesn't make much sense.

Is it perhaps that you can't ping anything(*) except 10.10.108.x from devices connected to ether1? That would be possible. Depending on what "anything" would be (if it includes 10.10.202.108 or not), it could be missing default gateway on those devices, or missing srcnat rule on this router.