Page 1 of 1

nstreme requirements

Posted: Sat Dec 18, 2004 5:52 am
by cybertime
Are there any particular requirements for nstreme?

We were trying to set up a p2p link as a transparent bridge. First time doing it with MT rather than some off the shelf bridge.

I wanted to get a RB/3F1 and ordered through Wind Wireless. But they do not carry the RB/3F1, and on the phone said I would just have to order the parts separately through their site.

So I bought a pair of RB/3D1, and 5G/AGP off their site. Then, when I got the routers, I upgraded the license for wireless support, and installed the cards.

This means each unit is a RouterBOARD 230, 64 MB SODIMM, 64MB flash, and a 802.11a+b+g 60 mW Wireless MiniPCI Card with the Atheros 5211A chip.

I can configure the wireless up as an AP, client, etc. but there is no nstreme tab in winbox. I also tried through the serial port, and it ignores the nstreme commands.

Re: nstreme requirements

Posted: Sat Dec 18, 2004 10:11 am
by mag
which router os version?


Posted: Sun Dec 19, 2004 2:22 am
by cybertime
Came with 2.8.20, when I did not see it I tried 2.8.21.

Posted: Sun Dec 19, 2004 11:02 pm
by mag
Came with 2.8.20, when I did not see it I tried 2.8.21.
did you load by chance the wireless-legacy package or both wireless packages. for nstreme only wireles package has to be used.


Posted: Mon Dec 20, 2004 9:56 pm
by cybertime
It came with everything, so when I updated I loaded everything to make sure it all got updated. I then disabled many things that were not needed. I will see if the legacy is in there and running.

Posted: Tue Dec 21, 2004 1:19 pm
by [ASM]
try "/system reset" and start from the beggining

Posted: Mon Dec 27, 2004 10:58 pm
by cybertime
I did a system reset when I got them.

I am now down to the following packages:


All version 2.8.21

The following drivers are listed:

Atheros AR5211 PCI
NationalSemiconductors DP8381x

Just did another system reset to clear out all the bridging, etc that was on them. Enabled ether2, which I am hooked up to on the macine I am configuring it from, and assigned a fakenet IP. Went in with Winbox, enabled wlan1, pulled up the setting, and there is no nstreem config area.

So with that minimal of a package set, and a clean config, I still do not get nstreem.

Posted: Tue Dec 28, 2004 9:31 am
by normis
wrong wireless package probably. remove wireless and install `wireless.npk`, not `wireless-legacy`.

Posted: Wed Dec 29, 2004 1:01 am
by cybertime
It is wireless, not wireless-legacy.

Posted: Wed Dec 29, 2004 2:50 am
by cybertime
Since 2.8.22 came out yesterday, I upgraded to that.

All nstreme options now show up properly.

Posted: Wed Dec 29, 2004 10:24 am
by mag
It is wireless, not wireless-legacy.
after installation "wireless-legacy" and "wireless" both are showing up as "wireless". only the nstreme and some other features are not available in the winbox with wireless-legacy.

Posted: Thu Dec 30, 2004 12:45 pm
by cybertime
In previous versions I have seen both wireless and wireless-legacy seperatly. If the latest versions change the name of wireless-legacy, it is something I am not aware of.

When I cut down the packages, and did upgrades, and re-installs as part of all this, I installed just the small set listed above.

If legacy was in there somewhere, it hid itself.

When I installed the 2.8.22, again only the small set listed above, it worked fine.

Posted: Thu Dec 30, 2004 1:14 pm
by normis
you can't see the difference just like that. in the package list they both show up as `wireless`. only the build date changes. you can't have them both at the same time, and also as i said - the legacy is an old package with no new features.

however this doesn't matter as you say it's working fine now :)

Posted: Sat Jan 01, 2005 2:30 am
by cybertime
In older units, I have had them both in at the same time. However, that was a Soekris board running the trial licence without any wireless cards in it.