Community discussions

MikroTik App
 
hrz
just joined
Topic Author
Posts: 15
Joined: Fri May 25, 2007 12:38 pm

Shaping Problems

Thu Jun 14, 2007 1:08 pm

Hi there...

Currently i'm using MT box on a Pentium 4 2.4 Ghz with 768Mb Dual Channel DDR RAM.
The MT Box is used for bridging between my clients and my uplink network, therefore i can setup a bandwidth shaper(limiter).
I'm using PCQ method as same as http://wiki.mikrotik.com/wiki/PCQ_Examples described.
This is my mangle setup for each client :
-------------------------------------------------------------------------
/ip firewall mangle add chain=prerouting src-address=xxx.xxx.xxx.xxx in-interface=to-lan (interface that connect to my clients) action=mark-connection new-connection-mark=user1-link passthrough=yes

/ip firewall mangle add chain=forward connection-mark=user1-link action=mark-packet new-packet-mark=user1 passthrough=no
-------------------------------------------------------------------------
Then setup the queue tree with PCQ method. It's work, but sometimes (very rarely, maybe once a month), packet mangle only works on marking connection, but the packet marking doesnt work, it makes the queue fail (am i right?). I tried to reboot the MT box, but the problems still occur, but when i moved the client mangle rules above another rules, it works... but sometimes another clients mangle rules become fail, then i moved again and find perfect mangle rules order, then it all works normally.
Currently i'm managing 40 ip's (clilents).

Why this happened? Does rules order is affecting the packet mangle? because i'm mangling based on IP Address, it doesnt matter if i placed that rules above or below another rules, am i right?

Thx for helping :D
 
galaxynet
Long time Member
Long time Member
Posts: 648
Joined: Fri Dec 17, 2004 2:52 pm
Contact:

Re: Shaping Problems

Thu Jun 14, 2007 3:29 pm

Hrz -
Well, what you describe doesn't sound quite like it can happen the way you have put things in.....

That being said - you must have put new rules in during the month period or changed some of the rules during that time - perhaps you have some dynamic rules being added?

Basically mangle works on the first rule that matches the conditions you set in the rule and additionaly depending on the passthrough being yes/no additional rules can be applied.... If the packet/connection doesn't match any rule - well you know what happens then....



Perhaps if you posted all the rules we could help you more.

Thom
 
hrz
just joined
Topic Author
Posts: 15
Joined: Fri May 25, 2007 12:38 pm

Re: Shaping Problems

Thu Jun 14, 2007 10:06 pm

Hrz -
Well, what you describe doesn't sound quite like it can happen the way you have put things in.....

That being said - you must have put new rules in during the month period or changed some of the rules during that time - perhaps you have some dynamic rules being added?

Basically mangle works on the first rule that matches the conditions you set in the rule and additionaly depending on the passthrough being yes/no additional rules can be applied.... If the packet/connection doesn't match any rule - well you know what happens then....



Perhaps if you posted all the rules we could help you more.

Thom
Thx Thom...
perhaps you have some dynamic rules being added? ==> nope, i dont have dynamic rules...
the only problems when this "strange" conditions occur is, connection marking works successfully (the counter starts) but the packet mark doesn't works (the counter didn't starts), so the client doesn't get the granted bandwidth (because bandwidth limiter are based on packet mark) and this is only happen for 1 or 2 clients, the others are works normally. When i change the order, all IP's are mangled correctly, and i just can hope that the "strange" conditions doesn't happen again :) Once again, this is very very rarely... for the past 2 months, i only get it twice, and this is happen not to specific clients (ip's)

and all i have to do is monitoring the packet mark, if the connection mark is counting, but the packet mark isn't, maybe that "strange" conditions occur, call the IP holder, ask if he/she is using my services and get the granted bandwidth or not... :)

i thought this is not major problems, since my job desc is monitoring the networks.. :D but maybe a technical answers would be pleased my bozz...
Thx...

Who is online

Users browsing this forum: Google [Bot] and 57 guests