I've been running Mikrotik gear for a while, but with the new switch we have for the office, I'm trying to make sure I do things "properly". I'm attempting to follow the wiki, specifically, https://wiki.mikrotik.com/wiki/Manual:I ... figuration.
The switch I'm working with is the CRS354-48G-4S+2Q+, so where relevant I'm following the CRS3XXX pages.
My current configuration is using a bridge, and setting the IP address directly on the bridge, then ensuring the pvid of the bridge is 88, as this is the only VLAN I require management access from.
This seems to be in conflict with the wiki page which suggests that I should create a new VLAN interface in Interfaces -> VLAN, and assign the IP address of the switch to that. When I attempt to follow this as in the wiki, the switch doesn't respond to ARP on this new address. I have attempted assigning two IPs (one on bridge1, one on the vlan88 interface I created), and the old approach keeps working while the new one does not.
My questions are:
a) Is the current approach I'm using appropriate? Should I change it? I haven't noticed any problems with it as of yet, but I'd rather do this the right way than have headaches later
b) If I should not be using this approach, why would the instructions on the wiki under that section not work? From my current configuration, running the instructions from the wiki result in my switch no longer responding (or not responding on the new address):
Code: Select all
/interface vlan add interface=bridge1 name=MGMT vlan-id=88
/ip address add address=192.168.88.10/24 interface=MGMT
/interface bridge set bridge1 vlan-filtering=yes
If it helps, here is an excerpt of my current configuration (it's 48 ports, so I've stripped it down to a few example ports that should be relevant):
Code: Select all
# model = CRS354-48G-4S+2Q+
/interface bridge
add admin-mac=C4:AD:34:9A:E8:CC auto-mac=no comment=defconf name=bridge1 pvid=88 vlan-filtering=yes
/interface bridge port
# access ports for workstations
add bridge=bridge1 comment=defconf interface=ether30 pvid=88
add bridge=bridge1 comment=defconf interface=ether31 pvid=88
# trunk port
add bridge=bridge1 hw=no interface=ether48 pvid=88
/interface bridge vlan
add bridge=bridge1 tagged=ether48 untagged=ether30,ether31 vlan-ids=88
/ip address
add address=192.168.88.9/24 comment=defconf interface=bridge1 network=192.168.88.0
/ip route
add distance=1 gateway=192.168.88.1