Community discussions

MikroTik App
 
User avatar
Davis
Member Candidate
Member Candidate
Topic Author
Posts: 111
Joined: Mon Aug 01, 2011 12:27 pm
Location: Latvia, Riga
Contact:

Unexpected behavior of check-gateway in /ip route

Tue Oct 20, 2020 12:50 am

I have recently noticed unexpected behavior of check-gateway in /ip route - looks like setting it for one entry automatically enables it for other entries with the same gateway.
E.g. in this configuration:
/ip route
add distance=1 dst-address=1.0.0.1/32 gateway=192.168.1.1
add check-gateway=ping distance=1 dst-address=1.1.1.1/32 gateway=192.168.1.1
when 192.168.1.1 stops responding to ping, both routes become inactive.

Is this expected, but undocumented behavior? Or is this a bug?
 
User avatar
Davis
Member Candidate
Member Candidate
Topic Author
Posts: 111
Joined: Mon Aug 01, 2011 12:27 pm
Location: Latvia, Riga
Contact:

Re: Unexpected behavior of check-gateway in /ip route

Fri Nov 20, 2020 7:57 am

Asked this question to MikroTik support and got this answer:
This is expected behavior. Check gateway is per nexthop not per route. You can see status and what check gateway option is enabled for particular nexthop in /ip route nexthop menu.

Who is online

Users browsing this forum: Baidu [Spider], dubuscyr, henrik27 and 180 guests