Page 1 of 1

Unexpected behavior of check-gateway in /ip route

Posted: Tue Oct 20, 2020 12:50 am
by Davis
I have recently noticed unexpected behavior of check-gateway in /ip route - looks like setting it for one entry automatically enables it for other entries with the same gateway.
E.g. in this configuration:
/ip route
add distance=1 dst-address=1.0.0.1/32 gateway=192.168.1.1
add check-gateway=ping distance=1 dst-address=1.1.1.1/32 gateway=192.168.1.1
when 192.168.1.1 stops responding to ping, both routes become inactive.

Is this expected, but undocumented behavior? Or is this a bug?

Re: Unexpected behavior of check-gateway in /ip route

Posted: Fri Nov 20, 2020 7:57 am
by Davis
Asked this question to MikroTik support and got this answer:
This is expected behavior. Check gateway is per nexthop not per route. You can see status and what check gateway option is enabled for particular nexthop in /ip route nexthop menu.