Community discussions

MikroTik App
 
serafin
just joined
Topic Author
Posts: 23
Joined: Mon Nov 14, 2011 9:07 pm

CRS125 & managemenent interface in tagged vlan

Sun Nov 01, 2020 7:19 pm

Hi,

I have CRS125-24G-1S device and can't reach it via IP address from one of the tagged VLANs received via trunk port. Let me describe my config - maybe somebody can spot where I made an error

I have bridge defined as in all examples in the wiki:
/interface bridge
add name=bridge1 protocol-mode=none
All ports are added to the bridge:
/interface bridge port
add bridge=bridge1 interface=ether1
...
add bridge=bridge1 interface=ether24
Uplink is configured via trunked ports:
/interface ethernet switch trunk
add member-ports=ether23,ether24 name=trunk1
And management interface is defined as vlan:
/interface vlan
add interface=bridge1 name=vlan-mgnt vlan-id=10


Now the mysterious switch chip config...

VLAN definition:
/interface ethernet switch vlan
add ports=trunk1,ether3,ether4,switch1-cpu vlan-id=10
Access port definition:
/interface ethernet switch ingress-vlan-translation
add customer-vid=0 new-customer-vid=10 ports=ether3,ether4
And where the tagged frames are send:
/interface ethernet switch egress-vlan-tag
add tagged-ports=trunk1 vlan-id=10


I can reach devices from VLAN 10 connected to ports ether3 & ether4 from other devices from my network, but not the CRS125 device itself (via address assigned to vlan-mgnt interface).

Maybe somebody can see the issue in my config?

Ser@fin
 
sid5632
Member
Member
Posts: 450
Joined: Fri Feb 17, 2017 6:05 pm

Re: CRS125 & managemenent interface in tagged vlan

Sun Nov 01, 2020 11:49 pm

You need the egress to include the switch1-cpu port as tagged:
/interface ethernet switch egress-vlan-tag add tagged-ports=trunk1,switch1-cpu vlan-id=10

I'm not sure whether having ether23 and ether24 as bridge ports is right or not. It feels wrong and you might consider removing them and adding trunk1 instead.
 
serafin
just joined
Topic Author
Posts: 23
Joined: Mon Nov 14, 2011 9:07 pm

Re: CRS125 & managemenent interface in tagged vlan

Mon Nov 02, 2020 11:50 pm

Bingo! - adding switch-cpu in egress-vlan-tag rule solves the probelm.

with trunk & adding ports to the bridge - this is CRS125, here ports have to be in the bridge to trunk them...

Who is online

Users browsing this forum: didomir, huntermic and 174 guests