Community discussions

MikroTik App
 
nikhil
Member Candidate
Member Candidate
Topic Author
Posts: 262
Joined: Wed Dec 22, 2004 5:04 pm
Location: US

SNMP not working

Thu Dec 23, 2004 4:31 pm

Using 2.8.18
SNMP does not work ! doing an nmap from a machine behind the router shows its filtered below are the details. And I am using xxxxxxxx as the community name via snmpwalk and snmpget .

[admin@gatekeeper1] > snmp print
enabled: yes

[admin@gatekeeper1] > snmp comm print
# NAME ADDRESS READ-ACCESS
0 public 0.0.0.0/0 no
1 xxxxxxxx 0.0.0.0/0 yes

Any help would be appreciated.
Thanks
 
viktorija
just joined
Posts: 24
Joined: Fri May 28, 2004 4:05 pm

Re: SNMP not working

Thu Dec 23, 2004 4:48 pm

Probably you have level 3 and wireless installed. So remove wireless package and SNMP will work

Using 2.8.18
SNMP does not work ! doing an nmap from a machine behind the router shows its filtered below are the details. And I am using xxxxxxxx as the community name via snmpwalk and snmpget .

[admin@gatekeeper1] > snmp print
enabled: yes

[admin@gatekeeper1] > snmp comm print
# NAME ADDRESS READ-ACCESS
0 public 0.0.0.0/0 no
1 xxxxxxxx 0.0.0.0/0 yes

Any help would be appreciated.
Thanks
 
nikhil
Member Candidate
Member Candidate
Topic Author
Posts: 262
Joined: Wed Dec 22, 2004 5:04 pm
Location: US

Thu Dec 23, 2004 4:58 pm

Level3 but wireless is not installed
The packages installed are
# NAME VERSION BUILD-TIME UNINSTALL
0 system 2.8.18 oct/19/2004 11:15:40 no
1 advanced-tools 2.8.18 oct/15/2004 13:45:39 no
2 gps 2.8.18 oct/15/2004 14:42:27 no
3 lcd 2.8.18 oct/15/2004 14:40:16 no
4 ntp 2.8.18 oct/15/2004 14:39:43 no
5 routing 2.8.18 oct/15/2004 13:58:26 no
6 security 2.8.18 oct/15/2004 13:48:45 no

Whats missing OR what needs to be added?
 
viktorija
just joined
Posts: 24
Joined: Fri May 28, 2004 4:05 pm

Fri Dec 24, 2004 11:10 am

then upgrade router to the latest version it should help

Level3 but wireless is not installed
The packages installed are
# NAME VERSION BUILD-TIME UNINSTALL
0 system 2.8.18 oct/19/2004 11:15:40 no
1 advanced-tools 2.8.18 oct/15/2004 13:45:39 no
2 gps 2.8.18 oct/15/2004 14:42:27 no
3 lcd 2.8.18 oct/15/2004 14:40:16 no
4 ntp 2.8.18 oct/15/2004 14:39:43 no
5 routing 2.8.18 oct/15/2004 13:58:26 no
6 security 2.8.18 oct/15/2004 13:48:45 no

Whats missing OR what needs to be added?
 
nikhil
Member Candidate
Member Candidate
Topic Author
Posts: 262
Joined: Wed Dec 22, 2004 5:04 pm
Location: US

still no luck

Sat Dec 25, 2004 8:25 am

Upgraded NO LUCK

snmpwalk -v 1 -c public xxx.xxx.xxx.xxx
Timeout: No Response from xxx.xxx.xxx.xxx

[admin@xxxxxxxx] > snmp print
enabled: yes

snmp> community print
# NAME ADDRESS READ-ACCESS
0 public 0.0.0.0/0 yes

here are the packages
# NAME VERSION BUILD-TIME UNINSTALL
0 system 2.8.21 dec/07/2004 15:02:01 no
1 advanced-tools 2.8.21 dec/07/2004 15:03:29 no
2 gps 2.8.21 dec/07/2004 15:59:11 no
3 dhcp 2.8.21 dec/07/2004 15:07:55 no
4 ppp 2.8.21 dec/07/2004 15:13:57 no
5 lcd 2.8.21 dec/07/2004 15:57:06 no
6 ntp 2.8.21 dec/07/2004 15:56:33 no
7 routing 2.8.21 dec/07/2004 15:16:10 no
8 security 2.8.21 dec/07/2004 15:06:33 no

nmap shows
Port State Service
21/tcp open ftp
22/tcp open ssh
23/tcp open telnet
80/tcp open http
2000/tcp open callbook
2602/tcp open ripd
2604/tcp open ospfd
3986/tcp open mapper-ws_ethd

WHAT COULD BE WRONG ?
 
viktorija
just joined
Posts: 24
Joined: Fri May 28, 2004 4:05 pm

Re: still no luck

Mon Dec 27, 2004 8:09 am

make supout file from router and send it to support@mikrotik.com
Upgraded NO LUCK

snmpwalk -v 1 -c public xxx.xxx.xxx.xxx
Timeout: No Response from xxx.xxx.xxx.xxx

[admin@xxxxxxxx] > snmp print
enabled: yes

snmp> community print
# NAME ADDRESS READ-ACCESS
0 public 0.0.0.0/0 yes

here are the packages
# NAME VERSION BUILD-TIME UNINSTALL
0 system 2.8.21 dec/07/2004 15:02:01 no
1 advanced-tools 2.8.21 dec/07/2004 15:03:29 no
2 gps 2.8.21 dec/07/2004 15:59:11 no
3 dhcp 2.8.21 dec/07/2004 15:07:55 no
4 ppp 2.8.21 dec/07/2004 15:13:57 no
5 lcd 2.8.21 dec/07/2004 15:57:06 no
6 ntp 2.8.21 dec/07/2004 15:56:33 no
7 routing 2.8.21 dec/07/2004 15:16:10 no
8 security 2.8.21 dec/07/2004 15:06:33 no

nmap shows
Port State Service
21/tcp open ftp
22/tcp open ssh
23/tcp open telnet
80/tcp open http
2000/tcp open callbook
2602/tcp open ripd
2604/tcp open ospfd
3986/tcp open mapper-ws_ethd

WHAT COULD BE WRONG ?
 
sorinbuda
newbie
Posts: 29
Joined: Sun Nov 14, 2004 6:27 am

I had the same problem

Tue Dec 28, 2004 2:06 am

Try this example:

to listern the SMNP from 192.168.xxx.xxx workstation which is connected to the router via the 192.168.xxx.xxx gateway
insert the gateway IP in the router SMNP setup and make sure to enable the SMNP from settings

Make sure you insert the correct mask number as well.

That should work,
Success
 
jarosoup
Long time Member
Long time Member
Posts: 600
Joined: Sun Aug 22, 2004 9:02 am

Tue Dec 28, 2004 9:34 pm

Are you sure your firewall rules aren't blocking the SNMP requests to UDP port 161?
 
nikhil
Member Candidate
Member Candidate
Topic Author
Posts: 262
Joined: Wed Dec 22, 2004 5:04 pm
Location: US

got it working

Wed Dec 29, 2004 2:15 am

Was a udp issue. Got it working. Thanks guys ! MT rocks.
 
cheinzle
newbie
Posts: 36
Joined: Thu Oct 28, 2004 7:06 pm
Location: Nebraska

Wed Dec 29, 2004 10:51 pm

what was your solution? Im having the same problems
 
nikhil
Member Candidate
Member Candidate
Topic Author
Posts: 262
Joined: Wed Dec 22, 2004 5:04 pm
Location: US

CHECK UDP

Thu Dec 30, 2004 6:21 am

Check there is nothing in between your machine and the router blocking of udp ports 161,162 . open everything and try. And take of wireless it will enable snmp
 
cheinzle
newbie
Posts: 36
Joined: Thu Oct 28, 2004 7:06 pm
Location: Nebraska

Thu Dec 30, 2004 3:17 pm

yeah, that doesnt seem to be a problem in my case. the mrtg server is connected directly to the MikroTik, with nothing in between. No Firewall rules that I can see that would be blocking, and I put in a passthrough statement for input and output to log SNMP traffic: traffic comes in but doesnt leave. Instead ICMP reply is sent (type 5 code 1; Redirect Datagram for the Host).

weird wild stuff

Who is online

Users browsing this forum: No registered users and 98 guests