Community discussions

MikroTik App
 
User avatar
Wolfraider
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 88
Joined: Wed Jul 15, 2015 8:06 pm

Slow Downloads

Mon Nov 16, 2020 7:48 pm

We have been having an ongoing issue with slow downloads on our Mikrotik routers. This does not seem to happen with our Cisco or Ubiquiti routers. We have simple queues setup to limit bandwidth to typically 100M/100M. Download rates are around 20M while the uploads are around 95M. CPU is between 2 and 35% utilization. We will have anywhere between 50 and 700 simple queues created. 1 per VLAN. The routers are a mixture of RB4011, CCR1009 and CCR2004. Firmware is 6.46.8 or 6.47.7 with a few older ones thrown in that I haven't had time to upgrade yet.
/interface ethernet
set [ find default-name=combo1 ] l2mtu=2024 mtu=2000
/interface vlan
add interface=ether1 name=A101 vlan-id=1101
add interface=ether1 name=A102 vlan-id=1102
add interface=ether1 name=A103 vlan-id=1103
add interface=ether1 name=A104 vlan-id=1104
add interface=ether1 name=A105 vlan-id=1105
add comment=Core1 interface=combo1 mtu=2000 name=vlan3172 vlan-id=3172
add comment=Core2 interface=combo1 mtu=2000 name=vlan3372 vlan-id=3372
/ip pool
add name=dhcp_pool_1201 ranges=100.101.1.20-100.101.1.254
add name=dhcp_pool_1202 ranges=100.101.2.20-100.101.2.254
add name=dhcp_pool_1203 ranges=100.101.3.20-100.101.3.254
add name=dhcp_pool_1204 ranges=100.101.4.20-100.101.4.254
add name=dhcp_pool_1205 ranges=100.101.5.20-100.101.5.254
/ip dhcp-server
add address-pool=dhcp_pool_1201 authoritative=after-2sec-delay disabled=no interface=B101 name=dhcp_1201
add address-pool=dhcp_pool_1202 authoritative=after-2sec-delay disabled=no interface=B102 name=dhcp_1202
add address-pool=dhcp_pool_1203 authoritative=after-2sec-delay disabled=no interface=B103 name=dhcp_1203
add address-pool=dhcp_pool_1204 authoritative=after-2sec-delay disabled=no interface=B104 name=dhcp_1204
add address-pool=dhcp_pool_1205 authoritative=after-2sec-delay disabled=no interface=B105 name=dhcp_1205
/ppp profile
add dns-server=xx.xx.253.138,xx.xx.2.3 local-address=xx.xx.0.57 name=ppp
/routing bgp instance
set default as=xxxx router-id=100.78.0.66
/routing ospf instance
set [ find default=yes ] router-id=100.78.0.66
/interface pppoe-server server
add default-profile=ppp disabled=no interface=A101 one-session-per-host=yes service-name=A101
add default-profile=ppp disabled=no interface=A102 one-session-per-host=yes service-name=A102
add default-profile=ppp disabled=no interface=A103 one-session-per-host=yes service-name=A103
add default-profile=ppp disabled=no interface=A104 one-session-per-host=yes service-name=A104
add default-profile=ppp disabled=no interface=A105 one-session-per-host=yes service-name=A105
/ip address
add address=100.101.1.1/24 interface=A101 network=100.101.1.0
add address=100.101.2.1/24 interface=A102 network=100.101.2.0
add address=100.101.3.1/24 interface=A103 network=100.101.3.0
add address=100.101.4.1/24 interface=A104 network=100.101.4.0
add address=100.101.5.1/24 interface=A105 network=100.101.5.0
add address=xx.xx.156.239 interface=LoopBack network=xx.xx.156.239
add address=100.78.0.66 interface=LoopBack network=100.78.0.66
add address=100.76.1.33/30 interface=vlan3172 network=100.76.1.32
add address=100.77.1.33/30 interface=vlan3372 network=100.77.1.32
/ip dhcp-server network
add address=100.101.1.0/24 dns-server=xx.xx.253.138,xx.xx.2.3 gateway=100.1.1.1
add address=100.101.2.0/24 dns-server=xx.xx.253.138,xx.xx.2.3 gateway=100.1.2.1
add address=100.101.3.0/24 dns-server=xx.xx.253.138,xx.xx.2.3 gateway=100.1.3.1
add address=100.101.4.0/24 dns-server=xx.xx.253.138,xx.xx.2.3 gateway=100.1.4.1
add address=100.101.5.0/24 dns-server=xx.xx.253.138,xx.xx.2.3 gateway=100.1.5.1
/ip firewall nat
add action=src-nat chain=srcnat src-address=100.101.1.0/24 to-addresses=xx.xx.156.239
add action=src-nat chain=srcnat src-address=100.101.2.0/24 to-addresses=xx.xx.156.239
add action=src-nat chain=srcnat src-address=100.101.3.0/24 to-addresses=xx.xx.156.239
add action=src-nat chain=srcnat src-address=100.101.4.0/24 to-addresses=xx.xx.156.239
add action=src-nat chain=srcnat src-address=100.101.5.0/24 to-addresses=xx.xx.156.239
/ip firewall service-port
set h323 disabled=yes
set sip disabled=yes
/ip service
set telnet disabled=yes
set ftp disabled=yes
set www disabled=yes
set ssh address=xx.xx.101.0/24
set api disabled=yes
set winbox address=xx.xx.101.0/24
set api-ssl disabled=yes
/ip ssh
set allow-none-crypto=yes forwarding-enabled=remote
/ppp aaa
set use-radius=yes
/radius
add address=xx.xx.128.139 secret=xxxxx service=ppp src-address=100.78.0.66
/routing bgp network
add network=xx.xx.156.239/32 synchronize=no
/routing bgp peer
add instance=default name=Core1 remote-address=100.78.0.1 remote-as=xxxx ttl=default update-source=100.78.0.66
add instance=default name=Core2 remote-address=100.78.0.2 remote-as=xxxx ttl=default update-source=100.78.0.66
/routing ospf interface
add network-type=broadcast passive=yes
add interface=vlan3172 network-type=point-to-point
add interface=vlan3372 network-type=point-to-point
/routing ospf network
add area=backbone network=100.78.0.66/32
add area=backbone network=100.76.1.32/30
add area=backbone network=100.77.1.32/30
/system clock
set time-zone-name=America/Chicago
/system ntp client
set enabled=yes primary-ntp=xx.xx.253.155
 
 
User avatar
Wolfraider
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 88
Joined: Wed Jul 15, 2015 8:06 pm

Re: Slow Downloads

Tue Nov 17, 2020 8:09 pm

Doing more testing, We see the issue on a CCR1009 and a RB4011. The RB4011 has 1 queue defined and the network we are testing from doesnt even use the queue. I dont believe this is a queue issue. We can't use fasttrack because of needing to throttle. No firewall rules or anything. Just simple NAT. Oh and no interface errors and flow control is turned off. Gotta be something simple though.
 
User avatar
Wolfraider
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 88
Joined: Wed Jul 15, 2015 8:06 pm

Re: Slow Downloads

Wed Nov 18, 2020 4:58 pm

Found an interesting piece of information. While running iPerf tests, the download will time out during the last half of the test which drops the whole speed test. Almost like a queue or something is filling up. The weird part is we see the same issue on locations that dont run any queues.

Who is online

Users browsing this forum: Ahrefs [Bot], neitro and 131 guests