Community discussions

MikroTik App
 
MaxKrok72
just joined
Topic Author
Posts: 5
Joined: Sun Nov 29, 2020 12:42 am

Why high latency for lte interface ping?

Sun Nov 29, 2020 12:47 am

I have installed USB LTE modem. The lte1 interface was dynamically created. The modem inner ip address is 192.168.8.1
I have 20-50ms latency while pinging this IP when latency for the router where the modem is installed itself is always 1ms.
Why such a severe latency?
 
User avatar
SiB
Forum Guru
Forum Guru
Posts: 1314
Joined: Sun Jan 06, 2013 11:19 pm
Location: Poland

Re: Why high latency for lte interface ping?

Fri Dec 04, 2020 12:56 pm

check traceroute, maybe you ping some other 192.168.8.1...
But be serious, USB devices connected to you should have 1ms latency, if not then try reboot it, change LAN ip inside that USB LTE device etc.
This is first info about it.

Show system resources usb print , to detect what that USB LTE device is.
MTCNA + MTCRE + MTCINE | ~600 users at ~150 RouterBoards in EMEA | Telegram: @SiB_PL
WinBox Tip: F6 works as ALT+TAB | Gliffy.com - free network schematic | prnt.sc - free ScreenShot software
I back from vacation and try answer at LTE posts
 
MaxKrok72
just joined
Topic Author
Posts: 5
Joined: Sun Nov 29, 2020 12:42 am

Re: Why high latency for lte interface ping?

Fri Dec 04, 2020 1:05 pm

Herein is the sreen with usb resources...
Image
Sorry 192.168.8.1 is the modem itself.
The LTE1 is 192.168.8.100.. The ping is 1ms
But the modem is 40-80ms... Even from the router... Why?
Image
 
User avatar
SiB
Forum Guru
Forum Guru
Posts: 1314
Joined: Sun Jan 06, 2013 11:19 pm
Location: Poland

Re: Why high latency for lte interface ping?

Fri Dec 04, 2020 1:20 pm

12d1 14db probably say about E3131, my works proper but I re-flashing it with some mode firmware... and use it as usb1 device with ppp-out1.
I not know that E3131 (or maybe you have other USB LTE unit ? ) support a Hi.Link and be exist as lte1 interface. It's new for me.

Strange but from user perspective you can only have latest RouterOS and create a supout.rif and send it to support.
support@mikrotik.com or https://mikrotik.com/support
MTCNA + MTCRE + MTCINE | ~600 users at ~150 RouterBoards in EMEA | Telegram: @SiB_PL
WinBox Tip: F6 works as ALT+TAB | Gliffy.com - free network schematic | prnt.sc - free ScreenShot software
I back from vacation and try answer at LTE posts
 
MaxKrok72
just joined
Topic Author
Posts: 5
Joined: Sun Nov 29, 2020 12:42 am

Re: Why high latency for lte interface ping?

Fri Dec 04, 2020 1:32 pm

Mine is E8372
How much ms ping you have to the modem?
Others?
 
User avatar
SiB
Forum Guru
Forum Guru
Posts: 1314
Joined: Sun Jan 06, 2013 11:19 pm
Location: Poland

Re: Why high latency for lte interface ping?

Fri Dec 04, 2020 1:36 pm

<1ms
MTCNA + MTCRE + MTCINE | ~600 users at ~150 RouterBoards in EMEA | Telegram: @SiB_PL
WinBox Tip: F6 works as ALT+TAB | Gliffy.com - free network schematic | prnt.sc - free ScreenShot software
I back from vacation and try answer at LTE posts
 
User avatar
Magalex
just joined
Posts: 4
Joined: Tue Nov 06, 2018 8:33 pm
Location: Saint-Petersburg, Russia

Re: Why high latency for lte interface ping?

Tue Dec 15, 2020 5:30 pm

Mine is E8372
How much ms ping you have to the modem?
Others?
Hello! I have E3372H-153 and also long pings to the modem itself. I don't know what the reason is, but I think that the matter may be that the modem's software is organized this way, which gives limited resources to processing icmp requests. Ping latency to a host does not mean that packets passing through it have the same latency. Maybe I'm soothing myself, yeah ) But it would be interesting to hear about the real reasons.
20 of 20 packets received	0 % packet loss	Min: 9 ms	Avg: 21 ms	Max: 31 ms
 
User avatar
SiB
Forum Guru
Forum Guru
Posts: 1314
Joined: Sun Jan 06, 2013 11:19 pm
Location: Poland

Re: Why high latency for lte interface ping?

Tue Dec 15, 2020 6:51 pm

tool traceroute mikrotik.com use-dns=no
should show you a AVG ms to your router and final target.

some host can
  • no answer
  • have limits at answering and generate fake packet loose but in next hop have 0% then you know that one is not trust
  • target can not answer at ping but you can know what is avg latency by prev hops.
Check below graphs.

Your USB modem or router (Hi.Link mode) should give you <1ms but big question is about what latency have next routers/hops ?

I like the Windows app who show you the avg and you can see who the latency inc from host to host... each next router give additional latency.
Image
Image
MTCNA + MTCRE + MTCINE | ~600 users at ~150 RouterBoards in EMEA | Telegram: @SiB_PL
WinBox Tip: F6 works as ALT+TAB | Gliffy.com - free network schematic | prnt.sc - free ScreenShot software
I back from vacation and try answer at LTE posts
 
MaxKrok72
just joined
Topic Author
Posts: 5
Joined: Sun Nov 29, 2020 12:42 am

Re: Why high latency for lte interface ping?

Tue Dec 15, 2020 7:31 pm

what is the fun to check some other hosts?
The proof that the modem has low icmp resourses is that the ping to the gate of mobile provider would be less then modem's ping.. but i do not have this type of picture...
So the conclusion is that modem slows the connection...
 
User avatar
SiB
Forum Guru
Forum Guru
Posts: 1314
Joined: Sun Jan 06, 2013 11:19 pm
Location: Poland

Re: Why high latency for lte interface ping?

Tue Dec 15, 2020 10:28 pm

Then connect your USB unit to PC and check latency.
Next if latency
* exist only at RouterBoard then write to support@mikrotik.com or https://mikrotik.com/support
* exist in PC too, then write to support of unit, seller, search other firmware
MTCNA + MTCRE + MTCINE | ~600 users at ~150 RouterBoards in EMEA | Telegram: @SiB_PL
WinBox Tip: F6 works as ALT+TAB | Gliffy.com - free network schematic | prnt.sc - free ScreenShot software
I back from vacation and try answer at LTE posts
 
MaxKrok72
just joined
Topic Author
Posts: 5
Joined: Sun Nov 29, 2020 12:42 am

Re: Why high latency for lte interface ping?

Tue Dec 15, 2020 10:38 pm

Then connect your USB unit to PC and check latency.
Next if latency
* exist only at RouterBoard then write to support@mikrotik.com or https://mikrotik.com/support
* exist in PC too, then write to support of unit, seller, search other firmware
already done... this type of hell is only on RB ... Mine is "hap lite ac"...
 
icsterm
newbie
Posts: 49
Joined: Sun Mar 11, 2018 11:11 pm

Re: Why high latency for lte interface ping?

Wed Jan 13, 2021 9:22 pm

Can confirm the same with my hap ac2 and an Huawei E8372h-155, the ping is non-sense if you ask me, the firmware is stock and the modem is detected as LTE interface.
Here is the ping to the modem's own IP while connected directly via USB:
usb modem.PNG

I think Mikrotik needs to improve this, it's too absurd !

The modem does support Hi-link.

So yes, it's something in the kernel of Mikrotik that needs improvement, I think the USB interface is flawed.

usb.PNG
Can someone please help with an workaround for this problem?
You do not have the required permissions to view the files attached to this post.
 
icsterm
newbie
Posts: 49
Joined: Sun Mar 11, 2018 11:11 pm

Re: Why high latency for lte interface ping?

Wed Jan 13, 2021 9:43 pm

Here is proof also while using traceroute with Pingplotter:

The USB modem is highlighted. There are no hubs or anything in-between.

The jitter is so insane I think it's something related to USB bus.
high latency.PNG
Willing to experiment with firmware hacks to improve latency, but I most likely need to visit russian websites, anyone can point me to some good tutorial to open a more direct interface with the modem?

The wiki points that LTE interface only is supported, but I'm sure it's not updated.

I can sometimes get 2 ms so this is clearly some firmware issue, I'm running latest stable 6.48.

With the same modem directly in my PC I can't reproduce this issue.
You do not have the required permissions to view the files attached to this post.

Who is online

Users browsing this forum: bandini981, Google [Bot], Kindis, n21roadie, rioven, ros44 and 209 guests