Page 1 of 1

PPPoE MTU Problem

Posted: Thu Jul 12, 2007 11:12 pm
by joie
About 2 months ago I was testing using a MiniRouter as a PPPoE client and either on the forum or in the wiki there was an entry for fixing the MTU issue where certain websites wouldn't open but after searching for a while now I can't find the post anymore, and I seem to have misplaced the printout's I made so I'd have it.

I tried ip firewall mangle add out-interface=pppoe-out protocol=tcp tcp-flags=syn action=change-mss new-mss=1300 chain=forward but that didn't work, the only thing I remember is the original mangle I had that worked was two seperate entries but I can't for the life of me remember what they were.

Any ideas?

Re: PPPoE MTU Problem

Posted: Wed Jul 25, 2007 2:50 am
by airstream
In winbox you can set the MTU of the PPPoE client.

Common MTU's are:

Re: PPPoE MTU Problem

Posted: Wed Jul 25, 2007 6:07 pm
by abab_rafiq
You can add a firewall mangle here with TCP-MSS of 1400, I got good result with it.
add chain=forward p2p=all-p2p action=jump jump-target=p2p