Community discussions

MikroTik App
 
EzraCaleb
just joined
Topic Author
Posts: 1
Joined: Sat Jan 02, 2021 9:44 am

Problem Hardware Offload on CRS326-24G-2S+?

Sat Jan 02, 2021 9:46 am

Hello,

I ran into trouble with HW offloading on CRS326-24G-2S+.

On interface "uplink" an CRS326-24S+2Q+ is connected by 802.1ad (2 * 10GbE), this interface works properly
with HW offload.

On interface "backup-src" a FreeBSD 12.1 server is connected with 802.1ad (2 * GE). This
connection does not HW offload and therefore there is a poor performance and high CPU load.
802.1ad config on FreeBSD is ok, at least it works with a Cisco Nexus 3000 used for reference.

Config on CRS326-24G-2S+
Code: Select all
# may/02/2020 12:01:18 by RouterOS 6.46.5
# software id = PUMZ-Z25Q
#
# model = CRS326-24G-2S+
# serial number = 94550BB498A4
/interface bridge
add name=bridge1 vlan-filtering=yes
add name=vlan2
/interface bridge port
add bridge=bridge1 interface=uplink
add bridge=vlan2 interface=VLAN2
add bridge=vlan2 interface=backup-srv
/interface bridge vlan
add bridge=bridge1 tagged=uplink,bridge1 untagged=vlan2 vlan-ids=2
/interface bonding
add lacp-rate=1sec mode=802.3ad name=backup-srv slaves=ether15,ether16
add lacp-rate=1sec mode=802.3ad name=uplink slaves=sfp-sfpplus1,sfp-sfpplus2

FreeBSD Interface Config
Code: Select all
ifconfig_em0="up"
ifconfig_em1="up"
cloned_interfaces="lagg0"
ifconfig_lagg0="laggproto lacp laggport em0 laggport em1 192.168.1.4/24"
defaultrouter="192.168.1.254"

I have no clue, what is wrong with this configuration.

Please give me a hint.

best regards
 
Kindis
Member
Member
Posts: 360
Joined: Tue Nov 01, 2011 6:54 pm
Location: Sweden

Re: Problem Hardware Offload on CRS326-24G-2S+?

Fri Jan 08, 2021 12:06 am

So you have 2 Bridges. One named Bridge and one named VLAN2. Hardware offload only works for one bridge. You have to move the config from VLAN to bridge to the Bridge named Bridge (This became confusing :)) to get this to work.
Then delete other Bridge

Read more here
https://wiki.mikrotik.com/wiki/Manual:C ... s_switches

Who is online

Users browsing this forum: Baidu [Spider], Bing [Bot] and 221 guests