Community discussions

MikroTik App
 
RcRaCk2k
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 53
Joined: Mon May 07, 2012 10:40 pm

IPIP Tunnel and inner IPv6 not working

Thu Jan 07, 2021 9:19 pm

Hi Guys,

why is IPv6 in an IPIP tunnel not working?

I have a IPIP Tunnel Interface and have added an IPv6-Address to that interface.
But both ends can not see each other?!?

IPv4 works.

Is there some missconfiguration or is mikrotik not capable in encapsulate IPv6 in IPIP-Tunnels?
 
mkx
Forum Guru
Forum Guru
Posts: 5246
Joined: Thu Mar 03, 2016 10:23 pm

Re: IPIP Tunnel and inner IPv6 not working

Thu Jan 07, 2021 9:40 pm

You need ipip6 tunnel.
BR,
Metod
 
RcRaCk2k
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 53
Joined: Mon May 07, 2012 10:40 pm

Re: IPIP Tunnel and inner IPv6 not working

Fri Jan 08, 2021 8:27 pm

Thats very bad, because there is no PBR support for IPv6 in ROSv6.xx.

I will try to get my hands on the v7 BETA... Hope that my current setup will work in v7 current development state ;-)
 
nescafe2002
Forum Veteran
Forum Veteran
Posts: 728
Joined: Tue Aug 11, 2015 12:46 pm
Location: Netherlands

Re: IPIP Tunnel and inner IPv6 not working

Fri Jan 08, 2021 10:04 pm

You can use 6to4 (6in4) to tunnel ipv6 traffic over ipv4.

/interface 6to4
add !keepalive name=6to4-branch remote-address=branch.tld
/ipv6 route
add distance=1 dst-address=2001:db8:10:10::/64 gateway=6to4-branch
/interface list member
add interface=6to4-branch list=LAN


/interface 6to4
add !keepalive name=6to4-hq remote-address=hq.tld
/ipv6 address
add address=2001:db8:10:10::1/64 interface=bridgeLocal
/ipv6 route
add distance=1 dst-address=2000::/3 gateway=6to4-hq

Who is online

Users browsing this forum: j2sw, MattMiTi, sindy, vhynek and 260 guests