Community discussions

MikroTik App
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 77
Joined: Fri Apr 05, 2019 4:06 pm
Location: Italy

Few VLANs stopped after reboot (detect internet issue)  [SOLVED]

Thu Feb 18, 2021 9:25 pm

Hello all,
I'd like to report one issue that I had about some VLAN that stopped working, just after rebooting the router.
I'm using a RB4011 with ROS 6.46.8 connected to a CRS328, where I have defined several VLANs.
After rebooting the RB4011 I've got an issue with couple of VLANs related to 2 LANs; no traffic was passed to clients and other APs.
However other VLANs were still working, including the one used to manage and interconnect all devices together.
After several tries I found out that my problem had to deal with "Interface List" setting.
Basically on reboot that list was changed such that my 2 affected VLANs were dynamically assigned to the WAN list; then the firewall was preventing VLAN to function.
I have tried again to reboot the router and each time it was coming back with the same issue with Interface list.
In my case I have more than one list, since I'm also using "Detect Internet" with a multi-wan setup; it might be that such setup creates some weird behaviour caused by detect internet.
I have tried also with latest long-term ROS 6.47.9 with same end result.
This issue happened to me last month when I did another reboot; at that time I didn't see what the issue was because after re-organizing the LAN on a different eth port on RB4011 the issue was gone by itself. Most likely adding new ports was fixing the Interface list, removing the dynamic assignment for the LAN's VLAN.
This time, as I had more time to spend, I found what the real problem was so I'm sharing this just in case others might experience some weird behaviour under similar circumstances.

EDIT: after disabling the "Detect Internet" feature, this issue doesn't appear anymore after reboot.

Regards, Armando

Who is online

Users browsing this forum: amsteen, eworm, skylark, spmd and 217 guests