Community discussions

MikroTik App
 
Guscht
newbie
Topic Author
Posts: 33
Joined: Thu Jul 01, 2010 5:32 pm

No DNS for PPP-clients

Sun Feb 21, 2021 3:42 pm

Hi,

I use in my home-network a Pi-Hole for ad-blocking.
When I connect to our company VPN, the ads are back.

Because the company router as DNS-resolver is transmitted from the server (SSTP for clarification).
Its exact the same as described here: viewtopic.php?t=83843

As described in the other thread, if the DNS-server field (PPP -> Profiles) is empty/blank. there is always a DNS transmitted (I assume this is the standard behaviour).
But I found a simple solution, just use 255.255.255.255 as the DNS entry:
vpn-profile.jpg
This results in no inserted DNS-entry:
win.jpg


For confirmation, if the DNS-server-field in the profile is empty (or 0.0.0.0 is used):
vpn-profil_2.jpg
The DNS is inserted:
win_2.jpg

Unfortunately, this works only with Windows-Clients. Linux/Android-Clients receive and use the 255.255.255.255 as DNS.
In this case, use the "ignore pushed DNS servers" option if available.


If you know another option to suppress the DNS, let me know.
You do not have the required permissions to view the files attached to this post.
 
tdw
Forum Veteran
Forum Veteran
Posts: 709
Joined: Sat May 05, 2018 11:55 am

Re: No DNS for PPP-clients

Sun Feb 21, 2021 5:25 pm

AFAIK there isn't. At some point a 'No DNS' option was added to the DHCP server to prevent DNS being offered to DHCP clients, it would be nice if Mikrotik added similar for PPP profiles.

Who is online

Users browsing this forum: andya, Google [Bot], mkx and 176 guests