Community discussions

MikroTik App
 
ChepeS
just joined
Topic Author
Posts: 1
Joined: Mon Feb 22, 2021 5:37 am

CAPsMAn with VLAN no DHCP

Mon Feb 22, 2021 6:12 am

Hi to all, maybe some one can give me some direction to what I'm doing wrong.

I have a RouterBOARD 951, giving vlan 4 in the port ether 2, this goes through a Cloud router Switch CRS238 with SwOS, and receiving the vlan 4 in with trunk port on ether 1. and access to ether 9.

and on the ether 9 i have connected a wAP AC in CAP Mode. and the CAPS mode is working fine, but on the DHCP Wireless Clients doesn't receives the IP'S.

RouterBOARD 951 Configuration

/caps-man configuration
add country=guatemala datapath.client-to-client-forwarding=yes \
datapath.vlan-id=4 datapath.vlan-mode=no-tag mode=ap name=\
configuracion2.4 security.authentication-types=wpa2-psk \
security.encryption=aes-ccm security.passphrase=Imagenes123 ssid=RED2.4
/caps-man datapath
add client-to-client-forwarding=yes name=path2.4 vlan-id=4 vlan-mode=use-tag
/interface wireless
set [ find default-name=wlan1 ] ssid=MikroTik
/interface vlan
add interface=ether2 name=vlan2 vlan-id=2
add interface=ether2 name=vlan3 vlan-id=3
add interface=ether2 name=vlan4 vlan-id=4
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip pool
add name=dhcp_pool0 ranges=192.168.2.2-192.168.2.254
add name=dhcp_pool1 ranges=192.168.3.2-192.168.3.254
add name=dhcp_pool2 ranges=192.168.4.2-192.168.4.254
/ip dhcp-server
add address-pool=dhcp_pool0 disabled=no interface=vlan2 name=dhcp1
add address-pool=dhcp_pool1 disabled=no interface=vlan3 name=dhcp2
add address-pool=dhcp_pool2 disabled=no interface=vlan4 name=dhcp3
/caps-man manager
set enabled=yes
/caps-man provisioning
add action=create-dynamic-enabled master-configuration=configuracion2.4
/ip address
add address=192.168.2.1/24 interface=vlan2 network=192.168.2.0
add address=192.168.3.1/24 interface=vlan3 network=192.168.3.0
add address=192.168.4.1/24 interface=vlan4 network=192.168.4.0
/ip dhcp-server network
add address=192.168.2.0/24 dns-server=8.8.8.8,8.8.4.4 gateway=192.168.2.1
add address=192.168.3.0/24 dns-server=8.8.8.8,8.8.4.4 gateway=192.168.3.1
add address=192.168.4.0/24 dns-server=8.8.8.8,8.8.4.4 gateway=192.168.4.1

wAP AC configuration
/interface bridge
add admin-mac=64:D1:54:87:DF:FB auto-mac=no comment=defconf name=bridgeLocal \
vlan-filtering=yes
/interface wireless
# managed by CAPsMAN
# channel: 2447/20-eC/gn(28dBm), SSID: RED2.4, CAPsMAN forwarding
set [ find default-name=wlan1 ] ssid=MikroTik
set [ find default-name=wlan2 ] ssid=MikroTik
/interface vlan
add interface=ether1 name=vlan4 vlan-id=4
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip hotspot profile
set [ find default=yes ] html-directory=hotspot
/interface bridge port
add bridge=bridgeLocal comment=defconf interface=ether1
/interface wireless cap
#
set bridge=bridgeLocal discovery-interfaces=bridgeLocal enabled=yes \
interfaces=wlan1
/ip dhcp-client
add comment=defconf disabled=no interface=bridgeLocal

Many Thanks,

Who is online

Users browsing this forum: akakua, kennethtipton, Note, sindy, Znevna and 161 guests