Community discussions

MikroTik App
 
hakeem
just joined
Topic Author
Posts: 3
Joined: Tue Sep 26, 2006 12:51 am

Filter content *.iso, *.rar, etc

Tue Jul 24, 2007 11:41 am

dear all,

I have 2 WAN with different ISP, default will used ISP A. Is it possible in Mikrotik to filter content *.iso, *.rar, *.zip, etc with will re-route to ISP B ? How to configure that rules in Mikrotik ?
Thank's a lot.

hakeem
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24645
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: Filter content *.iso, *.rar, etc

Tue Jul 24, 2007 11:51 am

you can filter downloads of certain file types if you use Webproxy and Access Lists.
 
hakeem
just joined
Topic Author
Posts: 3
Joined: Tue Sep 26, 2006 12:51 am

Re: Filter content *.iso, *.rar, etc

Tue Jul 24, 2007 1:05 pm

you can filter downloads of certain file types if you use Webproxy and Access Lists.
Sorry i'm beginner in Mikrotik.
I want still allow user to download *.iso, *.rar, etc.....not to block, but if they are download that file, will be re-direct to ISP B.... not with ISP A.
Can you gift me samples rules if using webproxy and access lists. ?
Thank's a lot.

hakeem
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24645
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: Filter content *.iso, *.rar, etc

Tue Jul 24, 2007 1:06 pm

webproxy only knows how to block or allow. redirect based on file extension is not possible.
 
User avatar
cholegm
Frequent Visitor
Frequent Visitor
Posts: 56
Joined: Thu Jul 19, 2007 7:43 pm
Location: Gornji Milanovac, Serbia
Contact:

Re: Filter content *.iso, *.rar, etc

Tue Jul 24, 2007 1:10 pm

/ip firewall nat
add chain=dstnat protocol=tcp dst-port=80 in-interface="name of interface" action=redirect to-ports=3128 
(3128 or 8080, port of your web proxy server)
/ ip web-proxy access 
add url=":\\.mp\[3g\]\$" action=deny comment="" disabled=no 
add url=":\\.wm\[av\]\$" action=deny comment="" disabled=no
add url=":\\.avi\$" action=deny comment="" disabled=no 
add url=":\\.pls\$" action=deny comment="" disabled=no 
add url=":\\.torrent\$" action=deny comment="" disabled=no 
add url=":\\.nzb\$" action=deny comment="" disabled=no 
add url=":\\.exe\$" action=deny comment="" disabled=no 
add url=":\\.rar\$" action=deny comment="" disabled=no 
add url=":\\.zip\$" action=deny comment="" disabled=no 

And if you don't known how to configure web proxy, here you are:
/ ip web-proxy 
set enabled=yes src-address=0.0.0.0 port=3128 hostname="proxy.domain.com" transparent-proxy=yes \
    parent-proxy=0.0.0.0:0 cache-administrator="webmaster@domain.com" \
    max-object-size=4096KiB cache-drive=system max-cache-size=none \
    max-ram-cache-size=unlimited 
 
hakeem
just joined
Topic Author
Posts: 3
Joined: Tue Sep 26, 2006 12:51 am

Re: Filter content *.iso, *.rar, etc

Wed Jul 25, 2007 11:06 am

ok thx's

hakeem

Who is online

Users browsing this forum: erlinden, eworm, mudhoney, tgkmilo and 102 guests