Community discussions

MikroTik App
 
Traveler382
just joined
Topic Author
Posts: 22
Joined: Mon Mar 01, 2021 4:41 pm

Help configuring jumbo frames on CCR2004 VLANs

Thu Mar 25, 2021 3:29 pm

I'm having problems finding all the required settings for enabling jumbo frames for VLANs on my CCR2004. I thought I got everything properly configured (router config below), but Winbox shows an actual MTU of 1500 for all VLAN interfaces. The bridge itself shows 9000. Ultimately what I need is all VLAN interfaces (except WAN) set to an actual MTU of 9000. What am I missing? I basically have the same VLAN config on my CRS317, and those are set to 9000.

Screenshot:
https://imgur.com/a/9K8MLaD
# Global settings 
/ip route add dst-address=0.0.0.0/0 gateway=10.13.2.1 
/ip dns 
set servers=10.13.2.200,10.13.2.201 
/system identity 
set name=CCR2004 
/system ntp client 
set enabled=yes primary-ntp=216.239.35.8 secondary-ntp=216.239.35.4 

# Set Jumbo frames 

/interface ethernet 
set sfp-sfpplus1,sfp-sfpplus2,sfp-sfpplus3,sfp-sfpplus4,sfp-sfpplus5,sfp-sfpplus6,sfp-sfpplus7,sfp-sfpplus8,sfp-sfpplus9,sfp-sfpplus10,sfp-sfpplus11,sfp-sfpplus12 l2mtu=9578
set sfp-sfpplus1,sfp-sfpplus2,sfp-sfpplus3,sfp-sfpplus4,sfp-sfpplus5,sfp-sfpplus6,sfp-sfpplus7,sfp-sfpplus8,sfp-sfpplus9,sfp-sfpplus10,sfp-sfpplus11,sfp-sfpplus12 mtu=9000

# Setup Bridge 

/interface bridge 
add name=bridge vlan-filtering=no mtu=9000
/interface bridge port 
# upstream port will be untagged (access) port of VLAN ID 42 
add bridge=bridge pvid=42 ingress-filtering=yes frame-types=admit-only-untagged-and-priority-tagged interface=sfp-sfpplus1
# The rest of SFP+ ports are bridged together, all tagged 
add bridge=bridge ingress-filtering=yes frame-types=admit-only-vlan-tagged interface=sfp-sfpplus2 disabled=yes 
add bridge=bridge ingress-filtering=yes frame-types=admit-only-vlan-tagged interface=sfp-sfpplus3 disabled=yes 
add bridge=bridge ingress-filtering=yes frame-types=admit-only-vlan-tagged interface=sfp-sfpplus4 disabled=yes 
add bridge=bridge ingress-filtering=yes frame-types=admit-only-vlan-tagged interface=sfp-sfpplus5 disabled=yes 
add bridge=bridge ingress-filtering=yes frame-types=admit-only-vlan-tagged interface=sfp-sfpplus6 disabled=yes 
add bridge=bridge ingress-filtering=yes frame-types=admit-only-vlan-tagged interface=sfp-sfpplus7 disabled=yes 
add bridge=bridge ingress-filtering=yes frame-types=admit-only-vlan-tagged interface=sfp-sfpplus8 disabled=yes 
add bridge=bridge ingress-filtering=yes frame-types=admit-only-vlan-tagged interface=sfp-sfpplus9 disabled=yes 
add bridge=bridge ingress-filtering=yes frame-types=admit-only-vlan-tagged interface=sfp-sfpplus10 disabled=yes 
add bridge=bridge ingress-filtering=yes frame-types=admit-only-vlan-tagged interface=sfp-sfpplus11 disabled=yes 
add bridge=bridge ingress-filtering=yes frame-types=admit-only-vlan-tagged interface=sfp-sfpplus12 

/interface bridge vlan 
# sfp-sfpplus1 gets added as untagged automatically due to pvid setting above
add bridge=bridge tagged=bridge vlan-ids=42  
add bridge=bridge tagged=bridge,sfp-sfpplus12 vlan-ids=2611 
add bridge=bridge tagged=bridge,sfp-sfpplus12 vlan-ids=2612 
add bridge=bridge tagged=bridge,sfp-sfpplus12 vlan-ids=2613 

/interface vlan 
add name=WAN interface=bridge vlan-id=42 
add name=2611-MGT interface=bridge vlan-id=2611 mtu=9000
add name=2612-vMotion interface=bridge vlan-id=2612 mtu=9000
add name=2613-VM interface=bridge vlan-id=2613 mtu=9000

/ip address 
add address=10.13.2.10/24 interface=WAN 
add interface=2611-MGT address=172.26.11.1/24 
add interface=2612-vMotion address=172.26.12.1/24 
add interface=2613-VM address=172.26.13.1/24 

#DHCP Relay to Infoblox for select VLANs
/ip dhcp-relay add name=2611-MGT-Relay interface=2611-MGT dhcp-server=10.13.2.12 local-address=172.26.11.1 disabled=no
/ip dhcp-relay add name=2613-VM-Relay interface=2613-VM dhcp-server=10.13.2.12 local-address=172.26.13.1 disabled=no

/interface bridge set bridge vlan-filtering=yes

#BGP Routing
/routing bgp instance
set default as=65020
/routing bgp peer
add name=Vyos01 remote-address=172.26.13.101 remote-as=65010

Who is online

Users browsing this forum: lecyborg, Neon278, zendra and 85 guests