Community discussions

MikroTik App
 
TheLordOfTheShells
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 71
Joined: Tue Oct 03, 2017 2:48 am

VRRP flapping

Thu Apr 08, 2021 5:57 am

Hi guys.
I setup HA for 2 CRS317 Mikroitk switch using VRRP protocol.
Following this wiki article: https://wiki.mikrotik.com/wiki/Manual:VRRP-examples
The issue now is the vrrp up and down frequently. I have seen some topics on Mik forum with similar issue but all seem not have the right answer.
Log:
Image
Configuration on Sw01
/interface vlan
add interface=bridge1 name=CAMERA_30 vlan-id=30
add interface=bridge1 name=LAN_10 vlan-id=10
add interface=bridge1 name=LOA_50 vlan-id=50
add interface=bridge1 name=MGMT_99 vlan-id=99
add interface=bridge1 name=NS2_60 vlan-id=60
add interface=bridge1 name=NS3_70 vlan-id=70
add interface=bridge1 name=TEL_40 vlan-id=40
add interface=bridge1 name=WIFI_20 vlan-id=20

/interface vrrp
add interface=CAMERA_30 name=VRRP_CAMERA_30 priority=105 vrid=30
add interface=LAN_10 name=VRRP_LAN_10 priority=105 vrid=10
add interface=LOA_50 name=VRRP_LOA_50 priority=105 vrid=50
add interface=MGMT_99 name=VRRP_MGMT_99 priority=105 vrid=99
add interface=NS2_60 name=VRRP_NS2_60 priority=105 vrid=60
add interface=NS3_70 name=VRRP_NS3_70 priority=105 vrid=70
add interface=TEL_40 name=VRRP_TEL_40 priority=105 vrid=40
add interface=WIFI_20 name=VRRP_WIFI_20 preemption-mode=no vrid=20

/ip address
add address=4.4.4.4 interface=Loopback network=4.4.4.4
add address=172.16.2.2/24 interface=sfp-sfpplus1 network=172.16.2.0
add address=172.16.3.2/30 interface=sfp-sfpplus2 network=172.16.3.0
add address=172.16.10.1 interface=VRRP_LAN_10 network=172.16.10.1
add address=172.16.10.2/24 interface=LAN_10 network=172.16.10.0
add address=172.16.20.1 interface=VRRP_WIFI_20 network=172.16.20.1
add address=172.16.20.2/23 interface=WIFI_20 network=172.16.20.0
add address=172.16.30.1 interface=VRRP_CAMERA_30 network=172.16.30.1
add address=172.16.30.2/24 interface=CAMERA_30 network=172.16.30.0
add address=172.16.40.1 interface=VRRP_TEL_40 network=172.16.40.1
add address=172.16.40.2/24 interface=TEL_40 network=172.16.40.0
add address=172.16.50.1 interface=VRRP_LOA_50 network=172.16.50.1
add address=172.16.50.2/24 interface=LOA_50 network=172.16.50.0
add address=172.16.60.1 interface=VRRP_NS2_60 network=172.16.60.1
add address=172.16.60.2/24 interface=NS2_60 network=172.16.60.0
add address=172.16.70.1 interface=VRRP_NS3_70 network=172.16.70.1
add address=172.16.70.2/24 interface=NS3_70 network=172.16.70.0
add address=172.16.99.1 interface=VRRP_MGMT_99 network=172.16.99.1
add address=172.16.99.2/24 interface=MGMT_99 network=172.16.99.0
Configuration on Sw02
/interface vlan
add interface=bridge1 name=CAMERA_30 vlan-id=30
add interface=bridge1 name=LAN_10 vlan-id=10
add interface=bridge1 name=LOA_50 vlan-id=50
add interface=bridge1 name=MGMT_99 vlan-id=99
add interface=bridge1 name=NS2_60 vlan-id=60
add interface=bridge1 name=NS3_70 vlan-id=70
add interface=bridge1 name=TEL_40 vlan-id=40
add interface=bridge1 name=WIFI_20 vlan-id=20

/interface vrrp
add interface=CAMERA_30 name=VRRP_CAMERA_30 preemption-mode=no vrid=30
add interface=LAN_10 name=VRRP_LAN_10 preemption-mode=no vrid=10
add interface=LOA_50 name=VRRP_LOA_50 preemption-mode=no vrid=50
add interface=MGMT_99 name=VRRP_MGMT_99 preemption-mode=no vrid=99
add interface=NS2_60 name=VRRP_NS2_60 preemption-mode=no vrid=60
add interface=NS3_70 name=VRRP_NS3_70 preemption-mode=no vrid=70
add interface=TEL_40 name=VRRP_TEL_40 preemption-mode=no vrid=40
add interface=WIFI_20 name=VRRP_WIFI_20 priority=105 vrid=20


/ip address
add address=5.5.5.5 interface=Loopback network=5.5.5.5
add address=172.16.4.2/30 interface=sfp-sfpplus1 network=172.16.4.0
add address=172.16.5.2/30 interface=sfp-sfpplus2 network=172.16.5.0
add address=172.16.10.1 interface=VRRP_LAN_10 network=172.16.10.1
add address=172.16.10.3/24 interface=LAN_10 network=172.16.10.0
add address=172.16.20.1 interface=VRRP_WIFI_20 network=172.16.20.1
add address=172.16.20.3/23 interface=WIFI_20 network=172.16.20.0
add address=172.16.30.1 interface=VRRP_CAMERA_30 network=172.16.30.1
add address=172.16.30.3/24 interface=CAMERA_30 network=172.16.30.0
add address=172.16.40.1 interface=VRRP_TEL_40 network=172.16.40.1
add address=172.16.40.3/24 interface=TEL_40 network=172.16.40.0
add address=172.16.50.1 interface=VRRP_LOA_50 network=172.16.50.1
add address=172.16.50.3/24 interface=LOA_50 network=172.16.50.0
add address=172.16.60.1 interface=VRRP_NS2_60 network=172.16.60.1
add address=172.16.60.3/24 interface=NS2_60 network=172.16.60.0
add address=172.16.70.1 interface=VRRP_NS3_70 network=172.16.70.1
add address=172.16.70.3/24 interface=NS3_70 network=172.16.70.0
add address=172.16.99.1 interface=VRRP_MGMT_99 network=172.16.99.1
add address=172.16.99.3/24 interface=MGMT_99 network=172.16.99.0
My topo:
Image
Hope to receive your advice!

Who is online

Users browsing this forum: Ahrefs [Bot], dmitris, karlisi, loloski, onnyloh, sadjoe and 94 guests