Community discussions

MikroTik App
 
abatie
just joined
Topic Author
Posts: 23
Joined: Sat Feb 20, 2016 2:17 am

Vlan splitting

Sat Sep 04, 2021 2:16 am

I'm trying to do a simple trunk -> access port vlan split per https://wiki.mikrotik.com/wiki/Manual:I ... s_Ports.29 (really, combining examples 1 and 3); when I have vlan filtering off, the vlan ip addresses are pingable over the tagged uplink port, but not when vlan filtering is turned off. Initially, a client on one of the access ports could ping the router, but that seems to have stopped working (the router is not responding to arp requests, nor sending them out).

# feb/02/1970 20:32:01 by RouterOS 6.46.7
# software id = G0ZP-8CHD
#
# model = RB760iGS
# serial number = A51A0980D52F
/interface bridge
add name=uplink-bridge vlan-filtering=yes
/interface ethernet
set [ find default-name=ether1 ] comment="handoff 1" speed=100Mbps
set [ find default-name=ether2 ] comment="handoff 2" speed=100Mbps
set [ find default-name=ether3 ] speed=100Mbps
set [ find default-name=ether4 ] speed=100Mbps
set [ find default-name=ether5 ] comment="Local access port" speed=100Mbps
set [ find default-name=sfp1 ] comment=uplink
/interface vlan
add interface=uplink-bridge name=vlan200 vlan-id=200
add interface=uplink-bridge name=vlan613 vlan-id=613
/interface bridge port
add bridge=uplink-bridge interface=ether1 pvid=200
add bridge=uplink-bridge interface=ether2 pvid=613
add bridge=uplink-bridge interface=sfp1
/interface bridge vlan
add bridge=uplink-bridge tagged=sfp1 untagged=ether1 vlan-ids=200
add bridge=uplink-bridge tagged=sfp1 untagged=ether2 vlan-ids=613
/ip address
add address=192.168.88.1/24 comment=defconf interface=ether5 network=192.168.88.0
add address=207.55.110.1/30 interface=vlan200 network=207.55.110.0
add address=10.99.200.10/24 interface=vlan200 network=10.99.200.0
add address=10.99.113.10/24 interface=vlan613 network=10.99.113.0
 
User avatar
anav
Forum Guru
Forum Guru
Posts: 18958
Joined: Sun Feb 18, 2018 11:28 pm
Location: Nova Scotia, Canada
Contact:

Re: Vlan splitting  [SOLVED]

Sat Sep 04, 2021 3:12 am

Its not the complete config next time please include it all
/export hide-sensitive file=anynameyouwish

(1) You forgot to tag also the bridge for both rules.
FM
interface bridge vlan
add bridge=uplink-bridge tagged=sfp1 untagged=ether1 vlan-ids=200
add bridge=uplink-bridge tagged=sfp1 untagged=ether2 vlan-ids=613
TO
interface bridge vlan
add bridge=uplink-bridge tagged=uplink-bridge,sfp1 untagged=ether1 vlan-ids=200
add bridge=uplink-bridge tagged=uplink-bridge,sfp1 untagged=ether2 vlan-ids=613

(2) A vlan network can only have one address what is the purpose of the line in red???
/ip address
add address=192.168.88.1/24 comment=defconf interface=ether5 network=192.168.88.0
add address=207.55.110.1/30 interface=vlan200 network=207.55.110.0
add address=10.99.200.10/24 interface=vlan200 network=10.99.200.0
add address=10.99.113.10/24 interface=vlan613 network=10.99.113.0
 
User avatar
anav
Forum Guru
Forum Guru
Posts: 18958
Joined: Sun Feb 18, 2018 11:28 pm
Location: Nova Scotia, Canada
Contact:

Re: Vlan splitting

Sat Sep 04, 2021 3:17 am

As for this vlan split you mention.
Please explain it more clearly.

There are three types of ports typically
a. Trunk port which is all tagged vlans 1 or more, that are going to a smart device that can read vlan tags
b. Access port which is one untagged vlan that is going to a dumb device that cannot read vlan tags.
c. hybrid port, less common, where one untagged vlan and 1 or more tagged vlans are going to a device that can handle both.
(ex. voip phone with two ports in the phone, the incoming data over tagged vlans is read by the phone, the untagged vlan goes out the second voip port to the associated PC - dumb device)
 
abatie
just joined
Topic Author
Posts: 23
Joined: Sat Feb 20, 2016 2:17 am

Re: Vlan splitting

Sat Sep 04, 2021 3:18 am

Doh! Thanks!

The 207 address is the real address of the vlan when it goes into production, I'm just testing with the 10.99 addresses

Who is online

Users browsing this forum: almdandi, korg and 83 guests