Page 1 of 1

multiple PPPoE Outs

Posted: Thu Jan 20, 2005 4:42 am
by savage
Hi,

I'm trying to accomplish something - but I think that it is impossible due to the nature of PPPoE... I'd appreciate it if someone can give me some clarity....

At the moment, I have one PPPoE Session, working perfecting and masqing for my entire LAN. I now want to establish a second PPPoE session, and run inbound NAT on that one session, to allow one IP on my LAN to "mask" a outside address.

The problem I think, is that both PPPoE Sessions run from the same network card. It's either that, or that MT can't handle the multiple addresses received from my DSL provider....

The second PPPoE Session simply goes:
initializing
dialing
terminating
disconnected


PPPoE config:
Flags: X - disabled, R - running
0 R name="Gateway" mtu=1480 mru=1480 interface=Server Network user="user1"
password="whatever" profile=MainDSL service-name=""
ac-name="" add-default-route=yes dial-on-demand=no
use-peer-dns=no allow=mschap2,mschap1,chap,pap

1 name="Static NAT" mtu=1480 mru=1480 interface=Server Network user="user1" password="whatever"
profile=CustDSL service-name="" ac-name=""
add-default-route=no dial-on-demand=no use-peer-dns=no allow=pap
When I kill connection 0, connection 1 connects without a problem. I can't however manage to get both connected. I also tried running each connection on its own ethernet interface - but no luck...

Hope someone can help me.

Posted: Thu Jan 20, 2005 12:40 pm
by YazzY
The problem is propably at your ISP not allowing multiple PPP connections from the same user. Try to contact them and explain your situation.
Maybe they can route a /30 to you instead.

Posted: Thu Jan 20, 2005 1:44 pm
by savage
Not quite but close... Maintenance. Sorry ppl :)