Community discussions

 
Znuff
Member Candidate
Member Candidate
Topic Author
Posts: 139
Joined: Tue Sep 26, 2006 2:42 am
Contact:

[webproxy-test bug] <base href="http://url/" /> gets trimmed

Tue Oct 02, 2007 8:16 pm

Hello.

I'm using webproxy-test under 2.9.45 and I have a small issue with a website and probably with others.

Try visiting http://www.upc.ro when the webproxy-test is enabled and set as transparent proxy. Nothing loads up. Not the images, not the javascript, not the css and links don't work. Upon disabling the srcnat rule in the firewall (thus having direct access to the web) the website works fine.

Later edit: it seems to have an issue with the <base href=""> tag...
When the proxy is enabled I get <base href="http:///" />, while the correct tag in the page is <base href="http://www.upc.ro/" />.
 
Znuff
Member Candidate
Member Candidate
Topic Author
Posts: 139
Joined: Tue Sep 26, 2006 2:42 am
Contact:

Re: [webproxy-test bug] <base href="http://url/" /> gets trimmed

Wed Oct 03, 2007 2:47 pm

So where do I post a bug, seeming that here nobody notices the bug posts?
 
Znuff
Member Candidate
Member Candidate
Topic Author
Posts: 139
Joined: Tue Sep 26, 2006 2:42 am
Contact:

Re: [webproxy-test bug] <base href="http://url/" /> gets trimmed

Tue Oct 16, 2007 1:36 am

Is this thing actually getting noticed?
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24206
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: [webproxy-test bug] <base href="http://url/" /> gets trimmed

Tue Oct 16, 2007 10:32 am

can you try ROS v3 RC6?
No answer to your question? How to write posts
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Posts: 6616
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Re: [webproxy-test bug] <base href="http://url/" /> gets trimmed

Wed Oct 17, 2007 4:29 pm

Contact support (support@mikrotik.com), in case you think that you have found bug at RouterOS.
 
Znuff
Member Candidate
Member Candidate
Topic Author
Posts: 139
Joined: Tue Sep 26, 2006 2:42 am
Contact:

Re: [webproxy-test bug] <base href="http://url/" /> gets trimmed

Thu Oct 18, 2007 8:01 pm

Can't try to use RC6 on that particular box. It's our main gateway and I don't want to risk breaking internet access for all our customer. I'll try and see on another box.
 
Znuff
Member Candidate
Member Candidate
Topic Author
Posts: 139
Joined: Tue Sep 26, 2006 2:42 am
Contact:

Re: [webproxy-test bug] <base href="http://url/" /> gets trimmed

Sun Oct 21, 2007 7:19 am

This is confirmed under version 3.00 RC7 too.

Who is online

Users browsing this forum: No registered users and 89 guests