Page 1 of 1

Second and subsequent PPPoE connections fail

Posted: Mon Oct 15, 2007 5:48 pm
by Calrion
After configuring multiple PPPoE connections to my ISP, the second and subsequent connection(s) always fail. It doesn't matter which I enable first; the first one always works, the others always fail.

So, some facts: my MT box is behind an ADSL modem in bridge mode. I'm running ROS 2.9.38. My ISP permits up to four concurrent PPPoE connections. I'm using the MT box as the PPPoE client. I'm using a Level 4 license, which I understand to support up to 200 concurrent PPPoE connections.

I've plugged my Vista-powered laptop into the ADSL modem and established a second concurrent PPPoE connection, so I can rule out a problem with the modem, and also with the ISP. I've called the ISP helpdesk and they confirmed that yes, they officially permit up to four PPPoE connections, and also that they can't see any evidence of the failling connections (i.e. they see the first, but not the others).

The logging detail I get in MT simply says "terminating - disconnected".

Has anyone come across this before? Any advice?

Thanks in advance,
Greg.

Re: Second and subsequent PPPoE connections fail

Posted: Tue Oct 16, 2007 1:29 am
by Znuff
The PPPoE _server_ supports up to 200 clients.

Turn on debug for ppp and see what you get.

Re: Second and subsequent PPPoE connections fail

Posted: Tue Oct 16, 2007 3:09 am
by Calrion
Ahh, fair enough. Ok, so I told ROS:
add topics=pppoe,debug prefix="" action=memory system logging action
And got the following when I enabled the second PPPoE connection, let it try to connect (and fail), then disabled it again:
09:20:30 pppoe,ppp,debug dsl-XXXXXXXXX-dyn2: PPP restart 
09:20:30 pppoe,ppp,info dsl-XXXXXXXXX-dyn2: initializing... 
09:20:30 pppoe,ppp,debug dsl-XXXXXXXXX-dyn2: PPP started 
09:20:30 pppoe,ppp,info dsl-XXXXXXXXX-dyn2: dialing... 
09:20:30 pppoe,debug,packet dsl: sent PADI to FF:FF:FF:FF:FF:FF 
09:20:30 pppoe,debug,packet     session-id=0x0000 
09:20:30 pppoe,debug,packet     host-uniq=0x443 
09:20:30 pppoe,debug,packet     service-name= 
09:20:30 system,info device changed by admin 
09:20:30 pppoe,debug,packet dsl: rcvd PADO from 00:90:1A:A0:6F:D2 
09:20:30 pppoe,debug,packet     session-id=0x0000 
09:20:30 pppoe,debug,packet     ac-name=####-######## 
09:20:30 pppoe,debug,packet     host-uniq=0x443 
09:20:30 pppoe,debug,packet     service-name= 
09:20:30 pppoe,debug,packet     ac-cookie=96 b6 d7 12 9d 65 d4 72 97 5d 5a d5 
    a3 07 8f c2 
09:20:30 pppoe,debug,packet dsl: sent PADR to 00:90:1A:A0:6F:D2 
09:20:30 pppoe,debug,packet     session-id=0x0000 
09:20:30 pppoe,debug,packet     host-uniq=0x444 
09:20:30 pppoe,debug,packet     service-name= 
09:20:30 pppoe,debug,packet     ac-cookie=96 b6 d7 12 9d 65 d4 72 97 5d 5a d5 
    a3 07 8f c2 
09:20:31 pppoe,debug,packet dsl: sent PADR to 00:90:1A:A0:6F:D2 
09:20:31 pppoe,debug,packet     session-id=0x0000 
09:20:31 pppoe,debug,packet     host-uniq=0x444 
09:20:31 pppoe,debug,packet     service-name= 
09:20:31 pppoe,debug,packet     ac-cookie=96 b6 d7 12 9d 65 d4 72 97 5d 5a d5 
    a3 07 8f c2 
09:20:32 pppoe,debug,packet dsl: sent PADR to 00:90:1A:A0:6F:D2 
09:20:32 pppoe,debug,packet     session-id=0x0000 
09:20:32 pppoe,debug,packet     host-uniq=0x444 
09:20:32 pppoe,debug,packet     service-name= 
09:20:32 pppoe,debug,packet     ac-cookie=96 b6 d7 12 9d 65 d4 72 97 5d 5a d5 
    a3 07 8f c2 
09:20:33 pppoe,debug,packet dsl: sent PADR to 00:90:1A:A0:6F:D2 
09:20:33 pppoe,debug,packet     session-id=0x0000 
09:20:33 pppoe,debug,packet     host-uniq=0x444 
09:20:33 pppoe,debug,packet     service-name= 
09:20:33 pppoe,debug,packet     ac-cookie=96 b6 d7 12 9d 65 d4 72 97 5d 5a d5 
    a3 07 8f c2 
09:20:34 pppoe,debug,packet dsl: sent PADR to 00:90:1A:A0:6F:D2 
09:20:34 pppoe,debug,packet     session-id=0x0000 
09:20:34 pppoe,debug,packet     host-uniq=0x444 
09:20:34 pppoe,debug,packet     service-name= 
09:20:34 pppoe,debug,packet     ac-cookie=96 b6 d7 12 9d 65 d4 72 97 5d 5a d5 
    a3 07 8f c2 
09:20:35 pppoe,ppp,debug dsl-XXXXXXXXX-dyn2: PPP disconnected <disconnected> 
09:20:35 pppoe,ppp,info dsl-XXXXXXXXX-dyn2: terminating... - disconnected 
09:20:35 pppoe,ppp,debug dsl-XXXXXXXXX-dyn2: PPP stopped 
09:20:35 pppoe,ppp,info dsl-XXXXXXXXX-dyn2: disconnected 
09:20:35 pppoe,ppp,debug dsl-XXXXXXXXX-dyn2: CCP lowerdown 
09:20:35 pppoe,ppp,debug dsl-XXXXXXXXX-dyn2: CCP down event in initial state 
09:20:35 pppoe,ppp,debug dsl-XXXXXXXXX-dyn2: IPCP lowerdown 
09:20:35 pppoe,ppp,debug dsl-XXXXXXXXX-dyn2: IPCP down event in initial state 
09:20:35 pppoe,ppp,info dsl-XXXXXXXXX-dyn2: initializing... 
"dsl" is the name of the ethernet interface connected to the ADSL modem; "dsl-XXXXXXXXX-dyn2" is the PPPoE connection and "####-########" is the dynamically discovered access concentrator.

If I'm interpreting this correctly, it seems that MT is trying the PPPoE connection, but not getting a response. Which is all the more confusing...

Re: Second and subsequent PPPoE connections fail

Posted: Tue Oct 16, 2007 9:27 am
by apu132
Dear ,

here i got an info that ...mikrotik pppoe userlimit 200....
But is it active user limit ??? or
how mikrotik maintain this limitaion ..is it any software bugs or is it depands on licence level limit ??

Awaiting for kind breif description ??

--->> (Apu)

Re: Second and subsequent PPPoE connections fail

Posted: Tue Oct 16, 2007 1:40 pm
by Chupaka
here i got an info that ...mikrotik pppoe userlimit 200....
But is it active user limit ??? or
how mikrotik maintain this limitaion ..is it any software bugs or is it depands on licence level limit ??
The number of PPPoE tunnels is limited to 200 for L4 and to 500 for L5 license. See http://www.mikrotik.com/pricelist.php?sect=1

Re: Second and subsequent PPPoE connections fail

Posted: Thu Oct 18, 2007 4:14 pm
by Calrion
Well, unfortunately (it's not the preferred outcome), I think I've solved the problem: you can't have two PPPoE connections between the same pair of MAC addresses.

I've taken quite a few steps to troubleshoot this, including setting up a vanilla ROS box, and using Windows Vista to setup connections. I've NEVER been able to get two concurrent PPPoE connections between the same pair of MAC addresses, but have ALWYAYS been successful when each PPPoE connection is sent from a unique MAC.

This is disappointing, as I was hoping to have all the PPPoE connections terminate on the ROS box; oh well.

Thanks all for your help.

Re: Second and subsequent PPPoE connections fail

Posted: Thu Oct 18, 2007 4:23 pm
by mrz
You are wrong, it is possible to have multiple connections from one host if PPPOE server allows to do that.
In routerOS you can do it by setting one-session-per-host to no.

/interface pppoe-server server set <id> one-session-per-host=no

Re: Second and subsequent PPPoE connections fail

Posted: Thu Oct 18, 2007 9:21 pm
by gmsmstr
I think he is the PPPoE Client, why not just let the MT be the client and NAT the rest of your computers ..

Re: Second and subsequent PPPoE connections fail

Posted: Fri Oct 19, 2007 1:26 am
by Calrion
I am? Excellent!

I guess this means the problem is at the AC, and not my end (and perhaps a result of the dreaded "by design"). Unfortunately, the AC is run either by my ISP or, worse luck, the incumbent telecommunications company.

The trouble with this is--and also why I'd basically discounted it until now--that my ISP say they can't see any authentication attempts for the connections that fail. Looks like I need to do some more research...

EDIT (saw new post): Oh, I do use NAT currently; but there are certain things (e.g. multiple HTTP/S servers that aren't on special ports) for which additional addresses would be useful--even if they're dynamic. My ISP allows a total of four concurrent PPPoE connections, including one with a static IP; they also permit running servers and don't block any ports. And yes, you're right, MT is the client; but that's ok, I'm more than happy with an academic "it's possible" at this point.

Re: Second and subsequent PPPoE connections fail

Posted: Fri Oct 19, 2007 4:54 am
by shielder
hi calrion,

i think it's better to get 4 modem and 4 ethernet interface on your Mikrotik. So it would dial from different interface to your ISP. Isn't better and solved all the problem?

Cheers..
Good luck

Re: Second and subsequent PPPoE connections fail

Posted: Fri Oct 19, 2007 10:53 am
by Calrion
Four phone lines would certainly be overkill, and the redundancy isn't really required as the connection hasn't had significant downtime since its inception (and a dial-up modem would be sufficient when it does). I could use multiple ethernet interfaces connected to the ADSL modem, but I'm hoping to find a better solution. The research continues...

Re: Second and subsequent PPPoE connections fail

Posted: Sat Oct 20, 2007 3:50 pm
by Calrion
This post originally asked for a way to specify the session ID...

Well I went back and read the RFC, and my bad, ROS is doing exactly what it's supposed to do (of course!). Turns out that the session ID MUST be 0 in the PADI, PADO and PADR packets.

Next step is to sniff things and see if the AC ever sends a PADS packet (not expecting one). It's looking more and more likely that although my ISP doens't block things, the incumbent carrier (which provides the last-mile copper, DSLAM and ATM backhaul to an aggregation point) may well be.

I'm just going to have to figure out how I can set things up so each PPPoE connection comes from a different MAC.

Thanks again everyone for your help!