Community discussions

 
User avatar
kapis
just joined
Topic Author
Posts: 17
Joined: Fri May 28, 2004 3:23 pm
Contact:

multicast routing

Tue Oct 23, 2007 11:27 am

Hi all,
I don't know if this is the right place in this forum where to post this but I have been having some issues configuring pim, apparently because of lack of knowledge :lol: :lol: :lol: :lol:

So I was wondering - could someone provide me with some info or some liitle example or howto ???

Thanks!!!! and sorry for my bad english :)
--KAPIS--
 
kiket
Frequent Visitor
Frequent Visitor
Posts: 56
Joined: Thu Mar 02, 2006 5:32 pm

Re: multicast routing

Mon Nov 05, 2007 10:11 pm

I'm interested in see another multicast config too.

I have a multicast config (similar to the wiki, 2 routers Pto-Pto), but when the client stop playing the stream, traffic don't stop!!.I use VLC server and viewer to test it. I use the demo 3.0rc9. Anyone with the same problem??

Best regards,

Kiket
 
User avatar
kapis
just joined
Topic Author
Posts: 17
Joined: Fri May 28, 2004 3:23 pm
Contact:

Re: multicast routing

Tue Nov 06, 2007 10:24 am

I had a similar problem. I don't know much about pim-sm but I think that in sparse mode traffic should stop if there is no listener.

You could correct me if i'm wrong.
--KAPIS--
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: multicast routing

Tue Nov 06, 2007 12:58 pm

this is known problem (continues to transmit when it should end) and will be resolved in future releases
 
kiket
Frequent Visitor
Frequent Visitor
Posts: 56
Joined: Thu Mar 02, 2006 5:32 pm

Re: multicast routing

Tue Nov 06, 2007 1:14 pm

Thanks Janisk.
 
User avatar
kapis
just joined
Topic Author
Posts: 17
Joined: Fri May 28, 2004 3:23 pm
Contact:

Re: multicast routing

Mon Nov 12, 2007 10:03 am

hi, looks like in new release (RC10) it is not fixed, at least in changelog it is not mentioned. any updates somebody??
--KAPIS--
 
kiket
Frequent Visitor
Frequent Visitor
Posts: 56
Joined: Thu Mar 02, 2006 5:32 pm

Re: multicast routing

Tue Nov 13, 2007 10:25 pm

I don't test the last release rc10 (have no changes about multicast), but I think in the next releases will be fixed.

Kike
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: multicast routing

Wed Nov 14, 2007 3:27 pm

no there are no fixes in rc10 for PIM (multicast)

if you want you can run basic configurations of PIM in your network, simple static configurations should work.

just remember that multicast addresses use class D addresses and that 224.0.0.0/24 is reserved for network processes and same goes for 238.0.0.0/24

here you can see in more detail about international assigned multicast groups in use:
http://www.iana.org/assignments/multicast-addresses
 
francescov
just joined
Posts: 13
Joined: Mon Jan 29, 2007 8:13 pm

Re: multicast routing

Thu Nov 22, 2007 4:32 pm

hi, I try multicast routing with vlc using a configuration like described in mikrotik wiki, but I have some problems.

can someone post a working configuration/example?

tanx to all
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 5942
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: multicast routing

Thu Nov 22, 2007 4:37 pm

What kind of problems you have?

Btw example in wiki IS working example.
 
kiket
Frequent Visitor
Frequent Visitor
Posts: 56
Joined: Thu Mar 02, 2006 5:32 pm

Re: multicast routing

Thu Nov 22, 2007 4:47 pm

Hi francescov,

I have made the wiki configuration,all the config work well unless the unic problem I have is that when the client (running VLC) stop playing the stream, the traffic doesn't stop.

Best regards,

Kike
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: multicast routing

Fri Nov 23, 2007 12:01 pm

"leaving channel" will be solved in next release, so traffic will stop when client disconnects
 
vlada1
Frequent Visitor
Frequent Visitor
Posts: 89
Joined: Sun Mar 04, 2007 2:18 pm

Re: multicast routing

Fri Nov 23, 2007 10:36 pm

i expected next release today :)
 
kiket
Frequent Visitor
Frequent Visitor
Posts: 56
Joined: Thu Mar 02, 2006 5:32 pm

Re: multicast routing

Sat Nov 24, 2007 12:18 am

Thanks Janisk!!! I will waiting to the rc11!!
 
francescov
just joined
Posts: 13
Joined: Mon Jan 29, 2007 8:13 pm

Re: multicast routing

Mon Nov 26, 2007 11:23 am

I'm not very expert on multicast routing...I encounter problems with wiki example.

this is my configuration:

Sender -- (subnet I) --> Router A -- (subnet II) --> Router B -- (subnet III) --> Receiver

#####configuration script for router A
###

/ip address
add address=10.0.1.1/24 interface=ether1
add address=10.0.0.1/24 interface=ether2

/ip route
ip route add dst-address=10.0.2.0/24 gateway=10.0.0.2

/routing pim interface
add

/routing pim rp
add address=10.0.1.1

#####configuration script for router B
###

/ip address
add address=10.0.2.1/24 interface=ether1
add address=10.0.0.1/24 interface=ether2

/ip route
ip route add dst-address=10.0.1.0/24 gateway=10.0.0.1

/routing pim interface
add interface=ether1

/routing pim rp
add address=10.0.1.1

###router are connected by ether2 ports
###vlc streaming server is connected to ether1 of routerA and streams to 224.0.1.20
###vlc client is connected to ether1 of routerB and receive from 224.0.1.20
###I have made "ip route add 224.0.1.20/32 via 10.0.1.1" on vlc streaming server

I need some help!

best regards

--------------FV--------------
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: multicast routing

Mon Nov 26, 2007 12:18 pm

you have to check joins in PIM settings to see has someone joined that group or not.

when we did tests - PIM worked though NAT not talking about simple routed network.

anyway, wait for rc11 when it comes out. it is working better then rc10

also check if your client and server can ping each other as it is simple routing network.

and whereis that 10.0.0.2 that is used as a gateway?
 
francescov
just joined
Posts: 13
Joined: Mon Jan 29, 2007 8:13 pm

Re: multicast routing

Mon Nov 26, 2007 10:39 pm

Tanx Janisk, now vlc works well on mikrotik router. I have change pim config:

#####configuration script for router A
###

/ip address
add address=10.0.2.1/24 interface=ether1
add address=10.0.0.2/24 interface=ether2

/ip route
ip route add dst-address=10.0.1.0/24 gateway=10.0.0.1

/routing pim interface
add

/routing pim rp
add address=10.0.0.2

#####configuration script for router B
###

/ip address
add address=10.0.1.1/24 interface=ether1
add address=10.0.0.1/24 interface=ether2

/ip route
ip route add dst-address=10.0.2.0/24 gateway=10.0.0.2

/routing pim interface
add interface=ether1
add interface=ether2

/routing pim rp
add address=10.0.0.2

the only problem is "leaving channel": when I stop vlc, traffic don't stop!
I'm waiting for Rc11!!

best regard

---------------FV-----------------
 
uldis
MikroTik Support
MikroTik Support
Posts: 3426
Joined: Mon May 31, 2004 2:55 pm

Re: multicast routing

Tue Nov 27, 2007 1:20 pm

v3.0rc11 is released, you can try it out.
 
laurinkus
Member Candidate
Member Candidate
Posts: 100
Joined: Thu Aug 31, 2006 5:05 pm
Location: Europe

Re: multicast routing

Wed Nov 28, 2007 12:45 am

PIM does not work properly on VLAN interfaces.
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 5942
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: multicast routing

Wed Nov 28, 2007 3:29 pm

You should be more specific what isn't working. It works for me.
 
laurinkus
Member Candidate
Member Candidate
Posts: 100
Joined: Thu Aug 31, 2006 5:05 pm
Location: Europe

Re: multicast routing

Wed Nov 28, 2007 4:50 pm

Ok. Here's some more details:

My configuration:
# nov/28/2007 16:44:48 by RouterOS 3.0rc10
/routing pim 
set switch-to-spt=no switch-to-spt-bytes=0 switch-to-spt-interval=0s 
/routing pim interface 
add assert-override-interval=3s assert-time=3m disabled=no dr-priority=1 hello-holdtime=1m45s hello-period=30s \
    hello-trigerred-delay=5s igmp-version=IGMPv2 interface=vlan60 join-prune-holdtime=3m30s join-prune-period=1m \
    override-interval=250 propagation-delay=50 protocols=pim require-hello=yes tracking-support=yes 
 > ip address print from=12
Flags: X - disabled, I - invalid, D - dynamic 
 #   ADDRESS            NETWORK         BROADCAST       INTERFACE
 0   192.168.0.253/30   192.168.0.252   192.168.0.255   vlan60   
After PIM interface is added I observe PIM Hello's on vlan 60:
# tcpdump -n -i xl1 vlan 60 and ether host not 00:15:fa:9a:cd:04

16:41:29.658318 IP 192.168.0.253 > 224.0.0.13: PIMv2, Hello, length: 34
16:41:29.659229 IP 192.168.0.254 > 224.0.0.13: PIMv2, Hello, length: 34
16:41:58.965801 IP 192.168.0.254 > 224.0.0.13: PIMv2, Hello, length: 34
16:41:59.657671 IP 192.168.0.253 > 224.0.0.13: PIMv2, Hello, length: 34
16:42:04.940687 IP 192.168.0.254 > 224.0.0.13: PIMv2, Bootstrap, length: 36
.. however neighbor table is empty.
> routing pim neighbors print detail 

> 
PS. 192.168.0.254 is C3560 family device.
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 5942
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: multicast routing

Wed Nov 28, 2007 5:23 pm

Well you are using RC10, multicast wasn't working very well in that version.
Have you tried RC11?
 
laurinkus
Member Candidate
Member Candidate
Posts: 100
Joined: Thu Aug 31, 2006 5:05 pm
Location: Europe

Re: multicast routing

Wed Nov 28, 2007 11:19 pm

Upgrade to RC11 didn't helped too much. Still facing same problem.
 
kiket
Frequent Visitor
Frequent Visitor
Posts: 56
Joined: Thu Mar 02, 2006 5:32 pm

Re: multicast routing

Tue Dec 04, 2007 10:20 pm

Hi all!!

I update to rc11 and "leave channel" now work ok!!,but I have a question, is normal that have 15Mb of traffic in the point to point wireless link without play any stream?.

I have a config like this:

FIRST CONFIG == it's normal

VLC Server (22Mb traffic) ----- (ether1) ROUTER A RP(wlan1) ------ 0 Mb----- (wlan1)ROUTER B (ether1) ---- CLIENT (0 Mb traffic)


SECOND CONFIG == it's normal????

VLC Server (22Mb traffic) ----- (ether1) ROUTER A (wlan1) ------15Mb----- (wlan1)ROUTER B RP(ether1) ---- CLIENT (0 Mb traffic)

WITHOUT PLAYING ANY STREAM, If I put the ROUTER A (where is conected the streaming server) as RP, the link
have no traffic. But when I put the ROUTER B (where is the CLIENT) as RP . I have 15 Mb along the wireless
link. I know that the RP have the table of multicast streamers and clients but think that 15Mb to update
the table is too much!!!

Thansk for all.

Kiket
 
User avatar
macgaiver
Forum Guru
Forum Guru
Posts: 1721
Joined: Wed May 18, 2005 5:57 pm
Location: Sol III, Sol system, Sector 001, Alpha Quadrant

Re: multicast routing

Tue Dec 11, 2007 3:48 pm

IMHO Stream must get to RP, no matter what! There you have your 15Mbps!
With great knowledge comes great responsibility, because of ability to recognize id... incompetent people much faster.
 
kiket
Frequent Visitor
Frequent Visitor
Posts: 56
Joined: Thu Mar 02, 2006 5:32 pm

Re: multicast routing

Wed Dec 12, 2007 12:49 pm

It's a problem in "REGISTER STOP". When no router receives a stream request, it should cancel the transmission.

I don't know if I have a bad config or is a mikrotik rc11 version bug.

If anyone have the same results or have any solution, post here it,please.

Best regards.

Kike
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: multicast routing

Wed Dec 12, 2007 1:03 pm

that is correct macgaiver.

when source appear on the multicast network, closes router becomes its designated router, that knows RP's for multicast groups, then designated router does source join to RP, thus creating the tunnel to RP then RP tries to get same multicast traffic without tunnel and does backward joins to reach source, when this is done tunnel is discarded and RP is receiving multicast stream. if some client want to join that group it will be group-joined to that RP not the source.

so, that RP receives stream is OK and that SHOULD be so.



so kikat - this is not a problem, please read available multicast documentation (RFC is good option). Then you will see that RP should be joined and should have stream, if you group-join and then client leaves, then this group-joined router should stop receiving the stream, and that is not the case of source-join

you can set up closer RP with higher than others priority for that single group, so every other stream goes to your main RP but that groups RP is on the other side.

also you can try STP mode (you can see description in wiki)
 
kiket
Frequent Visitor
Frequent Visitor
Posts: 56
Joined: Thu Mar 02, 2006 5:32 pm

Re: multicast routing

Tue Jan 22, 2008 1:45 pm

Hi all,

Thanks for your comments!!. I write now to comment another problem?¿.

SCHEME

VLC Server (6 MPEG2 STREAMS 22Mb traffic) ----- (ether1) ROUTER A RP(wlan1) ------ 0 Mb----- (wlan1)ROUTER B (ether1) ---- CLIENT (0 Mb traffic)

When I make a bandwith test the link give me 40 Mbps,when I designate the ROUTER B as RP, I can see the 6 streams perfectly in the client, but if I designate the ROUTER A as RP (as the scheme), only can play 2 or 3 streams (7 - 10,5Mb) in the client, when the traffic along the wireless link go up from 10Mb in the client the image is distorts. I can't transmit more than 2 or 3 streams in a good conditions, and the link can support more than this.

Anyone can help me.

Best regards and thanks in advance.
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: multicast routing

Tue Jan 22, 2008 2:12 pm

what is PPS when you set ROUTER B as a RP and when you try to watch when ROUTER A is RP i think that streams are managed differently when client joins and when it is sent to the RP

also you can try to set up nstream on your wireless link
 
kiket
Frequent Visitor
Frequent Visitor
Posts: 56
Joined: Thu Mar 02, 2006 5:32 pm

Re: multicast routing

Tue Jan 22, 2008 5:08 pm

Hi Janisk thanks to answer my question, I test all the options with Nstreme but don't get best results.

See this picture from ROUTER A as RP, in WLAN1 PPS - TX 997 / RX 5 (Can you see in this picture what is the problem at the right when play the third stream)

Image

See this picture from ROUTER B as RP,in WLAN1 PPS - TX 5 / RX 1548 ( Here are 4 stream playing and it seen without problems).

Image
I don't understand where can stay the problem. I think this PPS are normal.

I'm so interested in know how to solve this, because want to test a Point - Multi Point streaming, and if no solve it, it's imposible. Now I can only stream 2 files.

Thanks in advance.

Kiket

---- UPDATE ----

HI Janisk, all my config that I explained up, is without SPT. I test now that if I active the SPT when the ROUTER B is the RP, the router A only transmit 10,6Mb!!! (just for play 2 streams well ) can apreciate this in the first picture. If I don't use SPT the ROUTER B receive all the bandwith 20Mb to play all the streams perfectly.

I think the problem is in the form where ROUTER A transmit to ROUTER B when the client send join to Router A.The ROUTER A don't push more than 10-11 Mb.
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: multicast routing

Wed Jan 23, 2008 9:54 am

in the setup when you run RP on the ROUTER A an when you get distorts please create supout.rif file and send it to support@mikrotik so we could see what is happening.

also ensure that you have latest version available.
 
kiket
Frequent Visitor
Frequent Visitor
Posts: 56
Joined: Thu Mar 02, 2006 5:32 pm

Re: multicast routing

Wed Jan 23, 2008 5:09 pm

Hi Janisk,

I send this morning the supout.rif to support@mikrotik.com

Thanks in advance.

Kike.
 
kiket
Frequent Visitor
Frequent Visitor
Posts: 56
Joined: Thu Mar 02, 2006 5:32 pm

Re: multicast routing

Mon Jan 28, 2008 8:14 pm

No one has a configuration similar to mine, or nobody uses multicast on their networks?.I think it's a basic config, and I'm sure that someone has done.

I Would be very grateful if someone could tell me if the same thing happens, I hope while mikrotik's support reply my mail.

Best regards,

Kike.
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: multicast routing

Tue Jan 29, 2008 1:33 pm

kiket if you can set ROUTER-A as station and ROUTER-B as a AP-bridge or bridge and see if you still have a problem when you move your RP on ROUTER-A
 
kiket
Frequent Visitor
Frequent Visitor
Posts: 56
Joined: Thu Mar 02, 2006 5:32 pm

Re: multicast routing

Tue Jan 29, 2008 5:08 pm

Hi Janisk,

I change the ROUTER A as station and the ROUTER B as apbridge/bridge, and the problem is the same. Router A as RP.
 
esn.toolz
newbie
Posts: 42
Joined: Mon May 28, 2007 6:52 am

Re: multicast routing

Wed Feb 13, 2008 6:10 pm

Can you try tunneling the link with an eoip based one?
 
kiket
Frequent Visitor
Frequent Visitor
Posts: 56
Joined: Thu Mar 02, 2006 5:32 pm

Re: multicast routing

Wed Feb 13, 2008 6:58 pm

Hi esn.toolz,

I can test it this weekend, but Janisk say me that "He is working on that and other problems connected with PIM implementation in RouterOS"

Best regards,

Kike
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: multicast routing

Thu Feb 14, 2008 9:40 am

you can try to create EoiP tunnel through wireless link as multicast packets are handled differently by wireless. So that idea is actually good.
 
kiket
Frequent Visitor
Frequent Visitor
Posts: 56
Joined: Thu Mar 02, 2006 5:32 pm

Re: multicast routing

Wed Feb 20, 2008 1:46 am

Hi all!!

The EoIP test don't work. I have make a BRIDGED EoIP tunnel between the 2 WLAN but don't work well.

Only if I try to ROUTING with Eoip (I don't know if it's correct) it work well (when make Pto-Pto) but it does not adjust to my needed, because I want to make a Pto - MPoint, and when I make more than one Eoip tunnel doesn't work.

This my config and want to implement correctly with more clients:

Image

Thanks,

Kike
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: multicast routing

Wed Feb 20, 2008 3:45 pm

i have tested multicast using EoIP tunnels and u have not seen any problem with that.

since EoIP is layer 2 then you have to bridge it for it to work.
 
kiket
Frequent Visitor
Frequent Visitor
Posts: 56
Joined: Thu Mar 02, 2006 5:32 pm

Re: multicast routing

Wed Feb 20, 2008 5:22 pm

Hi Janisk,

Yes it work, I had something bad in my configuration, It seems work well. I will continue with my test.

Thanks,

Kike.

---- UPDATED ---

On EoIP can't use multicast routing, I think this is a temporal "solution" while you solve the problem with the routing pim.
 
phendry
Member Candidate
Member Candidate
Posts: 258
Joined: Fri May 28, 2004 4:42 pm

Re: multicast routing

Sat Feb 23, 2008 11:38 am

Hi guys. Is this still the case with v3.3? Also, if you have 3 wireless laptops associated and all joining the same group with a 2mbps stream should I expect to see 2mbps on the wireless of the AP or 6mbps?
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: multicast routing

Mon Feb 25, 2008 11:24 am

if AP is at the clients then yes, you should see stream to all subscribed customers
 
phendry
Member Candidate
Member Candidate
Posts: 258
Joined: Fri May 28, 2004 4:42 pm

Re: multicast routing

Mon Feb 25, 2008 1:02 pm

if AP is at the clients then yes, you should see stream to all subscribed customers
Not sure I understand your answer. Assuming the wireless AP is MT and there are multiple clients viewing the stream, will we see 1 x stream bandwidth or n x stream bandwidth?
 
kiket
Frequent Visitor
Frequent Visitor
Posts: 56
Joined: Thu Mar 02, 2006 5:32 pm

Re: multicast routing

Mon Feb 25, 2008 2:58 pm

Hi phendry,

If you use multicast routing, you can see in your server AP wireless interface 2Mb and 2Mb in any client. But can't send more than 11 Mb at the moment, since janisk fix it.

Kike
 
phendry
Member Candidate
Member Candidate
Posts: 258
Joined: Fri May 28, 2004 4:42 pm

Re: multicast routing

Mon Feb 25, 2008 3:48 pm

So 10 clients viewing a 2mbps stream will only generate 2mbps on the wireless of the AP and not 20mbps. Good stuff. Will test later today.
 
kiket
Frequent Visitor
Frequent Visitor
Posts: 56
Joined: Thu Mar 02, 2006 5:32 pm

Re: multicast routing

Mon Feb 25, 2008 7:08 pm

Yes, it's multicast.
 
phendry
Member Candidate
Member Candidate
Posts: 258
Joined: Fri May 28, 2004 4:42 pm

Re: multicast routing

Mon Feb 25, 2008 9:52 pm

Yes, it's multicast.
I know that. Just wasn't sure if there where any issues with wireless being the layer1/2 that needs to be taken into account.
 
kiket
Frequent Visitor
Frequent Visitor
Posts: 56
Joined: Thu Mar 02, 2006 5:32 pm

Re: multicast routing

Mon Feb 25, 2008 10:28 pm

Hi Phendry,

I think the only issue in wireless is the broadcast. If 2 clients demand 1 different streams anyone, the 2 streams arrive all clients.

Kike
 
Diganet
Member
Member
Posts: 349
Joined: Sun Oct 30, 2005 9:30 pm
Location: Denmark
Contact:

Re: multicast routing

Fri Feb 29, 2008 3:11 pm

Hi Phendry,

I think the only issue in wireless is the broadcast. If 2 clients demand 1 different streams anyone, the 2 streams arrive all clients.

Kike
Why should multicast behave differently because it travels on wireless?

/Henrik
 
kiket
Frequent Visitor
Frequent Visitor
Posts: 56
Joined: Thu Mar 02, 2006 5:32 pm

Re: multicast routing

Fri Feb 29, 2008 4:38 pm

Hi Diganet,

I don't explained well in last post. Really don't have any difference, but in wireless we have to see that all the traffic from the server go trought the wireless links. For example if you have a RB600 on server, they can pull for example 30Mb and if you have two different client router, for example RB112 and RB600. If the client on RB600 demand 20 Mb in streams, the RB112 client will have problems because this RB can't pass more than 15MB?¿.

I don't test it, and could be wrong but I think it.

Kike.
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: multicast routing

Tue Mar 04, 2008 3:14 pm

AFAIK every single client will receive its own stream. and so it will be in wilress, so if 2 clients are connected to multicast single multicast group then each client will receive its stream, so AP will TX twice the stream, so each client receive its own stream.
 
Diganet
Member
Member
Posts: 349
Joined: Sun Oct 30, 2005 9:30 pm
Location: Denmark
Contact:

Re: multicast routing

Tue Mar 04, 2008 11:54 pm

AFAIK every single client will receive its own stream. and so it will be in wilress, so if 2 clients are connected to multicast single multicast group then each client will receive its stream, so AP will TX twice the stream, so each client receive its own stream.
Exactly :)

/Henrik
 
kiket
Frequent Visitor
Frequent Visitor
Posts: 56
Joined: Thu Mar 02, 2006 5:32 pm

Re: multicast routing

Wed Mar 05, 2008 2:47 pm

I don't understand because AP have to TX twice the stream if it's multicast and send it from one interface.

If 2 clients are connected to a single multicast group, then each client will receive its stream. But the AP will TX only ONE stream (the stream from single multicast group) because it use ONE interface (wireless interface). I think that using a wireless interface to TX multicast to some clients is similarly in ethernet to put a switch L2 conected to one ethernet interface, it send 1 stream and it arrive to all clients conected to this switch (in this case wireless interface).

I am wrong in something?.

By the other hand I don't see in v3.4 changelog anything refered to pim fixes, we will waiting the next.

Kike.
 
kiket
Frequent Visitor
Frequent Visitor
Posts: 56
Joined: Thu Mar 02, 2006 5:32 pm

Re: multicast routing

Thu Apr 17, 2008 12:27 am

Any news about wireless routing PIM problem? or am I the only one who have problems with it?. From the first release that support multicast go out 7 versions and the problem is there.

Thanks for all.

Kike
 
laurinkus
Member Candidate
Member Candidate
Posts: 100
Joined: Thu Aug 31, 2006 5:05 pm
Location: Europe

Re: multicast routing

Thu Apr 17, 2008 4:14 pm

This is not a problem. This is how it works and should work.

You receive multicast to your switch (or wireless router). Packets to end-user are sent using unicast
 
kiket
Frequent Visitor
Frequent Visitor
Posts: 56
Joined: Thu Mar 02, 2006 5:32 pm

Re: multicast routing

Thu Apr 17, 2008 6:05 pm

Hi laurinkus,

This is not the problem. I refer to the problem that if I connect with ethernet 2 routers using PIM I can send trought it for example 20Mb multicast traffic, but if I change the ethernet for Wireless, I can't send more than 10Mb!! (When in wireless test I can pull trought the link more than 40Mb).

Why have this problem?? the same config, the the same client, the same streaming server, but different media.

Kike.
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: multicast routing

Wed Apr 23, 2008 2:02 pm

there are certain limitation to multicast packets when these are sent over wireless. they are sent in the lowest rate and not resent ever. so you wont be able to send a lot of traffic over plain wireless, you can circumvent this by creating tunnel and routing muticast through it.
 
phendry
Member Candidate
Member Candidate
Posts: 258
Joined: Fri May 28, 2004 4:42 pm

Re: multicast routing

Fri Sep 05, 2008 7:30 pm

AFAIK every single client will receive its own stream. and so it will be in wilress, so if 2 clients are connected to multicast single multicast group then each client will receive its stream, so AP will TX twice the stream, so each client receive its own stream.
So are you saying that if the clients are all wireless laptops running VLC to receive the multicast stream then the AP will unicast to each individual client?
 
phendry
Member Candidate
Member Candidate
Posts: 258
Joined: Fri May 28, 2004 4:42 pm

Re: multicast routing

Fri Sep 05, 2008 7:36 pm

You receive multicast to your switch (or wireless router). Packets to end-user are sent using unicast
Not sure that's true. What if 2 wireless clients on main multicast router where also Multicast routers serving end users? Connectivity should still be Multicast not Unicast.

Any more success with the latest version of V3?
 
Mplsguy
MikroTik Support
MikroTik Support
Posts: 226
Joined: Fri Jun 06, 2008 5:06 pm

Re: multicast routing

Fri Sep 05, 2008 11:17 pm

Multicast (and broadcast) over wireless works over wireless depending on who is transmitting multicast packet:

If AP transmits multicast packet, packet is transmitted over air with multicast receiver address (and yes - only single copy of packet is transmitted no matter how many clients are registered). As there is no single recipient of packet, it does not get acked - therefore delivery is not reliable (no retransmissions in case somebody does not receive packet). Due to this unreliable delivery, lowest basic rate is used to ensure as reliable delivery as possible. So even if you can send unicast stream between AP and Station using 54Mpbs air rate, multicasts are sent only using 6Mbps air rate (assuming that 6Mbps is lowest basic rate).

If Station transmits multicast packet, it is transmitted over air with unicast AP receiver address (as Stations always transmit all packets to AP, and always using unicast receiver address). Due to this, delivery of multicast packets from Station to AP is reliable and subject to normal rate selection process - max throughput can be used. What complicates the matter - when AP receives multicast packet from Station, it processes it locally, but it also must send it back over the air so that the rest of stations in wireless network see it (think of AP as switch in ethernet, except that is does not have to send multiple copies of packet for all clients to receive). This causes AP to execute multicast transmission procedure as described above, therefore every multicast packet gets transmitted over air twice - first time by Station (using its transmit rate) and second time - by AP using lowest basic rate. This behaviour can be altered by disabling "forwarding" option for particular Station on AP (or for all clients using "default-forwarding" option) - disabling forwarding causes AP not to forward traffic between clients and also disables "sending back" multicasts and broadcasts received from client, because that can be considered special case of forwarding traffic between clients.

If multicast traffic is forwarded across WDS link, it is transmitted over air with unicast receiver address (remote end of WDS link) and therefore is reliable and subject to normal rate selection.

From above we can draw some conclusions, how to increase wireless network throughput:
- Ensure that unicast receiver address is used when transmitting multicast
- Increase lowest basic rate if feasible.

Some ideas on how to apply above conclusions:
- In case multicast traffic is to be delivered over point-to-point link (e.g. some backbone link), you should ensure by some means that multicasts are delivered over wireless using unicast receiver address. This can be achieved by using tunnels (as previously discussed) or by using WDS links (either AP-to-AP WDS or AP-to-StationWDS WDS link). If WDS links are used, care must be taken not to inject multicasts in regular wireless interface (to avoid regular AP multicast transmission procedure).
- In case WDS can not be used, network should be planned so that Station is transmitting multicasts and AP should have forwarding disabled.
- In case multicasts are to be delivered to multiple destinations in wireless network, it is best to organize network such that AP is transmitting multicasts (because AP will transmit just one copy) and increase lowest basic rate, if throughput is not enough.
 
magnavox
Member
Member
Posts: 339
Joined: Thu Jun 14, 2007 1:03 pm

Re: multicast routing

Thu Dec 17, 2009 3:32 pm

Tanx Janisk, now vlc works well on mikrotik router. I have change pim config:

#####configuration script for router A
###

/ip address
add address=10.0.2.1/24 interface=ether1
add address=10.0.0.2/24 interface=ether2

/ip route
ip route add dst-address=10.0.1.0/24 gateway=10.0.0.1

/routing pim interface
add

/routing pim rp
add address=10.0.0.2

#####configuration script for router B
###

/ip address
add address=10.0.1.1/24 interface=ether1
add address=10.0.0.1/24 interface=ether2

/ip route
ip route add dst-address=10.0.2.0/24 gateway=10.0.0.2

/routing pim interface
add interface=ether1
add interface=ether2

/routing pim rp
add address=10.0.0.2

the only problem is "leaving channel": when I stop vlc, traffic don't stop!
I'm waiting for Rc11!!

best regard

---------------FV-----------------
Hi, your multicat config is working? can help me?
Best Regards...
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: multicast routing

Wed Dec 23, 2009 2:34 pm

maybe you could specify what exactly is not working with what configuration?
 
TerAnYu
newbie
Posts: 25
Joined: Sun Jun 20, 2010 1:46 pm
Location: Russia, Novosibirsk

Re: multicast routing

Tue Aug 26, 2014 9:28 pm

Hello!
This configuration not worked, not transfer stream:
Stream_1
"vlc.exe" "file:///D:/stream/video_file_1.avi" :sout=#transcode{vcodec=mp2v,vb=800,acodec=mpga,ab=128,channels=2,samplerate=44100}:duplicate{dst=udp{mux=ts,dst=239.0.0.1:1234},dst=display} :sout-keep
Stream_2
"vlc.exe" "file:///D:/stream/video_file_2.avi" :sout=#transcode{vcodec=mp2v,vb=800,acodec=mpga,ab=128,channels=2,samplerate=44100}:duplicate{dst=udp{mux=ts,dst=239.0.0.2:1234},dst=display} :sout-keep
#####configuration script for router A
###

/ip address
add address=10.0.2.1/24 interface=ether1
add address=10.0.0.2/24 interface=ether2

/ip route
ip route add dst-address=10.0.1.0/24 gateway=10.0.0.1

/routing pim interface
add

/routing pim rp
add address=10.0.0.2
#####configuration script for router B
###

/ip address
add address=10.0.1.1/24 interface=ether1
add address=10.0.0.1/24 interface=ether2

/ip route
ip route add dst-address=10.0.2.0/24 gateway=10.0.0.2

/routing pim interface
add interface=ether1
add interface=ether2

/routing pim rp
add address=10.0.0.2
Client playlist.m3u
#EXTM3U
#EXTINF:0,Stream_1
udp://@239.0.0.1:1234
#EXTINF:0,Stream_2
udp://@239.0.0.2:1234
Please help configure PIM
You do not have the required permissions to view the files attached to this post.
ROS: 6.[latest]
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: multicast routing

Wed Aug 27, 2014 9:09 am

what active source joins you see?

are there join requests from the customer registered correctly?

do you see stream packets, how far they go?

What is the TTL of the stream packets?


this is as a basic configuration as you can get, this works. Different special cases with dynamic routing etc. may become unstable. Usually it is TTL that is set to 1 in VLC that does not work.
 
TerAnYu
newbie
Posts: 25
Joined: Sun Jun 20, 2010 1:46 pm
Location: Russia, Novosibirsk

Re: multicast routing

Thu Aug 28, 2014 6:34 pm

Thanks!
After change TTL to 3 or more - earned.
Stream_1
"vlc.exe" --ttl 4 "file:///D:/stream/video_file_1.avi" :sout=#transcode{vcodec=mp2v,vb=800,acodec=mpga,ab=128,channels=2,samplerate=44100}:duplicate{dst=udp{mux=ts,dst=239.0.0.1:1234},dst=display} :sout-keep
Stream_2
"vlc.exe" --ttl 4 "file:///D:/stream/video_file_2.avi" :sout=#transcode{vcodec=mp2v,vb=800,acodec=mpga,ab=128,channels=2,samplerate=44100}:duplicate{dst=udp{mux=ts,dst=239.0.0.2:1234},dst=display} :sout-keep
ROS: 6.[latest]

Who is online

Users browsing this forum: dynek and 62 guests