Page 1 of 1

Vlan Issues

Posted: Thu Nov 01, 2007 2:06 am
by Belyivulk
Hi All

Im having an issue with 2.9.48 & .38 with Vlans.

I have 4 routers, and i've create a vlan that works perfectly up to the 3rd router. When i add the vlan from the 4th, the whole vlan stops being able to pass IP data. I can still see things over IP Neighbour, and i can get a DHCP lease, but cannot pass traffic. I also tried setting the wireless interface into WDS and adding the WDS interface into the bridge with the vlan, but that results in the same problem.

Occasionally, though not all the time, i will also see a packet storm happen.

I've replaced the 3rd router :)

Routed works fine, i can get to the 4th router when using routed, but in this case i need to use Vlans

The routers arrived to me running .38 and i have upgraded to .48 due to the issue im having.

Has anyone got any suggestions?

Re: Vlan Issues

Posted: Thu Nov 01, 2007 5:43 am
by Belyivulk

So far i've tried downgrading the routers, system resetting the routers, only running one Vlan, bridging the wds interface in with the vlan, all of it results in the same thing.

I also get a packet storm everytime i do it. Ideas??

Edit: To narrow it down even further, anytime i add any interface to the bridge, on the 3rd router, that router can no longer ping the other end of the vlan. If i disable the port, it pings correctly again.

Re: Vlan Issues

Posted: Thu Nov 01, 2007 7:03 am
by BrianHiggins
sounds like you have a bridge loop... either figure out where the loop is at, or enable spanning tree on at least one of the bridge interfaces

Re: Vlan Issues

Posted: Thu Nov 01, 2007 7:57 am
by Belyivulk
Could you explan a little better for me? That makes no sense to me (sorry)

Re: Vlan Issues

Posted: Thu Nov 01, 2007 10:54 am
by Belyivulk
I enabled STP on all the bridges, that stopped the packet storm, but i still cant seem to pass data, and the problem still persists with data ceasing to pass on the 3rd router when i add the 4th into the bridge.

Interestingly, the 4th router can get a DHCP lease but not ping the other side