Community discussions

MikroTik App
 
ccnakramcse
just joined
Topic Author
Posts: 4
Joined: Mon Sep 24, 2007 12:18 pm

port forwarding and NAT

Sun Nov 04, 2007 4:23 pm

Image

As simple as this
You can see my network in picture above my problem is in port forwarding for using torrent I add port forwarding to the ADSL modem and as you can see in picture that I have to configure NAT in MikroTik OS can anyone help me just to know how to let torrent work in 192.168.7.50 ... and thanx for every one how can help me
 
User avatar
antefe
Frequent Visitor
Frequent Visitor
Posts: 57
Joined: Fri Oct 12, 2007 12:36 pm
Location: Crete-Greece

Re: port forwarding and NAT

Sun Nov 04, 2007 4:47 pm

this is the rules i use in ip-firewall-nat
1 ;;; Forward port 1750-1752 TCP (utorrent) from WAN to my laptop
chain=dstnat action=dst-nat to-addresses=10.255.255.251
to-ports=1750-1752 in-interface=wan dst-port=1750-1752 protocol=tcp

2 ;;; Forward port 1750-1752 UDP (utorrent) from WAN to my laptop
chain=dstnat action=dst-nat to-addresses=10.255.255.251
to-ports=1750-1752 in-interface=wan dst-port=1750-1752 protocol=udp

10.255.255.251 is the is of my laptop
wan interface is the interface connected to my modem

the only thing that can go wrong with your configuration is that I'm not sure that forwarding a range of ports from your modem to only one port in MT will work...
 
User avatar
Letni
Member
Member
Posts: 375
Joined: Tue Dec 05, 2006 5:16 am
Location: South Carolina

Re: port forwarding and NAT

Sun Nov 04, 2007 4:55 pm

/ip firewall nat
add action=dst-nat chain=dstnat comment="" disabled=no dst-address=192.168.10.1 dst-port=6881-6999 protocol=tcp to-addresses=192.168.7.50 to-ports=6881-6999
add action=dst-nat chain=dstnat comment="" disabled=no dst-address=192.168.10.1 dst-port=6881-6999 protocol=udp to-addresses=192.168.7.50 to-ports=6881-6999
 
User avatar
antefe
Frequent Visitor
Frequent Visitor
Posts: 57
Joined: Fri Oct 12, 2007 12:36 pm
Location: Crete-Greece

Re: port forwarding and NAT

Sun Nov 04, 2007 8:53 pm

it seems that he doesn't forward these port on the same ones...
 
ccnakramcse
just joined
Topic Author
Posts: 4
Joined: Mon Sep 24, 2007 12:18 pm

Re: port forwarding and NAT

Sun Nov 04, 2007 10:10 pm

Thanxx a lot Letni I own you one … I used your solution .. and it works … thanxx again
And thanxx for you antefe for your help…
 
foffa
newbie
Posts: 32
Joined: Fri Aug 17, 2007 1:23 am

Re: port forwarding and NAT

Thu Nov 08, 2007 8:33 pm

i will try this and let all know

Who is online

Users browsing this forum: No registered users and 98 guests