Community discussions

MikroTik App
 
Freman
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 76
Joined: Thu Jul 01, 2004 8:49 am

2.9beta12 Lost settings on reboot?

Tue Feb 01, 2005 9:02 am

G'day there

We upgraded from 2.8.23 to 2.9beta12 to gain access to preamble settings and the ability to change mac addresses... which all worked GREAT...

Except when we turn of the AP/Router and turn it back on, it returns to the way it was configured in 2.8.23 (but with the 2.9beta12 software installed) it's almost like there's a write protected file.

Can anyone give me any help with this?

Perhaps I should install off a CD not over ftp?

Thanks
 
Freman
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 76
Joined: Thu Jul 01, 2004 8:49 am

Tue Feb 01, 2005 10:21 am

Ok, further testing has found...

All settings work well until you change the mac address of the wireless interface and reboot, after that the wireless interface gets completely trashed.

Example configuration -> Fresh install
/interface print
/interface set ether1 disabled=no
/interface set wlan1 disabled=no
/interface wireless set wlan1 mode=bridge-ap name=senao preamble-mode=short ssid="office" mac-address=00093859345f
/interface bridge add name=bridge1
/interface bridge port set ether1 bridge=bridge1
/interface bridge port set wlan1 bridge=bridge1
/ip address add address=192.168.0.90/24 interface=bridge1

There a working AP

/interface print
0 R ether1 ether etc, etc, etc
1 R senao wlan etc, etc, etc
2 R bridge1 bridge etc, etc, etc

There you have a working ap, and it works wonderfully until... you reboot

hmmm comes up no workie?

/interface print
0 R ether1 ether etc, etc, etc
1 R bridge1 bridge etc, etc, etc
2 X wlan1 wlan etc, etc, etc

It's almost like someone pulled out the senao card and swapped it.

But if you repeat exactly the same configuration with out the mac-address setting, you can reboot as much as you like without loosing the senao

- This also happens when we try the same with the athros card we have, so it's not hardware related...

Perhaps when we change the mac address the router is saving the mac address over the stored card address then on boot is looking for the "new" mac address and not the REAL mac address..

Who is online

Users browsing this forum: bbond007, riyoritsu, tongjinooi, Znevna and 240 guests