Page 1 of 1

mikrotik hotspot users having problem with EMULE!!!

Posted: Tue Feb 01, 2005 11:38 pm
by spavkov
Hi

Does anybody has some expirience with setting up mikrotik firewall so that users behind MIKROTIK can use EMULE program ...???

it seems that my users always get LOW ID when they log on some EMULE servers... and their ul/dl speed is not fast as it could be (only2-8 kb/s)

I opened the ports that are needed (i read intrustions on emule web site) but its still the same...

i opened ports 4662, 4672, 4661, and 4665 but its not helping...

my users are wireless hotspot users and have a good strength...

any ideas???

Posted: Wed Feb 02, 2005 10:15 am
by Bill
It could be that the problem is from the other side. Maybe the servers they are trying to log into are being rate-limited. Remember that the upload for most connections is usually much lower than the download.

Many service providers are using the P2P control features of MT to keep this type of traffic under control. Check your firewall rules and make sure there are no P2P limiting rules in place.

Posted: Wed Feb 02, 2005 6:19 pm
by spavkov
Now i put destination nat firewall rule to NAT all incoming traffic to TCP port 4662 to one ip address (for example 10.5.50.39) and then its all working fine...

it looks like this in destination NAT firewall rule :
dst-address=:4662 protocol=tcp action=nat
to-dst-address=10.5.50.39 to-dst-port=4662

but only for this ip address, and other hotspot users cannot even log to emule servers anymore... :cry:

is it possible to nat to multiple addresses, for example to range of addresses..?

if not, is there a solution so that all my users can log in to emule servers and have a high id ??

Posted: Wed Feb 02, 2005 11:00 pm
by jarosoup
If you've got a lot of public IPs, you could 1-to-1 NAT to each eMule user. If not, I'm not sure there's much you can do unless each user can specify a different port range for their client and then you could forward the way you are now to each user's port range.

Posted: Fri Feb 04, 2005 12:23 am
by spavkov
hey jarosoup !!!

Thumbs up man!!!

your clue solved my emule problem !!!

tanx a million times !!!!

:lol:
.