Community discussions

MikroTik App
 
nemecio
newbie
Topic Author
Posts: 30
Joined: Wed Sep 05, 2007 11:57 pm
Location: Q.Roo, Mexico

Voip QOS, what am I doing wrong?

Thu Nov 15, 2007 8:48 am

Hello all,

I need some help, i saw in a post that this is the right way to prioritize voip trafic for bandwidth hog vonage....

I did copy this from someone else but do not seem to work... i still get broken voice when trying my calls...

Any help would be appreciated...

Those are my firewall mangle rules...

Flags: X - disabled, I - invalid, D - dynamic
0 chain=prerouting dst-port=10000-20000 protocol=udp
connection-mark=VoIPConn action=mark-connection
new-connection-mark=VoIPConn passthrough=yes

1 chain=prerouting connection-mark=VoIPConn action=mark-packet
new-packet-mark=VoiPAck passthrough=no

2 chain=postrouting dst-port=10000-20000 protocol=udp
connection-mark=VoIPConn action=mark-connection
new-connection-mark=VoIPConn passthrough=yes

3 chain=postrouting connection-mark=VoIPConn action=mark-packet
new-packet-mark=VoiPAck passthrough=no

4 chain=forward p2p=all-p2p limit=1,5 action=mark-connection
new-connection-mark=p2p_conn passthrough=yes

5 chain=forward connection-mark=p2p_conn limit=1,5 action=mark-packet
new-packet-mark=p2p passthrough=yes


And these are my queue tree rules:

0 name="VoIP" parent=global-total packet-mark=VoiPAck limit-at=128000
queue=default priority=1 max-limit=128000 burst-limit=0
burst-threshold=0 burst-time=0s

1 name="P2P_in" parent=global-in packet-mark=p2p limit-at=3000 queue=default
priority=8 max-limit=64000 burst-limit=0 burst-threshold=0 burst-time=0s

2 name="P2P_out" parent=global-out packet-mark=p2p limit-at=3000
queue=default priority=8 max-limit=32000 burst-limit=0 burst-threshold=0
burst-time=0s

The p2p rule seems to work since i do get some readings out of it.

But VOIp i get nothing....

Please help....

Saludos From mexico
Sooner or later, those who win are those who think they can... Paul Tournier
 
User avatar
tgrand
Long time Member
Long time Member
Posts: 671
Joined: Mon Aug 21, 2006 2:57 am
Location: Winnipeg, Manitoba, Canada

Re: Voip QOS, what am I doing wrong?

Thu Nov 15, 2007 2:39 pm

0 chain=prerouting dst-port=10000-20000 protocol=udp
connection-mark=VoIPConn action=mark-connection
new-connection-mark=VoIPConn passthrough=yes

This rule is only going to mark VoIPConn only if it is already marked VoIPConn.
Try this:

0 chain=prerouting dst-port=10000-20000 protocol=udp
action=mark-connection
new-connection-mark=VoIPConn passthrough=yes

However ports 10000-20000 could also be used for p2p, so move the rule below the packet marking for p2p.
 
nemecio
newbie
Topic Author
Posts: 30
Joined: Wed Sep 05, 2007 11:57 pm
Location: Q.Roo, Mexico

Re: Voip QOS, what am I doing wrong?

Thu Nov 15, 2007 5:58 pm


However ports 10000-20000 could also be used for p2p, so move the rule below the packet marking for p2p.
I have read the "move rule" "place rule first" so on and so forth but dont know how to "move" them around...

It must be something really stupid but i have not been able to figure out how to "move" rules around.

The only way i figured out to "move" the rule was to disable rule 0 and place a new rule at the end of the list....

Thank you for the swift reply....

Now it looks like this already modified:

Flags: X - disabled, I - invalid, D - dynamic
0 X chain=prerouting dst-port=10000-20000 protocol=udp action=mark-connection
new-connection-mark=VoIPConn passthrough=yes

1 chain=prerouting connection-mark=VoIPConn action=mark-packet
new-packet-mark=VoiPAck passthrough=no

2 chain=postrouting dst-port=10000-20000 protocol=udp
connection-mark=VoIPConn action=mark-connection
new-connection-mark=VoIPConn passthrough=yes

3 chain=postrouting connection-mark=VoIPConn action=mark-packet
new-packet-mark=VoiPAck passthrough=no

4 chain=forward p2p=all-p2p limit=1,5 action=mark-connection
new-connection-mark=p2p_conn passthrough=yes

5 chain=forward connection-mark=p2p_conn limit=1,5 action=mark-packet
new-packet-mark=p2p passthrough=yes

6 chain=prerouting dst-port=10000-20000 protocol=udp action=mark-connection
new-connection-mark=VoIPConn passthrough=yes
Sooner or later, those who win are those who think they can... Paul Tournier
 
User avatar
GWISA
Member
Member
Posts: 394
Joined: Tue Jan 31, 2006 2:37 pm
Location: Johannesburg, South Africa

Re: Voip QOS, what am I doing wrong?

Mon Nov 19, 2007 4:14 pm

I would identify the VoIP traffic by server IP if possible...

And to move rule, simply drag it to where you want it to be in winbox...
 
nowires
Frequent Visitor
Frequent Visitor
Posts: 51
Joined: Thu Apr 05, 2007 5:51 pm

Re: Voip QOS, what am I doing wrong?

Mon Nov 19, 2007 5:46 pm

I would identify the VoIP traffic by server IP if possible...
In my opinion it's the best way.
 
nemecio
newbie
Topic Author
Posts: 30
Joined: Wed Sep 05, 2007 11:57 pm
Location: Q.Roo, Mexico

Re: Voip QOS, what am I doing wrong?

Mon Nov 19, 2007 7:09 pm

And to move rule, simply drag it to where you want it to be in winbox...
I told you it would be something easy.... (it's the kind of stuff newbies want to learn but is documented nowhere)

Thank you, now I can "move" the rules all over the place as needed...

Have a great day....
Sooner or later, those who win are those who think they can... Paul Tournier

Who is online

Users browsing this forum: elvo3d, eworm, menelaos, nozlaf, reman6110 and 185 guests