Community discussions

MikroTik App
 
Binayak
just joined
Topic Author
Posts: 14
Joined: Fri Dec 08, 2006 4:11 pm
Location: Mumbai, India

BGP on Mikrotik

Thu Nov 22, 2007 7:08 pm

hello all,

We were looking ahead to implement BGP in our network, we have level 5 licence on our Mikrotik router. we are taking BGP for multi-homing with multiple ISPs over Internet.

I would like to know, if mikrotik can perform well with it and what things should taken care of before implementing BGP over mikrotik. How sucessfull it is till date.

THank

Binayak
 
User avatar
NetTraptor
Frequent Visitor
Frequent Visitor
Posts: 73
Joined: Tue May 17, 2005 4:12 pm
Location: Athens Greece
Contact:

Re: BGP on Mikrotik

Sat Nov 24, 2007 1:53 am

Leaving out some hickups that appear know and then.. it works OK. Not as good as quagga or cisco IOS but its OKish.

We have been using it in our community for almost 2 years know. :)
 
bokili
Member Candidate
Member Candidate
Posts: 135
Joined: Wed Aug 16, 2006 8:52 pm

Re: BGP on Mikrotik

Mon Dec 10, 2007 2:45 pm

Leaving out some hickups that appear know and then.. it works OK. Not as good as quagga or cisco IOS but its OKish.

We have been using it in our community for almost 2 years know. :)
Do you use it for public IP ranges?
Is it stable?

Anybody who can comment if use BGP for public IPs ?
 
paulos
just joined
Posts: 1
Joined: Wed Jun 06, 2007 11:33 am

Re: BGP on Mikrotik

Tue Dec 11, 2007 11:22 am

We are trying to set-up a new Internet Exchange in Malawi and we have worked out a router configuration using cisco bgp 4 as shown below. Now some us want to use Mikrotik router on the RB532 board and we are wondering how to convert our worked out cisco config to a corresponding mikrotik config.
- Could anyone please show us how to do a "peer-group" as done on the cisco config below?
- how do we do a corresponding router-map?
- what is the corresponding filter specification?

thanks in advance

Router> enable
Router# config terminal
Router(config)# hostname ISPA

ISPA(config)# no ip domain-lookup

ISPA(config)#interface loopback 0
ISPA(config-if)#ip address 172.30.0.7 255.255.255.255

ISPA(config)#interface Ethernet0
ISPA(config-if)# ip address 172.30.1.7 255.255.255.0
ISPA(config-if)#no shutdown

! will be replaced by our wlan interface on mikrotik
ISPA(config)#interface Serial1
ISPA(config-if)# ip address 192.168.0.1 255.255.255.0
ISPA(config-if)# clockrate 64000
ISPA(config-if)# no shutdown

ISPA(config)#router bgp 33773
ISPA(config-router)# no synchronization
ISPA(config-router)# no auto-summary
ISPA(config-router)#bgp log-neighbor-changes

ISPA(config-router)#network 196.45.188.0 mask 255.255.252.0
ISPA(config-router)#network 198.32.68.0 mask 255.255.255.0

ISPA(config-router)#neighbor IXP-peers peer-group
ISPA(config-router)#neighbor IXP-peers password sameforallpeers
ISPA(config-router)#neighbor IXP-Peers send-community
ISPA(config-router)#neighbor IXP-Peers version 4
ISPA(config-router)#neighbor IXP-Peers soft-reconfiguration inbound
ISPA(config-router)#neighbor IXP-Peers ebgp-multihop 3

ISPA(config-router)#neighbor 172.30.0.1 remote-as 65501
ISPA(config-router)#neighbor 172.30.0.1 update-source loopback 0
ISPA(config-router)#neighbor 172.30.0.1 description EBGP with Burco
ISPA(config-router)#neighbor 172.30.0.1 peer-group IXP-peers

ISPA(config-router)#neighbor 172.30.0.2 remote-as 65502
ISPA(config-router)#neighbor 172.30.0.2 update-source loopback 0
ISPA(config-router)#neighbor 172.30.0.2 description EBGP with CoM
ISPA(config-router)#neighbor 172.30.0.2 peer-group IXP-peers

ISPA(config-router)#neighbor 172.30.0.3 remote-as 65503
ISPA(config-router)#neighbor 172.30.0.3 update-source loopback 0
ISPA(config-router)#neighbor 172.30.0.3 description EBGP with Skyband
ISPA(config-router)#neighbor 172.30.0.3 peer-group IXP-peers

ISPA(config-router)#neighbor 172.30.0.4 remote-as 65504
ISPA(config-router)#neighbor 172.30.0.4 update-source loopback 0
ISPA(config-router)#neighbor 172.30.0.4 description EBGP with CompLand
ISPA(config-router)#neighbor 172.30.0.4 peer-group IXP-peers

ISPA(config-router)#neighbor IXP-Peers send-community
ISPA(config-router)#neighbor IXP-Peers route-map Net-No-Export out
ISPA(config)#route-map Net-No-Export permit 10
ISPA(config-route-map)set community no-export

ISPA(config)#route-map Net-No-Export permit 20

ISPA(config-router)#neighbor 172.30.0.1 maximum-prefix 100
ISPA(config-router)#neighbor 172.30.0.2 maximum-prefix 100
ISPA(config-router)#neighbor 172.30.0.3 maximum-prefix 100
ISPA(config-router)#neighbor 172.30.0.4 maximum-prefix 100

ISPA(config-router)#neighbor IXP-peers filter-list 1 out
ISPA(config-router)#neighbor IXP-peers filter-list 2 in

ISPA(config-router)#ip as-path access-list 1 permit ^$
ISPA(config-router)#ip as-path access-list 2 permit ^(65501|65502|65503|65504)$

ISPA(config-router)#neighbor IXP-peers prefix-list out-nets out
ISPA(config-router)#neighbor IXP-peers prefix-list in-nets in

ISPA(config)#ip prefix-list in-nets seq 5 permit 172.30.0.0/30 le 32
ISPA(config)#ip prefix-list in-nets seq 10 permit 172.30.1.0/24

ISPA(config)#ip prefix-list in-nets seq 20 deny 10.0.0.0 /8 le 32
ISPA(config)#ip prefix-list in-nets seq 25 deny 172.16.0.0/12 le 32
ISPA(config)#ip prefix-list in-nets seq 30 deny 192.168.0.0/16 le 32
ISPA(config)#ip prefix-list in-nets seq 35 permit 0.0.0.0/0 le 32

ISPA(config)#ip prefix-list out-nets seq 5 permit 172.30.0.0/30 le 32
ISPA(config)#ip prefix-list out-nets seq 10 permit 172.30.1.0/24

ISPA(config)#ip prefix-list out-nets seq 20 deny 10.0.0.0 /8 le 32
ISPA(config)#ip prefix-list out-nets seq 25 deny 172.16.0.0/12 le 32
ISPA(config)#ip prefix-list out-nets seq 30 deny 192.168.0.0/16 le 32
ISPA(config)#ip prefix-list out-nets seq 35 permit 0.0.0.0/0 le 32

ISPA(config)#ip route 172.30.0.1 255.255.255.255 172.30.1.1
ISPA(config)#ip route 172.30.0.2 255.255.255.255 172.30.1.2
ISPA(config)#ip route 172.30.0.3 255.255.255.255 172.30.1.3
ISPA(config)#ip route 172.30.0.4 255.255.255.255 172.30.1.4

! If you can’t see your own networks in your BGP table, add:

ISPA(config)#ip route 196.45.188.0 255.255.252.0 null0
ISPA(config)#ip route 194.42.96.224 255.255.255.240 null0
ISPA(config)#ip route 198.32.68.0 255.255.255.0 null0

Who is online

Users browsing this forum: rubenheyrman and 76 guests