Page 1 of 1

Simple Queues, Working on RC11?

Posted: Tue Dec 04, 2007 10:26 pm
by savage
/queue simple
add burst-limit=4000000/128000 burst-time=1m/1m comment="" direction=both disabled=no dst-address= interface=VLAN1001 limit-at=384000/128000 \
    max-limit=4000000/128000 name="VLAN1001" parent=none priority=8 queue=default-small/default-small total-queue=default-small
Yet, a simple test with SCP THROUGH the router, I am achieving 14Mbps upload, and 20Mbps download (from the client side).... Either I am doing something horribly wrong, or simple queues are horribly broken :(

EDIT: Seems that neither torch nor queues pick up traffic properly on VLAN interfaces. 99.9999% of the 14MB traffic on the Ethernet interface, is on VLAN1001, I can't do jack to limit the traffic currently :(

Re: Simple Queues, Working on RC11?

Posted: Wed Dec 05, 2007 5:02 am
by jacoblydon
Umm, are you setting Simple Queues on client device on AP? I have found that in my situation, I can get a more precise bandwidth control from AP side rather than client side. I usually have to manually set queues higher than the the default drop down list on Mikrotik O.S. example if I want customer to have 768k download I will manually set download to about 900k. Maybe this doesn't help your situation.

Re: Simple Queues, Working on RC11?

Posted: Wed Dec 05, 2007 8:47 am
by savage
No, this is a core router with 8 Ethernet interfaces, the VLAN's are running on the 'Internal Interface' which is Ethernet, and pushing traffic nicely, regardless of the fact that it -should- be no more than 4mbit...

-shrugs- Maybe it's time to just go back to 2.9... 3.0 has far to much issues lately...

Re: Simple Queues, Working on RC11?

Posted: Wed Dec 05, 2007 10:07 am
by sergejs
You have to specify 'target-address' for 'queue simple' entries.
It could be network address.

Re: Simple Queues, Working on RC11?

Posted: Wed Dec 05, 2007 10:11 am
by savage
Tried that, didn't change anything...

Whether the queue works or not, why does torch not even pick up the traffic on the VLAN?

Re: Simple Queues, Working on RC11?

Posted: Wed Dec 05, 2007 10:15 am
by sergejs
Are you sure there is traffic on the VLAN interface ?
What do you see when you torch for "Internal Network' interface ?

Re: Simple Queues, Working on RC11?

Posted: Wed Dec 05, 2007 10:27 am
by savage
/ip address export <snipped>
221 VLAN1001 >

Yes, is on VLAN1001, as indicated by torch, my session over the VLAN Interface to Winbox is showing.
/interface vlan
add arp=enabled comment="" disabled=no interface="Internal Network" mtu=1500 name="VLAN1001" vlan-id=1001

/interface ethernet
set 4 arp=enabled auto-negotiation=yes cable-settings=default comment="Internal Network" disable-running-check=yes disabled=no full-duplex=yes \
    mac-address=00:E0:18:84:A4:24 mtu=1500 name="Internal Network" speed=100Mbps

/ip address
add address= broadcast= comment="Internal Network" disabled=no interface="Internal Network" network=


add address= broadcast= comment="" disabled=no interface=VLAN1001 network=
It's impossible that could be talking over the Internal interface, then the VLAN on the Mikrotik would be leaking traffic, which is just as bad...

Re: Simple Queues, Working on RC11?

Posted: Thu Dec 06, 2007 3:24 pm
by savage

Traffic is going through the VRRP 'Interface', and not through the VLAN interface...

Scenario 1: I limit traffic on the VRRP Interface, customer change his default route to go to the physical address instead of the virtual address, he bypasses the queues

Scenario 2: I limit traffic on the VLAN Interface, customer change his default route to the virtual address and bypass queues.

Scenario 3: I setup two queues on both the interfaces, customer does fancy routing, and gets double the traffic he is limited at (4MB Down on the Virtual Interface, 4MB Down on the physical Interface). Three times more considering he can also use the physical interface on the 2nd router, as a gateway


How do we limit traffic on VRRP interfaces? How do we implement firewalls on VRRP interfaces without doing everything twice... I guess, at the end of the day, VRRP is STILL not working ( I'm -definately- not terminating 200+ VLANs on a Mikrotik when 1) I can't effectively manage the traffic (Queues / Firewalls / etc), or 2) there is no redundancy because I can't 'use' VRRP. So again (or is that still?)... Can VRRP please be fixed?