Community discussions

 
User avatar
BrianHiggins
Long time Member
Long time Member
Topic Author
Posts: 598
Joined: Mon Jan 16, 2006 6:07 am
Location: Norwalk, CT
Contact:

v4.0 Feature Request(s)

Fri Jan 25, 2008 8:24 pm

100% new version of NStream (NOT backwards compatable) to include advanced polling, full QOS, reduced latency, dynamic frequency selection WITHOUT disconnecting active clients, automaticly adjusting framing policy (that does not affect QOS)

New version of NStream Dual with automatic fall back to half duplex if one link fails

full antenna diversity support for regular 802.11a/b/g mode

full support for 802.11n and WiMax

ability to read every value displayed in winbox via SNMP, plus create custom snmp OIDs for values calculated through scripts
 
User avatar
roadrunner
Frequent Visitor
Frequent Visitor
Posts: 86
Joined: Thu May 18, 2006 11:22 pm
Location: US

Re: v4.0 Feature Request(s)

Fri Jan 25, 2008 9:24 pm

Isn't the next version number going to be 3.2.x or 3.1.x instead of 4.0? They had the 2.9.x, 2.8.x, 2.7.x, etc. series before 3.0.
full support for 802.11n and WiMax
I think Mikrotik have stated they will both be supported when they are supported in Linux with stable drivers.


A feature I would like to request is a 'PPP IP pool' that works like the DHCP lease table that is stored periodically. I would like my PPPoE users to get the same IP address, if available, even after rebooting my Mikrotik PPPoE server/router.
 
User avatar
BrianHiggins
Long time Member
Long time Member
Topic Author
Posts: 598
Joined: Mon Jan 16, 2006 6:07 am
Location: Norwalk, CT
Contact:

Re: v4.0 Feature Request(s)

Fri Jan 25, 2008 10:45 pm

Isn't the next version number going to be 3.2.x or 3.1.x instead of 4.0? They had the 2.9.x, 2.8.x, 2.7.x, etc. series before 3.0.
If you read the new description of this board, it states "BETA Testing and Feature Suggestions for the next RouterOS release (ROS v4)".
A feature I would like to request is a 'PPP IP pool' that works like the DHCP lease table that is stored periodically. I would like my PPPoE users to get the same IP address, if available, even after rebooting my Mikrotik PPPoE server/router.
you can already make PPPoE assign IPs out of a pool, if you want them to be static, assign them that way (most ISPs charge the customer a small monthly fee for a static IP).
 
User avatar
roadrunner
Frequent Visitor
Frequent Visitor
Posts: 86
Joined: Thu May 18, 2006 11:22 pm
Location: US

Re: v4.0 Feature Request(s)

Fri Jan 25, 2008 11:20 pm

it states "BETA Testing and Feature Suggestions for the next RouterOS release (ROS v4)".
Thanks, I found that info after posting. I haven't been in the forums much since 3.0 final was released.
you can already make PPPoE assign IPs out of a pool, if you want them to be static, assign them that way (most ISPs charge the customer a small monthly fee for a static IP).
I was just wanting semi-static pool like DHCP does. DHCP tries to assign the same IP address to a machine/mac address when a DHCP client re-connects. I have setup some customer with static IP's from my RADIUS server(s). We no longer allow dial-up users to request static IP's, only DSL & Wireless customers can get Static IP addresses.
I think Mikrotik have stated they will both be supported when they are supported in Linux with stable drivers.

This post by normis sums up their position on new hardware and drivers
http://forum.mikrotik.com/viewtopic.php?p=67179#p67179
we only support chipsets that are supported by the linux kernel. we don't add custom or hacked drivers.

I saw them testing 802.11n cards at the 2007 MUM in Orlando. I also want them to support WiMax/802.16 for my network. Some of the advantages of 802.11n might not be so useful for outdoor multipoint wireless networks, but I hope support for both 802.11n & WiMax will be added when available.
 
bokili
Member Candidate
Member Candidate
Posts: 135
Joined: Wed Aug 16, 2006 8:52 pm

Re: v4.0 Feature Request(s)

Sun Jan 27, 2008 1:17 pm

100% new version of NStream (NOT backwards compatable) to include advanced polling, full QOS, reduced latency, dynamic frequency selection WITHOUT disconnecting active clients, automaticly adjusting framing policy (that does not affect QOS)

New version of NStream Dual with automatic fall back to half duplex if one link fails

full antenna diversity support for regular 802.11a/b/g mode

full support for 802.11n and WiMax

ability to read every value displayed in winbox via SNMP, plus create custom snmp OIDs for values calculated through scripts
This will be excellent features. Is it possible that mikrotik make new dual nstreme from source, to achieve more bandwidth ?
 
rpingar
Long time Member
Long time Member
Posts: 541
Joined: Fri May 28, 2004 2:46 pm
Location: Italy

Re: v4.0 Feature Request(s)

Sun Jan 27, 2008 4:29 pm

in a PtMP system we are looking to lower the latency and to have a full wireless qos with nstream. We are not looking to more bandwidth.

So my vote is to a new feature in nstream that take into account the priority, it should be selected on the AP and not on the clients. We could not use it in a ptp link but it should be useful in a ptmp.

Regards
Ros
 
User avatar
BrianHiggins
Long time Member
Long time Member
Topic Author
Posts: 598
Joined: Mon Jan 16, 2006 6:07 am
Location: Norwalk, CT
Contact:

Re: v4.0 Feature Request(s)

Tue Jan 29, 2008 11:07 pm

This will be excellent features. Is it possible that mikrotik make new dual nstreme from source, to achieve more bandwidth ?
full QOS and reduced latency will provide better bandwidth where needed through more efficient use of the airtime.
 
NickW
just joined
Posts: 16
Joined: Thu Jun 28, 2007 6:12 pm

Re: v4.0 Feature Request(s)

Wed Feb 13, 2008 6:51 pm

I'd really like to assign dynamic public IP addresses from a single pool, from my FreeRadius server.
 
hqvnet
just joined
Posts: 7
Joined: Thu Feb 14, 2008 3:00 am

Re: v4.0 Feature Request(s)

Thu Feb 14, 2008 7:21 am

01
-----
The possibility of the mark packet ttl, in the firewall to allow such ttl 128 and ttl 64, blocking the rest, avoiding the sharing of the connection linux and windows xp
-----

02
-----

In Winbox

A menu where I can write all of my ip Mikrotik

After Winbox connected, I can, switch to another ip automatically, simply just, click on the option.
Example
| 192.168.10.1 Base |
| 192.168.10.2 AP |
| 192.168.10.3 Hotspot |

When I click on the option chosen in Winbox, he now automatically connects at ip or Mac desired, without having to open another window winbox it going easy, clicked, connected.
---

03
-----

Then add more options. I have to leave now.
 
User avatar
nz_monkey
Forum Guru
Forum Guru
Posts: 1821
Joined: Mon Jan 14, 2008 1:53 pm
Location: Straya
Contact:

Re: v4.0 Feature Request(s)

Fri Feb 15, 2008 5:31 am

I would like to request 802.1f / IAPP support so that devices such as Wifi VoIP phones can roam from AP to AP without dropping out.

This would also allow devices to roam on outdoor AP's e.g. a 4 wheel motorbike with a 900mhz radio mounted could roam from AP to AP without drop outs.
http://thebrotherswisp.com/ | Mikrotik MTCNA, MTCRE, MTCINE | Fortinet FTCNA, FCNSP, FCT | Extreme Networks ENA
 
User avatar
uebi
Member Candidate
Member Candidate
Posts: 117
Joined: Tue Sep 13, 2005 5:27 pm
Location: Austria
Contact:

Re: v4.0 Feature Request(s)

Tue Mar 11, 2008 3:33 pm

A small but (at least to me) useful feature would be a tiny upgrade to Tools -> Graphing.
The graphing for queues works really great, but..... in Winbox you can also see the traffic transmitted for every queue. Would it be possible to include this value on the queue graph website where "Max-limit:" etc is listed?
I guess this would be pretty easy to implement. The graphs keep untouched but one more value (next to Max-limit, Limit-at, ...) would be included.

This would be nice, because if the amount of transmitted traffic would be shown on the website, a customer could use the graphing facility as a "cheap" accounting tool (apart from the router reboot issue) with "allow target" enabled.
Every user could browse to the Mikrotik router and see how much traffic he/she already transmitted. A script like
:local date
:local day
:set date [/system clock get date]
:set day [:pick $date 5 6]
/queue simple
:if (day = 01) do={ 
reset-counters-all 
}
could reset the counters on the 1st day of every month the the show starts again.

Anyone sharing my idea? :)


Greets,
uebi
"They have the Internet on computers now?" - Homer Simpson
 
User avatar
Ibersystems
Forum Guru
Forum Guru
Posts: 1683
Joined: Wed Apr 12, 2006 12:29 am
Location: Cabrils, Barcelona - Spain
Contact:

Re: v4.0 Feature Request(s)

Fri Mar 14, 2008 4:25 pm

Hi,

we need support for LACP. Now LACP packets can't pass over RouterOS.

This makes very simple to make redundant links without scripts.


Thanks,
Martín
 
User avatar
nz_monkey
Forum Guru
Forum Guru
Posts: 1821
Joined: Mon Jan 14, 2008 1:53 pm
Location: Straya
Contact:

Re: v4.0 Feature Request(s)

Fri Mar 14, 2008 11:28 pm

To support LACP over Bridged link's Mikrotik will need to change to using a commercial network stack such as the one from ZebOS. The linux bridge will not support this functionality. Hell they only just added support for RSTP which has been a standard for as long as I can remember, do you think the linux dev's will ever add LACP and MSTP support to it ?

ZebOS has it right now however, so is a good option.
http://thebrotherswisp.com/ | Mikrotik MTCNA, MTCRE, MTCINE | Fortinet FTCNA, FCNSP, FCT | Extreme Networks ENA
 
vlada1
Frequent Visitor
Frequent Visitor
Posts: 89
Joined: Sun Mar 04, 2007 2:18 pm

Re: v4.0 Feature Request(s)

Tue Mar 18, 2008 1:11 pm

Add this to v3 first .... then v4 lol

LDP features:

* downstream on demand label advertisement
* ordered label distribution control
* conservative label retention

MP-BGP based MPLS IP VPN
MPLS TE support using RSVP
 
User avatar
nz_monkey
Forum Guru
Forum Guru
Posts: 1821
Joined: Mon Jan 14, 2008 1:53 pm
Location: Straya
Contact:

Re: v4.0 Feature Request(s)

Wed Mar 19, 2008 5:38 am

Agreed on the MPLS features, if these were available we could sell Mikrotik kit instead of Juniper M series.
http://thebrotherswisp.com/ | Mikrotik MTCNA, MTCRE, MTCINE | Fortinet FTCNA, FCNSP, FCT | Extreme Networks ENA
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24268
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v4.0 Feature Request(s)

Wed Mar 19, 2008 9:09 am

Add this to v3 first .... then v4 lol
do you want v3 to ever be stable? ;)
No answer to your question? How to write posts
 
bokili
Member Candidate
Member Candidate
Posts: 135
Joined: Wed Aug 16, 2006 8:52 pm

Re: v4.0 Feature Request(s)

Wed Mar 19, 2008 1:17 pm

do you want v3 to ever be stable? ;)
I want this desperately!!!! :shock:
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24268
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v4.0 Feature Request(s)

Wed Mar 19, 2008 2:27 pm

do you want v3 to ever be stable? ;)
I want this desperately!!!! :shock:
good! then let's concentrate on fixing and optimising, and let's leave BIG new features for v4
No answer to your question? How to write posts
 
User avatar
Ibersystems
Forum Guru
Forum Guru
Posts: 1683
Joined: Wed Apr 12, 2006 12:29 am
Location: Cabrils, Barcelona - Spain
Contact:

Re: v4.0 Feature Request(s)

Wed Mar 26, 2008 7:47 pm

Hi,

this is a little new feature to put systems on date/time.

A button in /system/clock that when you click on it winbox take system time/data (of our computers) and actualize routerOS time/data with this system time. It's to avoid putting date/time manually when no NTP service available. One click instead of put manually all data/time parameters.

Thanks,
Martín.
 
ngds
just joined
Posts: 20
Joined: Fri Sep 15, 2006 3:41 am

Re: v4.0 Feature Request(s)

Thu Mar 27, 2008 4:23 am

I'd really like to see support for native vlans, so I can properly connect to my Cisco gear via trunks.
 
User avatar
jp
Long time Member
Long time Member
Posts: 599
Joined: Wed Mar 02, 2005 5:06 am
Location: Maine
Contact:

Re: v4.0 Feature Request(s)

Fri Mar 28, 2008 6:19 pm

I connect to HP gear using what you'd call Native VLAN. The native one would be the untagged VLAN that switch port is on and the main interface in the MT. The VLAN interface in MT would go to tagged VLANs on the same port in the switch. Not sure how the Ciscos differ, but HP tries to be fairly Cisco compatible in their switches.

Regarding NTP, unless you are on a brand new unconnected network, there is no reason why you might not be able to get NTP. Every MT can be a NTP server, so it should be trivial to have a single NTP server on your network for all your private devices. I would suggest this, especially if you need to be calea compliant, as it might be important to note the times of the data capturing.
 
gacopl
Frequent Visitor
Frequent Visitor
Posts: 63
Joined: Sun Jul 29, 2007 5:11 pm
Location: Poland

Re: v4.0 Feature Request(s)

Mon Mar 31, 2008 10:08 am

What I would really like to see is SNMP-write support please :)
 
netrat
Member
Member
Posts: 403
Joined: Thu Jun 07, 2007 1:16 pm
Location: Virginia

Re: v4.0 Feature Request(s)

Wed Apr 16, 2008 7:29 am

SCTP support
 
pedja
Long time Member
Long time Member
Posts: 684
Joined: Sat Feb 26, 2005 5:37 am

Re: v4.0 Feature Request(s)

Wed Apr 16, 2008 10:46 am

Allow option to see what actual connections are handled by specific queue rule. Torch is unusable for this, as what gets into queue depends on many factor which are not possible to handle with torch.

Allow option that shows how connections are routed within router. If there are several routes to the same destination it is very hard to find out which one is used for specific connection.
 
Wmillo
just joined
Posts: 24
Joined: Fri Apr 18, 2008 1:00 pm
Location: India

Re: v4.0 Feature Request(s)

Wed May 07, 2008 11:27 am

New access metod for PtMP system:
New scheduling for polling-nstream (not only round robin algorithm) with advanced QoS like 802.16(d-e).
Thanks
 
User avatar
BrianHiggins
Long time Member
Long time Member
Topic Author
Posts: 598
Joined: Mon Jan 16, 2006 6:07 am
Location: Norwalk, CT
Contact:

Re: v4.0 Feature Request(s)

Wed May 07, 2008 7:38 pm

New access metod for PtMP system:
New scheduling for polling-nstream (not only round robin algorithm) with advanced QoS like 802.16(d-e).
Thanks
don't forget the DFS part...
100% new version of NStream (NOT backwards compatable) to include advanced polling, full QOS, reduced latency, dynamic frequency selection WITHOUT disconnecting active clients, automaticly adjusting framing policy (that does not affect QOS)
 
Wmillo
just joined
Posts: 24
Joined: Fri Apr 18, 2008 1:00 pm
Location: India

Re: v4.0 Feature Request(s)

Thu May 08, 2008 1:07 pm

I'd like the alarm signal (or flag) if the received signal level is too high (saturation).
 
User avatar
nz_monkey
Forum Guru
Forum Guru
Posts: 1821
Joined: Mon Jan 14, 2008 1:53 pm
Location: Straya
Contact:

Re: v4.0 Feature Request(s)

Tue May 20, 2008 3:13 am

I would like to see the IPSEC implementation improved, in particular:

- Use generic names, e.g. Phase1 instead of "Peers", and Phase2 instead of "Policy", DH Group 2 instead of "modp 1024", or maybe extend the names e.g. "Peers - Phase1", "Policies - Phase2"

- Allow the use of IPSEC Tunnel Interfaces aka Route based VPN's, this will allow inter operable Dynamic routing over IPSEC with other vendors. It will also allow the use of simple firewall policies to/from the VPN interface.

- Add support for "Autokey Keep Alive"

- Change lifetimes to be measured in seconds (like every other IPSEC device in existence)

Adding these features will make it easier to understand the IPSEC process, make it easier to inter-operate with other vendors products, make it simpler to control inter-site traffic through the use of firewall policies, and make RouterOS more enterprise ready.
http://thebrotherswisp.com/ | Mikrotik MTCNA, MTCRE, MTCINE | Fortinet FTCNA, FCNSP, FCT | Extreme Networks ENA
 
hippo
just joined
Posts: 24
Joined: Wed Mar 26, 2008 2:12 pm

Re: v4.0 Feature Request(s)

Tue May 20, 2008 11:35 am

I second the request for tunnel based route based vpn:s (see nz_monkeys post).

I would also like to see support for virtual routers (vrouters,vrf...)
 
User avatar
nz_monkey
Forum Guru
Forum Guru
Posts: 1821
Joined: Mon Jan 14, 2008 1:53 pm
Location: Straya
Contact:

Re: v4.0 Feature Request(s)

Tue May 20, 2008 11:45 am

Virtual Routers/Virtual Domains is a great idea, but I would not want to be the programmers at Mikrotik trying to implement it!
http://thebrotherswisp.com/ | Mikrotik MTCNA, MTCRE, MTCINE | Fortinet FTCNA, FCNSP, FCT | Extreme Networks ENA
 
hippo
just joined
Posts: 24
Joined: Wed Mar 26, 2008 2:12 pm

Re: v4.0 Feature Request(s)

Tue May 20, 2008 4:40 pm

Actually most of the functionality for virtual routers are already in the routeros in the form of routing-tables. What needs to be added is some form of front end so that you are able to place interfaces in certain virtual-routers and make sure that traffic only hits the corresponding routing table. There also needs to be added some sort of functionality so that you can route traffic between virtual-routers (or routing tables), but I don't think it would be that hard.
 
pedja
Long time Member
Long time Member
Posts: 684
Joined: Sat Feb 26, 2005 5:37 am

Re: v4.0 Feature Request(s)

Wed May 21, 2008 9:30 am

Long time ago it was promised that we will get triggers - option that MT executes script when some condition occurs. That would help a lot preserving resources now spent on scheduled scripting.
 
User avatar
vsaldarriaga
just joined
Posts: 6
Joined: Thu Jun 26, 2008 8:48 pm
Location: Colombia

Re: v4.0 Feature Request(s)

Thu Jun 26, 2008 8:51 pm

I also second the request for tunnel based route based vpn:s (see nz_monkeys post).
Having to flush all installed-sa 's when only one problematic tunnel is the culprit of an
incomplete negotiation is also a hassle.
 
roneyeduardo
just joined
Posts: 10
Joined: Tue Sep 12, 2006 12:36 am

Re: v4.0 Feature Request(s)

Sat Jul 05, 2008 8:25 pm

Please, make a RouterOS version instalable in Ubiquity's NanoStation hardware. In it's forum, Ubiquity already stated that they would make any modification needed in their hardware to supporte RouterOS.
 
Falconix
just joined
Posts: 11
Joined: Tue May 24, 2005 2:15 am
Contact:

Re: v4.0 Feature Request(s)

Tue Aug 05, 2008 11:13 pm

XMPP(Jabber) functionality in in Router OS, send notice with scripts over XMPP.
 
QpoX
Member
Member
Posts: 387
Joined: Mon Mar 24, 2008 7:42 pm
Location: Lemvig, Denmark

Re: v4.0 Feature Request(s)

Wed Aug 06, 2008 2:08 am

Maybe some OEM support... a webserver that run's via files that the OEM corp has uploaded, files that exec commands to the RouterOS...
So that the enduser can not see that it runs RouterOS...

I think that more company's will use RouterOS that way...
It's will still be RouterOS under it all but with the resellers user-interface and Mikrotik still makes money...
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24268
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v4.0 Feature Request(s)

Wed Aug 06, 2008 8:32 am

Maybe some OEM support... a webserver that run's via files that the OEM corp has uploaded, files that exec commands to the RouterOS...
So that the enduser can not see that it runs RouterOS...

I think that more company's will use RouterOS that way...
It's will still be RouterOS under it all but with the resellers user-interface and Mikrotik still makes money...
if you are an OEM, then you would know that this is already possible
No answer to your question? How to write posts
 
QpoX
Member
Member
Posts: 387
Joined: Mon Mar 24, 2008 7:42 pm
Location: Lemvig, Denmark

Re: v4.0 Feature Request(s)

Wed Aug 06, 2008 5:04 pm

Maybe some OEM support... a webserver that run's via files that the OEM corp has uploaded, files that exec commands to the RouterOS...
So that the enduser can not see that it runs RouterOS...

I think that more company's will use RouterOS that way...
It's will still be RouterOS under it all but with the resellers user-interface and Mikrotik still makes money...
if you are an OEM, then you would know that this is already possible
I only thought a OEM chould change the logo ind the console...
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24268
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v4.0 Feature Request(s)

Thu Aug 07, 2008 9:12 am

Maybe some OEM support... a webserver that run's via files that the OEM corp has uploaded, files that exec commands to the RouterOS...
So that the enduser can not see that it runs RouterOS...

I think that more company's will use RouterOS that way...
It's will still be RouterOS under it all but with the resellers user-interface and Mikrotik still makes money...
if you are an OEM, then you would know that this is already possible
I only thought a OEM chould change the logo ind the console...
also the webpage. isn't that enough?
No answer to your question? How to write posts
 
Muqatil
Trainer
Trainer
Posts: 574
Joined: Mon Mar 03, 2008 1:03 pm
Location: London - UK
Contact:

Re: v4.0 Feature Request(s)

Thu Aug 07, 2008 1:16 pm

I would like to have a full configurable webbox selecting what i want to show on webbox (maybe only NAT rules and some few more features)
Something like the HotSpot Interface.
Renato Bernardi

skype: medtech5
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24268
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v4.0 Feature Request(s)

Thu Aug 07, 2008 1:19 pm

router OS has no built in webserver that could do these things.
No answer to your question? How to write posts
 
ottife
just joined
Posts: 13
Joined: Tue Aug 05, 2008 4:45 pm

Re: v4.0 Feature Request(s)

Thu Aug 07, 2008 5:30 pm

MESH,MESH,mature MESH protocols!!!
 
nathany
just joined
Posts: 9
Joined: Thu Jul 17, 2008 2:03 pm

Re: v4.0 Feature Request(s)

Wed Aug 13, 2008 2:37 am

I second the improved IPSEC implementation as mentioned by nz_monkeys
 
User avatar
nz_monkey
Forum Guru
Forum Guru
Posts: 1821
Joined: Mon Jan 14, 2008 1:53 pm
Location: Straya
Contact:

Re: v4.0 Feature Request(s)

Wed Aug 13, 2008 2:42 am

To the Mikrotik team. If you need access to other vendors hardware for compatibility testing with an improved IPSEC implementation please let me know.

We have hundreds of Juniper/Netscreen, Cisco, Fortinet routers/firewalls in production and can give you full access for testing.


Regards,



Andrew
http://thebrotherswisp.com/ | Mikrotik MTCNA, MTCRE, MTCINE | Fortinet FTCNA, FCNSP, FCT | Extreme Networks ENA
 
User avatar
omega-00
Forum Guru
Forum Guru
Posts: 1167
Joined: Sat Jun 06, 2009 4:54 am
Location: Australia
Contact:

Re: v4.0 Feature Request(s)

Thu Feb 05, 2009 5:31 am

MSTP support would be good to have for our larger implementations.
 
jahirg
just joined
Posts: 12
Joined: Mon Sep 22, 2008 12:29 am

Re: v4.0 Feature Request(s)

Mon Feb 09, 2009 6:28 am

I would like MKT add in routeros a special field for put one powerfull DPI engine in firewall.

MKT must be stablish a alliance with IPOQUE, They have a good software for detection in L7.

ipoque's Protocol and Application Classification Engine (PACE) helps network equipment and software vendors to enhance their products with a powerful and proven layer-7 protocol detection. PACE uses a combination of deep packet inspection (DPI) and behavioral analysis to reliably detect protocols even if they use advanced obfuscation and encryption techniques. PACE has been optimized for performance and classification reliability. It is highly flexible and can be integrated in any existing system such as firewalls, UTM appliances and WAN optimization controllers.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24268
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v4.0 Feature Request(s)

Mon Feb 09, 2009 9:49 am

so and RouterOS doesn't have this ?
http://wiki.mikrotik.com/wiki/L7
No answer to your question? How to write posts
 
cigamit
just joined
Posts: 8
Joined: Thu Jul 17, 2008 12:17 am

Re: v4.0 Feature Request(s)

Tue Feb 10, 2009 1:17 am

My feature request.

Inclusion of the ARP Cache into the SNMP ouput, just like my Cisco devices do.
RFC1213-MIB::atPhysAddress.2.1.192.168.0.150 = Hex-STRING: 00 23 5F 6E 56 76
 
scold
just joined
Posts: 3
Joined: Tue May 22, 2007 12:34 pm
Location: Hungary
Contact:

Re: v4.0 Feature Request(s)

Wed Feb 18, 2009 3:23 am

Is it possible to have tftp, snmpget (for graphs), snmptrap, machine(s) class (for usermanager), optional usermanager backend compatibility (radius, ldap), in RouterOS, please?
 
msundman
Frequent Visitor
Frequent Visitor
Posts: 76
Joined: Thu Jan 15, 2009 2:44 pm
Location: Stockholm, Sweden
Contact:

Re: v4.0 Feature Request(s)

Wed Feb 18, 2009 10:31 am

Here's my list:

* Route/interface based IPsec (0/0 - 0/0) (nz_monkey)

* vrouters (Metarouter on RB1000 might do the trick)

* Ethernet interface error statistics via CLI/Winbox

* Improved sniffer that allows to easily from cmdline filter and print sniffed packets in realtime. Just like running tcpdump from a shell on a Linux firewall.

* Improved OpenVPN features: UDP, CCD-files, Multiple instances

* The torch on interface feature in winbox is awsome! I'd like to be able to do that on individual firewall filter rules as well! You can already see the counters on how much traffic is matched by each rule, so if I could just right click on a rule and select torch (or sniff) to see what accual traffic is matched by the rule it would be really even cooler :)
 
User avatar
omega-00
Forum Guru
Forum Guru
Posts: 1167
Joined: Sat Jun 06, 2009 4:54 am
Location: Australia
Contact:

Re: v4.0 Feature Request(s)

Sun Feb 22, 2009 4:02 pm

Can we get another option on the user accounts for the router that allows us to disable the 'show password' option?

Currently you can use the 'password' option to disable access to user account editing, but I don't know how I can give someone guest access without giving them all my pppoe and pptp client passwords at the moment.
 
User avatar
roc-noc.com
Forum Veteran
Forum Veteran
Posts: 869
Joined: Sun Dec 02, 2007 3:27 am
Location: Rockford, IL USA
Contact:

Re: v4.0 Feature Request(s)

Sun Feb 22, 2009 4:56 pm

I would like MT to cooperate with other vendors such as Ubiquiti for things like NSTREAM, or loading RouterOS onto their platform. (Ubnt needs to have some form of a polling protocol that is able to work with RouterOS) Many people here use MT as access points and Ubnt as the client CPE devices, but at the moment there is no option for polling. Ubnt has asked for your cooperation before (From what I was told) and you did not give them any.

I find Ubnt goes out of their way to cooperate with YOU and to work with MT hardware and even MT BUGS sometimes.

I think it would be fair to have MT cooperate with a company that tries its hardest to make it's gear compatible with yours, even though yours is not compatible with many other vendors.

(This is not a "feature" but it is something that MT should start to consider)
kewikeed you don't know what you are talking about. Mikrotik has spent many many years developing and improving their ROS which is the foundation of their success. You are asking them to give away the heart of the company to any competitor that makes cheap compatible hardware.

It is not going to happen. UBNT can spend their own money (including prize money) to develop their own OS. And don't believe that UBNT are just a bunch of nice guys who only want to make the world a better place to live. They are competitors who would love to take away Mikrotik's market.

Tom

PS I sell both Mikrotik and UBNT and I know what I am talking about.
-----------------------------------------------
http://www.roc-noc.com
Tom, CCNA, ISP, USA Mikrotik Distributor
888-762-5662
-----------------------------------------------
 
QpoX
Member
Member
Posts: 387
Joined: Mon Mar 24, 2008 7:42 pm
Location: Lemvig, Denmark

Re: v4.0 Feature Request(s)

Sun Feb 22, 2009 5:10 pm

I would like MT to cooperate with other vendors such as Ubiquiti for things like NSTREAM, or loading RouterOS onto their platform. (Ubnt needs to have some form of a polling protocol that is able to work with RouterOS) Many people here use MT as access points and Ubnt as the client CPE devices, but at the moment there is no option for polling. Ubnt has asked for your cooperation before (From what I was told) and you did not give them any.

I find Ubnt goes out of their way to cooperate with YOU and to work with MT hardware and even MT BUGS sometimes.

I think it would be fair to have MT cooperate with a company that tries its hardest to make it's gear compatible with yours, even though yours is not compatible with many other vendors.

(This is not a "feature" but it is something that MT should start to consider)
kewikeed you don't know what you are talking about. Mikrotik has spent many many years developing and improving their ROS which is the foundation of their success. You are asking them to give away the heart of the company to any competitor that makes cheap compatible hardware.

It is not going to happen. UBNT can spend their own money (including prize money) to develop their own OS. And don't believe that UBNT are just a bunch of nice guys who only want to make the world a better place to live. They are competitors who would love to take away Mikrotik's market.

Tom

PS I sell both Mikrotik and UBNT and I know what I am talking about.

RouterOS does run on custom x86 hardware...
In my eyes getting RouterOS on more hardware = more sold licenses.
But getting RouterOS on UNBT hardware does cost some $$$ to make it work a 100%.
 
User avatar
roc-noc.com
Forum Veteran
Forum Veteran
Posts: 869
Joined: Sun Dec 02, 2007 3:27 am
Location: Rockford, IL USA
Contact:

Re: v4.0 Feature Request(s)

Sun Feb 22, 2009 5:26 pm

Ethernet interface error statistics via CLI/Winbox and snmp.

You have already done a great job on wireless interfaces. Please pay similar attention to ethernet interfaces.

This is especially important now that you have RouterBoards like the new RB450G. We will be selling this as a low cost layer 3 switch. I can get loads of ethernet stats on the other layer 3 switches that I work with.

Tom
-----------------------------------------------
http://www.roc-noc.com
Tom, CCNA, ISP, USA Mikrotik Distributor
888-762-5662
-----------------------------------------------
 
hedele
Member
Member
Posts: 338
Joined: Tue Feb 24, 2009 11:23 pm

Re: v4.0 Feature Request(s)

Tue Feb 24, 2009 11:29 pm

Hello :)

Is there any chance of getting server-side MLPPPoE implemented?
We had to use a Cisco 7200 Router for PPPoE termination because RouterOS does not support MLPPP on the server side :(

Since it is already working pretty well client-side, I suppose it might only be a small step towards a MLPPPoE server?
 
taylorc
Frequent Visitor
Frequent Visitor
Posts: 99
Joined: Mon Aug 21, 2006 3:42 am

Re: v4.0 Feature Request(s)

Thu Feb 26, 2009 4:17 am

100% new version of NStream (NOT backwards compatable) to include advanced polling, full QOS, reduced latency, dynamic frequency selection WITHOUT disconnecting active clients, automaticly adjusting framing policy (that does not affect QOS)

New version of NStream Dual with automatic fall back to half duplex if one link fails
Perhaps enhance Nstreme throughput even more by providing the option of a sync-based mechanism. Example with 5 clients:

Polling-based
-----
AP Poll -> Client1
Client1 transmit
AP Poll -> Client2
Client2 transmit
AP Poll -> Client3
Client3 transmit
AP Poll -> Client4
Client4 transmit
AP Poll -> Client5
Client5 transmit

Sync-based
-----
AP -> Broadcast Sync and Timeslot assignments
Client1 transmit
Client2 transmit
Client3 transmit
Client4 transmit
Client5 transmit

Wouldn't that be sweet?!?!?
 
User avatar
Akangage
newbie
Posts: 38
Joined: Tue May 29, 2007 2:33 pm
Location: Indonesia
Contact:

Re: v4.0 Feature Request(s)

Wed Mar 11, 2009 6:29 pm

Profile feature @ UserManager
 
bofh666ie
just joined
Posts: 12
Joined: Sat Feb 14, 2009 9:57 pm

Re: v4.0 Feature Request(s)

Thu Mar 12, 2009 7:21 pm

interface error stats and SNMP traps. And logging for mpls/vpls/ldp
 
User avatar
sioannou
Member Candidate
Member Candidate
Posts: 121
Joined: Tue Apr 29, 2008 3:14 pm

Re: v4.0 Feature Request(s)

Sat Mar 14, 2009 4:48 pm

A torch option for the Firewall filter rules would be great.
e :D
01010011011011110111010001101001011100100110100101110011
 
User avatar
sioannou
Member Candidate
Member Candidate
Posts: 121
Joined: Tue Apr 29, 2008 3:14 pm

Re: v4.0 Feature Request(s)

Sun Mar 15, 2009 3:15 pm

what about an MTR tool included on the MT. That will really help on troubleshouting network issues.

For MTR info visit this site http://www.bitwizard.nl/mtr/
01010011011011110111010001101001011100100110100101110011
 
pedja
Long time Member
Long time Member
Posts: 684
Joined: Sat Feb 26, 2005 5:37 am

Re: v4.0 Feature Request(s)

Mon Mar 16, 2009 11:23 am

It would be great to see at least in and out interfaces for Connections. Some tool to investigate where actually travvic goeas according to Packet Flow Diagarm would be ultimate.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24268
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v4.0 Feature Request(s)

Mon Mar 16, 2009 11:23 am

in and out interfaces for Connections
torch is no good?
No answer to your question? How to write posts
 
User avatar
omega-00
Forum Guru
Forum Guru
Posts: 1167
Joined: Sat Jun 06, 2009 4:54 am
Location: Australia
Contact:

Re: v4.0 Feature Request(s)

Mon Mar 16, 2009 5:01 pm

Ethernet interface error statistics via CLI/Winbox and snmp.

You have already done a great job on wireless interfaces. Please pay similar attention to ethernet interfaces.

This is especially important now that you have RouterBoards like the new RB450G. We will be selling this as a low cost layer 3 switch. I can get loads of ethernet stats on the other layer 3 switches that I work with.

Tom
Error statistics are already available via snmp, I was looking at these myself on an RB1000 just the other night, however it would be good to have them under an advanced section (similar to the wireless) when we want to check from winbox itself.
 
andreacoppini
Trainer
Trainer
Posts: 486
Joined: Wed Apr 13, 2005 11:51 pm
Location: Malta, Europe

Re: v4.0 Feature Request(s)

Mon Mar 16, 2009 6:50 pm

It would be great to see at least in and out interfaces for Connections. Some tool to investigate where actually travvic goeas according to Packet Flow Diagarm would be ultimate.
Add me to this one! Bridges are hell to diagnose!
- No strings attached -

<< Please give good Karma if this post helped you. Press the + button above the Location entry
 
xezen
Long time Member
Long time Member
Posts: 628
Joined: Fri May 30, 2008 10:23 am
Location: South Africa

Re: v4.0 Feature Request(s)

Tue Mar 17, 2009 10:53 pm

add some way to right data to sql server

as i would like to make a gui of my system
with gps information
and snmp data
If i dont No Ask someone That Does!
 
andreacoppini
Trainer
Trainer
Posts: 486
Joined: Wed Apr 13, 2005 11:51 pm
Location: Malta, Europe

Re: v4.0 Feature Request(s)

Wed Mar 18, 2009 1:13 am

add some way to right data to sql server

as i would like to make a gui of my system
with gps information
and snmp data
Isn't that what monitoring tools are for? The Dude can do that, only not in SQL (yet).


I vote for wireless diversity support.
- No strings attached -

<< Please give good Karma if this post helped you. Press the + button above the Location entry
 
User avatar
chvdr
Member
Member
Posts: 403
Joined: Thu Sep 22, 2005 8:53 pm

Re: v4.0 Feature Request(s)

Fri Mar 20, 2009 12:41 pm

...
full antenna diversity support for regular 802.11a/b/g mode

full support for 802.11n and WiMax

...

is there some list of supported hardware
--
Best regards,
C. G.

If nothing to say, do not say anything...
All thoughts that have huge effect actually are simple...
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24268
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v4.0 Feature Request(s)

Fri Mar 20, 2009 12:44 pm

http://wiki.mikrotik.com/wiki/Supported_Hardware

user maintained list, anyone can update it
No answer to your question? How to write posts
 
User avatar
chvdr
Member
Member
Posts: 403
Joined: Thu Sep 22, 2005 8:53 pm

Re: v4.0 Feature Request(s)

Fri Mar 20, 2009 1:05 pm

i just wonder what about 802.11n
is there any hope...
--
Best regards,
C. G.

If nothing to say, do not say anything...
All thoughts that have huge effect actually are simple...
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24268
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v4.0 Feature Request(s)

Fri Mar 20, 2009 1:26 pm

i just wonder what about 802.11n
is there any hope...
search the forum, this question is answered too many times already
No answer to your question? How to write posts
 
pedja
Long time Member
Long time Member
Posts: 684
Joined: Sat Feb 26, 2005 5:37 am

Re: v4.0 Feature Request(s)

Sat Mar 21, 2009 7:53 pm

in and out interfaces for Connections
torch is no good?
Of course it is not. First it works only with one interface, and it shows traffic only on that interface.

What I asked for is that firewall connections show in and out interfaces in connection list. If the same list shows what exact routing table rule affected that connection that would be supreme help.

And, tool to investigate where through traffic actually goes according to Packet Flow Diagram would be ultimate.
 
User avatar
masked
just joined
Posts: 13
Joined: Tue Mar 24, 2009 6:11 am

Re: v4.0 Feature Request(s)

Tue Mar 24, 2009 6:16 am

ability to create hotspot options for users to select from bandwidth speeds and quota's not just time. please let me know if this is already available and i have overlooked it.
http://www.bewifi.org.au/ - Community Wireless Group
 
xezen
Long time Member
Long time Member
Posts: 628
Joined: Fri May 30, 2008 10:23 am
Location: South Africa

Re: v4.0 Feature Request(s)

Tue Mar 24, 2009 9:53 am

i wanted to know in the firewall address list if thay can in to it
so that we can have
name and
ip address

or select a dns

name and
dns name

and the same thing with firewall insted of an ip address an dns name
If i dont No Ask someone That Does!
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24268
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v4.0 Feature Request(s)

Tue Mar 24, 2009 9:56 am

what do you mean by "name" if it's not DNS name?
No answer to your question? How to write posts
 
xezen
Long time Member
Long time Member
Posts: 628
Joined: Fri May 30, 2008 10:23 am
Location: South Africa

Re: v4.0 Feature Request(s)

Tue Mar 24, 2009 10:16 am

for example

we have

name :goolge
ip address :196.100.30.1

now id like it to be

name :google
ip address :grayed out(as i have selected the option for dns name )
dns name :www.google.co.za
If i dont No Ask someone That Does!
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24268
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v4.0 Feature Request(s)

Tue Mar 24, 2009 10:19 am

what is the use of this? you want to make an alternative for DNS :) ?
No answer to your question? How to write posts
 
xezen
Long time Member
Long time Member
Posts: 628
Joined: Fri May 30, 2008 10:23 am
Location: South Africa

Re: v4.0 Feature Request(s)

Tue Mar 24, 2009 11:43 am

yes it more for local dns
like one big network with 20 mailserver voip servers and hosting sevrer

so i dont have to keep track of the ip addres i just use the dns names for each of the hosting servers
If i dont No Ask someone That Does!
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8319
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v4.0 Feature Request(s)

Tue Mar 24, 2009 2:33 pm

Normis, he just wants to use domain names instead of IP addresses in firewall rules =)

xezen, no, it's not possible directly. you should use scripting
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
andreacoppini
Trainer
Trainer
Posts: 486
Joined: Wed Apr 13, 2005 11:51 pm
Location: Malta, Europe

Re: v4.0 Feature Request(s)

Tue Mar 24, 2009 5:27 pm

Normis, he just wants to use domain names instead of IP addresses in firewall rules =)
Isn't that the use of firewall Address Lists?
- No strings attached -

<< Please give good Karma if this post helped you. Press the + button above the Location entry
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8319
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v4.0 Feature Request(s)

Tue Mar 24, 2009 5:36 pm

Isn't that the use of firewall Address Lists?
what's general between Address-Lists and Domain Names?..
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
andreacoppini
Trainer
Trainer
Posts: 486
Joined: Wed Apr 13, 2005 11:51 pm
Location: Malta, Europe

Re: v4.0 Feature Request(s)

Tue Mar 24, 2009 7:36 pm

Isn't that the use of firewall Address Lists?
what's general between Address-Lists and Domain Names?..
DNS names are for resolution by any TCP/IP device (computers, routers, servers, etc). Address Lists are only internal to the router they are specified on. Sort of like a 'Group' of IP addresses. A single address list name can contain multiple IP addresses, then when you set up firewall rules, you can use that address list 'name' instead of each device's IP address.

If you want to specify rules using names instead of IPs, and you want to address each device individually (instead of as a whole group), you could create a new address list for each device. So each address list name contains only 1 IP address. Very inefficient way of doing it in my opinion, but it can be done.

If you want to keep track of which rule is affecting which device, it's easier to just use comments!

Address Lists: http://www.mikrotik.com/testdocs/ros/3. ... s_list.php
- No strings attached -

<< Please give good Karma if this post helped you. Press the + button above the Location entry
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8319
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v4.0 Feature Request(s)

Wed Mar 25, 2009 2:43 am

xezen wants to use names because IPs can change without notification =) so, as I said, he should use scripting. yes, quite efficient way is to add address-list, add entries for needed servers, write domain names in comments of those entries, and periodically via script update addresses of those entries by resolving their comments
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
xezen
Long time Member
Long time Member
Posts: 628
Joined: Fri May 30, 2008 10:23 am
Location: South Africa

Re: v4.0 Feature Request(s)

Wed Mar 25, 2009 11:11 pm

im not good at scripting!!!!!!!!!!!
At all

so can you maybe show me an example to get this right
as it might be simple for others but im no good at it

so if you can give me an example i would be glad as it will help me a lot!
If i dont No Ask someone That Does!
 
User avatar
omega-00
Forum Guru
Forum Guru
Posts: 1167
Joined: Sat Jun 06, 2009 4:54 am
Location: Australia
Contact:

Re: v4.0 Feature Request(s)

Thu Mar 26, 2009 1:45 am

Heres an example of a command I use to change the IP for a VPN link between 2 dynamic IP addresses.
:global "vpn-interface-name" "Server_PPTP"
:global "new-vpn-ip" [:resolve "vpn.some.domain.tld"]
:global "current-vpn-ip" [/interface pptp-client get $"vpn-interface-name" connect-to]
:if ($"current-vpn-ip" != $"new-vpn-ip") do={ /interface pptp-client set [find name=$"vpn-interface-name"] connect-to=$"new-vpn-ip"}
It checks to see if the name resolution has changed since last time it looked (I'm using a dynamic DNS address on the vpn server router) and if so, changes the vpn connect-to ip to match.
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8319
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v4.0 Feature Request(s)

Thu Mar 26, 2009 1:50 am

add the following script
:local addresslist "mylist"
/ip firewall address-list
:foreach i in=[find list=$addresslist] do={set $i address=[:resolve [get $i comment]]}
change "mylist" to your desired address-list name, then
/ip firewall address-list
add list=mylist comment="google.com"
add list=mylist comment="myserver1.local"
add list=mylist comment="myserver2.local"
and run script
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
xezen
Long time Member
Long time Member
Posts: 628
Joined: Fri May 30, 2008 10:23 am
Location: South Africa

Re: v4.0 Feature Request(s)

Thu Mar 26, 2009 3:41 pm

thnaks for all the help with the scripting part it helped me solve the problem

there should be a topic i opend with examples of scipts to help people

as i know the people in this forum will have somthing to say as this topic we are talking in is for v4.0
and not for scrpits
thanks for the help
If i dont No Ask someone That Does!
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24268
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v4.0 Feature Request(s)

Thu Mar 26, 2009 3:55 pm

thnaks for all the help with the scripting part it helped me solve the problem

there should be a topic i opend with examples of scipts to help people

as i know the people in this forum will have somthing to say as this topic we are talking in is for v4.0
and not for scrpits
thanks for the help
there is such place: http://forum.mikrotik.com/viewforum.php?f=9
No answer to your question? How to write posts
 
xezen
Long time Member
Long time Member
Posts: 628
Joined: Fri May 30, 2008 10:23 am
Location: South Africa

Re: v4.0 Feature Request(s)

Fri Apr 24, 2009 4:37 pm

can use add a connection be able right logs straight into a access,sql or oracle database? even if it must be done by script

so routerboard will be able to understand SELECT * FROM WHERE
connect
address
username
password

as i like to have one thing that does everything?

or to allow some kind of file transfer to be able to take place between routerboards and a pc?
If i dont No Ask someone That Does!
 
User avatar
trm3
newbie
Posts: 34
Joined: Mon Jun 04, 2007 7:36 pm
Location: US, NC, Charlotte
Contact:

Re: v4.0 Feature Request(s)

Fri Apr 24, 2009 10:28 pm

I have a very specific need for real unencrypted GRE tunnels rather than IPIP tunnels. Some of the hardware that my customers' satellite traffic traverses can apply various spoofing / window adjustment acceleration procedures to both native traffic and GRE tunnels, but not IPIP or any other form of tunnel. Could there be a tunnel-type pull down defaulting to the existing IPIP, but allowing selection of GRE, in the IP Tunnel creation window?
Tim McKee
CTO, SDN Global
 
User avatar
trm3
newbie
Posts: 34
Joined: Mon Jun 04, 2007 7:36 pm
Location: US, NC, Charlotte
Contact:

Re: v4.0 Feature Request(s)

Fri Apr 24, 2009 11:16 pm

The ability to specify different redistribution rules for each VRF (for BGP/OSPF/RIP/Static/Connected) is a must in our environment. We have a global Cisco MPLS network with each VRF having a /27 or /28 presence in every major node with interconnected customer/satellite routers. We need either individual controls or individual in/out route-maps for each VRF.

Sorry if I've overlooked something, but I can't find this.
Tim McKee
CTO, SDN Global
 
titius
Member
Member
Posts: 338
Joined: Mon Oct 17, 2005 11:43 am
Location: Titel Serbia

Re: v4.0 Feature Request(s)

Tue Apr 28, 2009 9:37 am

USB ethernet and wireless support? Is it hard?

I know some USB ethernet work, but very very small number of devices work :(
 
xezen
Long time Member
Long time Member
Posts: 628
Joined: Fri May 30, 2008 10:23 am
Location: South Africa

Re: v4.0 Feature Request(s)

Tue Apr 28, 2009 9:49 pm

when i run this
:local addresslist "mylist"
/ip firewall address-list
:foreach i in=[find list=$addresslist] do={set $i address=[:resolve [get $i comment]]}
most of themstay 0.0.0.0 can anyone tell me why
If i dont No Ask someone That Does!
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8319
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v4.0 Feature Request(s)

Wed Apr 29, 2009 12:19 am

xezen, it seems like error in :resolve of unknown host in your comment. maybe some coments are absent, or they are inexistant names? try running this script in terminal window:
{
:local addresslist "mylist"
/ip firewall address-list
:foreach i in=[find list=$addresslist] do={set $i address=[:resolve [get $i comment]]}
:put "All done, keeper!"
}
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24268
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v4.0 Feature Request(s)

Wed Apr 29, 2009 2:51 pm

wrong thread! make a new post in Scripting forum
No answer to your question? How to write posts
 
HaQs
Member Candidate
Member Candidate
Posts: 153
Joined: Sat Oct 20, 2007 3:26 pm
Location: POLAND

Re: v4.0 Feature Request(s)

Wed Apr 29, 2009 11:02 pm

Native support in ROS to automaticaly backup CFG to FTP server
Set Time: day / week / month ...
file name: RB_IDENT_TIME ...
 
ayufan
Member
Member
Posts: 331
Joined: Sun Jun 03, 2007 9:35 pm
Contact:

Re: v4.0 Feature Request(s)

Thu Apr 30, 2009 12:46 am

You can send a mail with backup.
Last edited by ayufan on Thu Apr 30, 2009 1:47 am, edited 1 time in total.
hAP AC, TP-Link Archer C7 v2, RB951G, RB450G, RPI2, RPI zero
 
noam_chom
newbie
Posts: 37
Joined: Wed May 03, 2006 5:55 am

Re: v4.0 Feature Request(s)

Thu Apr 30, 2009 1:35 am

Decent per user QOS would be nice to have in the ROS 4.0 .
If I am not wrong we all concluded that still there is no way to make "per user QOS" in MT.

Ilija
 
xezen
Long time Member
Long time Member
Posts: 628
Joined: Fri May 30, 2008 10:23 am
Location: South Africa

Re: v4.0 Feature Request(s)

Thu Apr 30, 2009 12:02 pm

{
:local addresslist "mylist"
/ip firewall address-list
:foreach i in=[find list=$addresslist] do={set $i address=[:resolve [get $i comment]]}
:put "All done, keeper!"
}
i ran this and it sed
failure

i took all the comment and ran a ping on all of then and all come back with a reply

her is my examples

im having problems with

home.disney.go.com
youtube.com
facebook.com
If i dont No Ask someone That Does!
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8319
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v4.0 Feature Request(s)

Thu Apr 30, 2009 12:52 pm

open terminal and try ":put [:resolve home.disney.go.com]" - what will you see? maybe you have a space before or after comment?
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
User avatar
omega-00
Forum Guru
Forum Guru
Posts: 1167
Joined: Sat Jun 06, 2009 4:54 am
Location: Australia
Contact:

Re: v4.0 Feature Request(s)

Thu Apr 30, 2009 2:49 pm

when i run this
:local addresslist "mylist"
/ip firewall address-list
:foreach i in=[find list=$addresslist] do={set $i address=[:resolve [get $i comment]]}
most of themstay 0.0.0.0 can anyone tell me why
Side note that IS relevant to v4 feature requests: the resolve command is currently broken and has been for the last couple of versions.
using :resolve in any script where the domain doesn't resolve will simply cause the script to terminate. Can this be fixed for v4? :-P
 
xezen
Long time Member
Long time Member
Posts: 628
Joined: Fri May 30, 2008 10:23 am
Location: South Africa

Re: v4.0 Feature Request(s)

Thu Apr 30, 2009 11:21 pm

thanks for all the help thay should start a live chat that we can try solve this live as i tryed #mikrotik on the irc be not many people are on there
If i dont No Ask someone That Does!
 
xezen
Long time Member
Long time Member
Posts: 628
Joined: Fri May 30, 2008 10:23 am
Location: South Africa

Re: v4.0 Feature Request(s)

Thu Apr 30, 2009 11:24 pm

that was broken as one one my names on my list were not working and when i deleted them the rest worked so if this problem can be fixed it will be help full thanks
mikrotik and all the users forthe help
If i dont No Ask someone That Does!
 
titius
Member
Member
Posts: 338
Joined: Mon Oct 17, 2005 11:43 am
Location: Titel Serbia

Re: v4.0 Feature Request(s)

Fri May 01, 2009 4:30 pm

and you again posting scripting issues in wrong area?
 
iwikus
just joined
Posts: 23
Joined: Sat Jun 16, 2007 9:55 am

Re: v4.0 Feature Request(s)

Thu May 07, 2009 5:37 pm

Improved cluster (HA) support - to have two rb450G as active/standby cluster:
- nat table (conntrack) synchronization between two boxes.
- some kind of automatic configuration replication to standby box.
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8319
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v4.0 Feature Request(s)

Thu May 07, 2009 6:01 pm

- nat table (conntrack) synchronization between two boxes.
could you please describe it in more detail?..
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
QpoX
Member
Member
Posts: 387
Joined: Mon Mar 24, 2008 7:42 pm
Location: Lemvig, Denmark

Re: v4.0 Feature Request(s)

Thu May 07, 2009 6:09 pm

Improved cluster (HA) support - to have two rb450G as active/standby cluster:
- nat table (conntrack) synchronization between two boxes.
- some kind of automatic configuration replication to standby box.
i agree, redundancy on all functions.
 
iwikus
just joined
Posts: 23
Joined: Sat Jun 16, 2007 9:55 am

Re: v4.0 Feature Request(s)

Thu May 07, 2009 7:46 pm

If you use VRRP and NAT (and/or statefull firewall) you need to transfer connection states when IP is transfered to other box (failover happends). If not, established connections will be dropped.

http://conntrack-tools.netfilter.org/ma ... ml#sync-pb
- nat table (conntrack) synchronization between two boxes.
could you please describe it in more detail?..
 
User avatar
omega-00
Forum Guru
Forum Guru
Posts: 1167
Joined: Sat Jun 06, 2009 4:54 am
Location: Australia
Contact:

Re: v4.0 Feature Request(s)

Fri May 08, 2009 2:41 am

Improved cluster (HA) support - to have two rb450G as active/standby cluster:
- nat table (conntrack) synchronization between two boxes.
- some kind of automatic configuration replication to standby box.
Add to that, active hotspot user synchronization between devices.
 
jsanyi
just joined
Posts: 2
Joined: Mon May 18, 2009 2:20 pm
Location: Budapest, Hungary

Re: v4.0 Feature Request(s)

Mon May 18, 2009 2:52 pm

Hi!
Would it be possible to...
- use the dynamic address lists in webproxy access lists too? (adding and removing or disabling a lot of rules from access lists would be much problematic than using lists already defined for firewalling for the same, very different networked addresses)
- create some kind of rule groups in webproxy access lists? (eg. a group for chat sites could be assigned to an address or a subnet, or maybe to a list of ips with only one rule, this would minimalize the access list items needed and improve easy configuration, eg. 10+3 rules would be enough to enable/disable access to 10 sites for 3 subnets, while this now needs 10*3 rules)
Thanks!
 
astib
just joined
Posts: 8
Joined: Sun Feb 15, 2009 8:16 pm
Location: Czech Republic

Re: v4.0 Feature Request(s)

Thu May 28, 2009 2:30 am

Hi!
I would love to have in new version:
- GRE support (no EOIP, IPIP, PPTP ... just GRE please :-) This can make my life much easier!
- source address for EOIP tunnel, like IPIP has
- ability of telnet/ssh from MK to non-default ports
- keys support for WinBox
- synchronization of connections between routers
- synchronization of particular filter tables would be lovely, even very basic!
- better firewall logging (session creation,teardown, bytes sent, etc)

Just my ideas -- thanks for reading them :)

Astib
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8319
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v4.0 Feature Request(s)

Thu May 28, 2009 12:23 pm

- ability of telnet/ssh from MK to non-default ports
[admin@vpn1] > /system telnet 192.168.0.1 ?
Port ::= 1..65535    (integer number)
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
astib
just joined
Posts: 8
Joined: Sun Feb 15, 2009 8:16 pm
Location: Czech Republic

Re: v4.0 Feature Request(s)

Thu May 28, 2009 1:20 pm

:-D
ok, feeling ashamed, forget that line :)
 
Martell
just joined
Posts: 8
Joined: Sat Mar 15, 2008 11:48 pm

Re: v4.0 Feature Request(s)

Sun May 31, 2009 5:03 pm

I seriously second the improved IPSEC implementation as mentioned by nz_monkeys! Yes, yes and yes, please!

If possible, even in the 3.x version. I aslo work a lot of Junipers/Netscreens, Ciscos, Checkpoints and others, and the tunnel inerfaces are the most needed lack in the MT.

I know they are very serious guys there in the MT and they can easily make the changes! I respect them a lot.
 
User avatar
nz_monkey
Forum Guru
Forum Guru
Posts: 1821
Joined: Mon Jan 14, 2008 1:53 pm
Location: Straya
Contact:

Re: v4.0 Feature Request(s)

Mon Jun 01, 2009 10:07 am

Hi Martell,

Please vote on this feature at http://wiki.mikrotik.com/wiki/MikroTik_ ... e_Requests

A lot of people want the tunnel/route based IPSEC support, but it's no good posting all over the forums as it can be easily forgotten.

Also, if Normis or any of the other MT guys are paying attention I can provide access to:

- Juniper J Series, SRX, SSG(Netscreen)
- Fortinet FortiGate's
- Cisco 8xx, 18xx

For testing during the development of this feature.
http://thebrotherswisp.com/ | Mikrotik MTCNA, MTCRE, MTCINE | Fortinet FTCNA, FCNSP, FCT | Extreme Networks ENA
 
xezen
Long time Member
Long time Member
Posts: 628
Joined: Fri May 30, 2008 10:23 am
Location: South Africa

Re: v4.0 Feature Request(s)

Mon Jun 01, 2009 11:19 am

what about raid for x86 os?
so licanse key can be saved or backed up in somekind of whay
If i dont No Ask someone That Does!
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24268
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v4.0 Feature Request(s)

Mon Jun 01, 2009 11:24 am

raid makes problems with license key, it can't work. but this is not the only reason RAID is not supported.
No answer to your question? How to write posts
 
xezen
Long time Member
Long time Member
Posts: 628
Joined: Fri May 30, 2008 10:23 am
Location: South Africa

Re: v4.0 Feature Request(s)

Mon Jun 01, 2009 11:46 am

so what the best way i can set up a x86 system to prevent hardwer fail and be able so have storade

i thougt load os on sd card

put thats not best for proxy
If i dont No Ask someone That Does!
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8319
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v4.0 Feature Request(s)

Mon Jun 01, 2009 12:03 pm

you may use another drive for proxy cache
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
xezen
Long time Member
Long time Member
Posts: 628
Joined: Fri May 30, 2008 10:23 am
Location: South Africa

Re: v4.0 Feature Request(s)

Mon Jun 01, 2009 9:25 pm

so on sd card and another drive for proxy?


whats be safest way for less hardware problems
If i dont No Ask someone That Does!
 
User avatar
infowest
Frequent Visitor
Frequent Visitor
Posts: 94
Joined: Thu Jun 07, 2007 12:46 am

Re: v4.0 Feature Request(s)

Wed Jun 03, 2009 8:58 pm

Nstreme improvement ideas:

- Can Nstreme in PTMP environment be more intelligent about polling, such that "less busy" CPE's get fewer polls, thus reducing the resource usage and hopefully allowing us to get more cpe's per AP before we start hitting the nstreme limits?
- Can Nstreme be built into hardware on a routerboard to make it more efficient, handle more cpe's, etc?
- GPS sync for nstreme - what a winner that would be!
 
User avatar
nz_monkey
Forum Guru
Forum Guru
Posts: 1821
Joined: Mon Jan 14, 2008 1:53 pm
Location: Straya
Contact:

Re: v4.0 Feature Request(s)

Thu Jun 04, 2009 2:35 am

Put your requests on the Wiki so people can vote on them: http://wiki.mikrotik.com/wiki/MikroTik_ ... e_Requests
http://thebrotherswisp.com/ | Mikrotik MTCNA, MTCRE, MTCINE | Fortinet FTCNA, FCNSP, FCT | Extreme Networks ENA
 
ochyst
just joined
Posts: 21
Joined: Sat Jun 17, 2006 3:01 am

Re: v4.0 Feature Request(s)

Thu Jul 09, 2009 8:47 pm

Please, we need stable sshd and https on RouterOS or something to restart deamons without reboot router.

Watchdog for deamons?

Seting /ip services from more than one network (available from)?
Users - more than one allowed address?

Support for 3.5GHz?

More testing before relase new version of RouterOS!!!
 
Verlen
newbie
Posts: 36
Joined: Wed Aug 27, 2008 10:47 pm
Location: Lvov, Ukraine
Contact:

Re: v4.0 Feature Request(s)

Sun Jul 12, 2009 12:14 am

Please in add sorting by enabled/disabled account in PPP - Secrets (via Winbox)
 
xezen
Long time Member
Long time Member
Posts: 628
Joined: Fri May 30, 2008 10:23 am
Location: South Africa

Re: v4.0 Feature Request(s)

Sun Jul 12, 2009 11:04 am

cant mikrotik add VideoCache to mikrotik x86 proxy service?


as it would be nice to have one system working

we know squid is an option
If i dont No Ask someone That Does!
 
xezen
Long time Member
Long time Member
Posts: 628
Joined: Fri May 30, 2008 10:23 am
Location: South Africa

Re: v4.0 Feature Request(s)

Mon Jul 20, 2009 10:30 am

question has mikrotik thought aboat adding an digital in/output to one on the new release boards


uses for it could be for alarm output for tamper if some one trys to open mikrotik box so it can email and sms network administrator

can be used for a relay output if needed to trigger something

and can be used in industrial use for reading inputs and relaying outputs at the mikrotik is the best board used for many diffrent industrial useses just with comm to ip no relay input trigger and output trigger will make it very usefull in industrial use
If i dont No Ask someone That Does!
 
User avatar
infowest
Frequent Visitor
Frequent Visitor
Posts: 94
Joined: Thu Jun 07, 2007 12:46 am

TDMA and GPS on a routerboard?

Sat Aug 22, 2009 5:15 am

I'd much rather see polling done in hardware (fpga) so we can scale like crazy, but would TDMA be of any use in software? Someone apparently is doing that...

Examples:

FreeBSD (looks like it could even use GPS - why not add GPS to a routerboard?):

http://siomail.ucsd.edu/pipermail/swap/ ... 00683.html

Linux:

http://www.cs.ucdavis.edu/~prasant/pubs ... -tdmac.pdf
 
fewi
Forum Guru
Forum Guru
Posts: 7734
Joined: Tue Aug 11, 2009 3:19 am

Re: v4.0 Feature Request(s)

Sat Aug 22, 2009 5:45 am

If you use VRRP and NAT (and/or statefull firewall) you need to transfer connection states when IP is transfered to other box (failover happends). If not, established connections will be dropped.

http://conntrack-tools.netfilter.org/ma ... ml#sync-pb
- nat table (conntrack) synchronization between two boxes.
could you please describe it in more detail?..
I very much second that. This would put the firewalling capabilities somewhere up there with ASAs and competing products.

A related though somewhat different request: ideally, this could even be extended into a load sharing scenario - if all machines in the 'cluster' know about all clients, the DHCP server can pass out the different gateway IPs (possibly with a manually configurable weight? That way you can mix different hardware platforms) and you can scale with the number of customers simply by adding more routers. This would be extremely useful for Hotspot scenarios. I've dealt with Hotspot areas that had to temporarily support over 6,000 concurrent clients - nearly impossible to do on a single box.
In that case you may not be able to have full connection state table sharing so that connections are reset, but it could reasonably work just by all slaves sharing authentication state of clients so clients don't have to re-authenticate.

Felix
Specific answers require specific questions. When in doubt, post the output of "/ip address print detail", "/ip route print detail", "/interface print detail", "/ip firewall export", and an accurate network diagram.
 
fewi
Forum Guru
Forum Guru
Posts: 7734
Joined: Tue Aug 11, 2009 3:19 am

Re: v4.0 Feature Request(s)

Tue Aug 25, 2009 12:55 am

Very minor: when running "/system backup save", the default filename is in format Hostname-DDMMYYYY-HHMM. That doesn't sort very well, maybe it would be nice if this could be in ISO format Hostname-YYYYMMDD-HH:MM instead.

Felix
Specific answers require specific questions. When in doubt, post the output of "/ip address print detail", "/ip route print detail", "/interface print detail", "/ip firewall export", and an accurate network diagram.
 
dssmiktik
Forum Veteran
Forum Veteran
Posts: 732
Joined: Fri Aug 17, 2007 8:42 am

Re: v4.0 Feature Request(s)

Tue Aug 25, 2009 6:43 am

do you want v3 to ever be stable? ;)
Yes I do, very much so!
Doug
 
dssmiktik
Forum Veteran
Forum Veteran
Posts: 732
Joined: Fri Aug 17, 2007 8:42 am

Re: v4.0 Feature Request(s)

Tue Aug 25, 2009 6:46 am

Virtual Routers/Virtual Domains is a great idea, but I would not want to be the programmers at Mikrotik trying to implement it!
Using more standard, mature packages from open source would be nice. They've been around a long time and have a huge user base hacking and perfecting the software.
Doug
 
dssmiktik
Forum Veteran
Forum Veteran
Posts: 732
Joined: Fri Aug 17, 2007 8:42 am

Re: v4.0 Feature Request(s)

Tue Aug 25, 2009 6:51 am

I would like to have a full configurable webbox selecting what i want to show on webbox (maybe only NAT rules and some few more features)
Something like the HotSpot Interface.
*bump
Along with this a configuration option to enable/disable simple/advanced web interface (default being simple interface). This way many users are happy with simple webbox but advanced users can get advanced interface if desired.
Doug
 
User avatar
stephenpatrick
Forum Veteran
Forum Veteran
Posts: 703
Joined: Fri Aug 20, 2004 12:26 pm
Location: UK
Contact:

Re: v4.0 Feature Request(s)

Mon Sep 21, 2009 6:04 pm

Intel 82574L Gigabit Ethernet controller

Is this supported, or going to be supported?

Regards
CableFree - Wireless Excellence - Microwave, E-band Radios, Free Space Optics, High performance Radios & Routers
http://www.cablefree.net
 
dssmiktik
Forum Veteran
Forum Veteran
Posts: 732
Joined: Fri Aug 17, 2007 8:42 am

Re: v4.0 Feature Request(s)

Mon Sep 21, 2009 8:12 pm

Intel 82574L Gigabit Ethernet controller

Is this supported, or going to be supported?

Regards
Support for all Intel 825xxx gigabit ethernet controller. (This should be one driver to cover any card with that chipset.)
Doug
 
User avatar
nz_monkey
Forum Guru
Forum Guru
Posts: 1821
Joined: Mon Jan 14, 2008 1:53 pm
Location: Straya
Contact:

Hardware assisted TDMA

Sat Jan 09, 2010 1:25 pm

There are a few updated papers on Sam Leffler's Atheros hardware assisted TDMA implementation. They are a very interesting read, and something I hope we will see on RouterOS at some point in the future.

http://people.freebsd.org/~sam/FreeBSD_ ... 090921.pdf
http://people.freebsd.org/~sam/TDMAPres ... 090921.pdf
http://thebrotherswisp.com/ | Mikrotik MTCNA, MTCRE, MTCINE | Fortinet FTCNA, FCNSP, FCT | Extreme Networks ENA
 
User avatar
fbaffoni
Frequent Visitor
Frequent Visitor
Posts: 91
Joined: Fri Feb 22, 2008 2:10 pm

Re: v4.0 Feature Request(s)

Sun Jan 17, 2010 8:17 am

There are a few updated papers on Sam Leffler's Atheros hardware assisted TDMA implementation. They are a very interesting read, and something I hope we will see on RouterOS at some point in the future.

http://people.freebsd.org/~sam/FreeBSD_ ... 090921.pdf
http://people.freebsd.org/~sam/TDMAPres ... 090921.pdf
Totally Agree with nz_monkey, Ubiquiti has added the Sam Leffler's implementation on his new AirMax, could be greate if Mikrotik be compatible with Ubiquiti AirMax. I'd prefer to use a MK AP than a Ubiquiti AP (MK hardware has better rosourses)

I know that MK has his own polling algorithm using NSTREME and is possble to disable CSMA, but NSTREME is a propietary protocol, I can't use Ubiquiti. Could be greate if MK support TDM.


What do the MK people says about this?
 
User avatar
nz_monkey
Forum Guru
Forum Guru
Posts: 1821
Joined: Mon Jan 14, 2008 1:53 pm
Location: Straya
Contact:

Re: v4.0 Feature Request(s)

Sun Jan 17, 2010 10:10 am

I am not concerned with Ubiquiti AirMax compatibility at all.

It would just be good to see a hardware based TDMA protocol on Mikrotik.
http://thebrotherswisp.com/ | Mikrotik MTCNA, MTCRE, MTCINE | Fortinet FTCNA, FCNSP, FCT | Extreme Networks ENA
 
ElectricCat
newbie
Posts: 26
Joined: Thu Oct 22, 2009 2:46 pm

Re: v4.0 Feature Request(s)

Thu Feb 11, 2010 10:31 am

My feature request: sometimes the symbolic name of the PPTP-server is needed to connect to ISP, but the RouterOS asks the IP address only. If MikroTik were make it possible to use symbolic names as the PPTP-server address, there would be a great leap for them in Russia.
 
pedja
Long time Member
Long time Member
Posts: 684
Joined: Sat Feb 26, 2005 5:37 am

Re: v4.0 Feature Request(s)

Thu Feb 11, 2010 9:43 pm

That was asked long time ago and declined. Mikrotik stuff does not have understanding for our needs to be able to use mnemonic addresses instead of IP.
 
ElectricCat
newbie
Posts: 26
Joined: Thu Oct 22, 2009 2:46 pm

Re: v4.0 Feature Request(s)

Fri Feb 12, 2010 7:43 am

That was asked long time ago and declined. Mikrotik stuff does not have understanding for our needs to be able to use mnemonic addresses instead of IP.

Pity... Well, we should use our scripting solutions then...
 
pedja
Long time Member
Long time Member
Posts: 684
Joined: Sat Feb 26, 2005 5:37 am

Re: v4.0 Feature Request(s)

Fri Feb 12, 2010 5:14 pm

Yes, and do not ask why you have to hack something that should and can be so simple....

Good side is that we now have Routerboards with TWO power connectors. That is a huge gain.

Who is online

Users browsing this forum: No registered users and 112 guests