Community discussions

 
User avatar
karo84
Member Candidate
Member Candidate
Topic Author
Posts: 194
Joined: Fri Aug 17, 2007 9:06 am

Help Me with OSPF configuration

Thu Jan 31, 2008 7:13 pm

Hi
I have 5 routers working with ospf on. Everything is ok, but I have problem with routlist.
So I don't want some network routes to be send to other routers.
How can I do that setup ?
I mean the connected routes, not all to be sent to peer.
Tell me please how can I do that setup?
Thanks With Regarts
My All Routers Are RB 150, with ROS 3.1 on them.


Karapet Aznavuryan
 
awsmith
newbie
Posts: 45
Joined: Wed May 31, 2006 8:18 am

Re: Help Me with OSPF configuration

Fri Feb 01, 2008 6:51 am

To prevent the connected prefix of 10.70.1.0/24 from being redistributed into OSPF and announced, use the following:

/routing filter add action=discard chain=ospf-out prefix=10.70.1.0/24
 
User avatar
karo84
Member Candidate
Member Candidate
Topic Author
Posts: 194
Joined: Fri Aug 17, 2007 9:06 am

Re: Help Me with OSPF configuration

Fri Feb 01, 2008 9:16 am

Thanks Very Much, :)
 
Cyra-Orin
just joined
Posts: 6
Joined: Fri Feb 01, 2008 12:00 pm

Re: Help Me with OSPF configuration

Fri Feb 01, 2008 12:30 pm

To prevent the connected prefix of 10.70.1.0/24 from being redistributed into OSPF and announced, use the following:

/routing filter add action=discard chain=ospf-out prefix=10.70.1.0/24

So, where we put these settings in routing-ospf configuration, in routing-bgp configuration there's /rou bgp peer set {peer} out-filter={filter_from_chain}...or just like that ??
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 5942
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: Help Me with OSPF configuration

Fri Feb 01, 2008 12:58 pm

[
So, where we put these settings in routing-ospf configuration, in routing-bgp configuration there's /rou bgp peer set {peer} out-filter={filter_from_chain}...or just like that ??
/routing filter has two built in chains ospf-in and ospf-out. These two chains are used to filter ospf routes and there is no option to specify other chains like in BGP case.
 
Cyra-Orin
just joined
Posts: 6
Joined: Fri Feb 01, 2008 12:00 pm

Re: Help Me with OSPF configuration

Fri Feb 01, 2008 1:08 pm

[
So, where we put these settings in routing-ospf configuration, in routing-bgp configuration there's /rou bgp peer set {peer} out-filter={filter_from_chain}...or just like that ??
/routing filter has two built in chains ospf-in and ospf-out. These two chains are used to filter ospf routes and there is no option to specify other chains like in BGP case.
I c...thx!

Who is online

Users browsing this forum: No registered users and 46 guests