Community discussions

MikroTik App
 
msolis
newbie
Topic Author
Posts: 37
Joined: Thu Jul 08, 2004 1:16 am
Location: Costa Rica
Contact:

FTP problem

Wed Mar 02, 2005 3:12 am

With FTP session, in put or get file, the Mikrotik server return the message "Session Closed by remote host" and the operation don´t is completed.

This appends only in MS FTP Client (nothing strange). With the another FTP client the get or put operation is completed.

I discard the Mikrotik version (this is full upgrade in 2.8.24), because this problem is in various router with different version. Some if they complete the operation.

I need help, because I need a MS FTP script for download periodical back-up.

Thanks for its aid

Miguel Solis
 
msolis
newbie
Topic Author
Posts: 37
Joined: Thu Jul 08, 2004 1:16 am
Location: Costa Rica
Contact:

Re: FTP problem

Wed Mar 02, 2005 3:16 am

Something more: My 21 and 20 ports is up.

This is the message for Windows:
C:\>ftp 10.3.1.252
Conectado a 10.3.1.252.
220 MikroTik FTP server (MikroTik v2.8.24) ready
Usuario (10.3.1.252:(none)): admin
331 Password required for admin
Contrase±a:
230 User admin logged in
ftp> put prueba
200 PORT command successful
Conexión cerrada por el host remoto.
 
cheinzle
newbie
Posts: 36
Joined: Thu Oct 28, 2004 7:06 pm
Location: Nebraska

FTP Problem

Thu Mar 03, 2005 9:09 pm

is it perhaps a 'passive transfer' setting? try toggling passive mode.
 
msolis
newbie
Topic Author
Posts: 37
Joined: Thu Jul 08, 2004 1:16 am
Location: Costa Rica
Contact:

Thu Mar 03, 2005 9:31 pm

I don´t have firewall in my PC. Lamentably, the FTP W2K client don´t have passive mode.

Thanks Cheinzle
 
cheinzle
newbie
Posts: 36
Joined: Thu Oct 28, 2004 7:06 pm
Location: Nebraska

FTP

Mon Mar 07, 2005 4:39 pm

i guess you might try a freeware ftp program, such as WS-FTP, that has that feature availble
 
marvin
Member Candidate
Member Candidate
Posts: 119
Joined: Mon Nov 15, 2004 9:56 pm

Mon Mar 07, 2005 5:19 pm

Actually I could get no listing on ftp with 3 different ftp clients.. passive on, passive off, alternative download, alternative upload, use site ip for passive connection, use stat -l to list directories, site does not support FEAT command, show hidden files, disable force active mode for this IP... NOT one of these options worked. What worked reliably of all things was the simple built in Internet Explorer FTP capability.. And you can set in the options for ftp to use passive ftp mode. So try IE before trying ftp clients not sure what they do differently but I know for a fact that RouterOS 2.8.23 and .24 did not like any of these other clients.
 
cmit
Forum Guru
Forum Guru
Posts: 1552
Joined: Fri May 28, 2004 12:49 pm
Location: Germany

Mon Mar 07, 2005 5:21 pm

Well, using the integrated FTP from TotalCommander, SmartFTP and others I have to say I have no problems at all with FTP access to RouterOS machines (yes, also 2.8.23 and 2.8.24 versions)...
Best regards,
Christian Meis

Who is online

Users browsing this forum: almdandi, DanDan, markovip, MSN [Bot], Renfrew and 85 guests