Community discussions

MikroTik App
 
trottolino1970
Member Candidate
Member Candidate
Topic Author
Posts: 192
Joined: Thu May 17, 2007 4:25 pm
Contact:

how to block dhcp from my client to me!!

Thu Mar 13, 2008 10:58 am

how to block dhcp from my client to me and Sharing files and folders?
 
User avatar
sandov63
newbie
Posts: 34
Joined: Mon Jun 25, 2007 9:15 pm
Location: Villa del rosario perija zulia, venezuela

Re: how to block dhcp from my client to me!!

Fri Mar 14, 2008 10:52 pm

built this rule under ip -> firewall -->> filter rules

add chain=forward action=drop dst-port=68 protocol=udp comment="DROP DHCP \
SERVERS" disabled=no
add chain=input action=drop dst-port=68 protocol=udp comment="" disabled=no

this way you are blocking broadcasting from port 68 of users whose wake up a dhcp server
Cuando la ignorancia se impone, la razon cordialmente cede el paso.
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8394
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: how to block dhcp from my client to me!!

Sat Mar 15, 2008 2:00 am

are broadcast packets affected by forward chain? :)
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
trottolino1970
Member Candidate
Member Candidate
Topic Author
Posts: 192
Joined: Thu May 17, 2007 4:25 pm
Contact:

Re: how to block dhcp from my client to me!!

Sat Mar 15, 2008 9:05 am

are broadcast packets affected by forward chain? :)
And how to block them?
 
User avatar
nickb
Member
Member
Posts: 407
Joined: Thu Jan 26, 2006 6:24 pm
Location: Southeast Kansas
Contact:

Re: how to block dhcp from my client to me!!

Thu Mar 20, 2008 10:35 pm

Turn off "forwarding" on the wireless side; such as disable "default forward" if you have are using "default authenticate", or uncheck "Forwarding" in the access list entry for a MAC address. This will prevent DHCP from broadcasting to other wireless clients.
 
tenis
just joined
Posts: 3
Joined: Wed Jan 02, 2008 8:12 pm

Re: how to block dhcp from my client to me!!

Fri Mar 21, 2008 1:09 am

Turn off "forwarding" on the wireless side; such as disable "default forward" if you have are using "default authenticate", or uncheck "Forwarding" in the access list entry for a MAC address. This will prevent DHCP from broadcasting to other wireless clients.
What exactly turning off default-forwarding do? It just stops broadcasting all broadcasts from clients? This would be great, cause I had quite a few issues related to this (private DHCP server on client side, providing incorrect leases, etc.)
But I still would like to have clients able to speak between each other. How the arp who-has will be responded if it will not be broadcasted to all clients. Would AP be able to make this working?
 
User avatar
gmeyer
just joined
Posts: 12
Joined: Fri Aug 17, 2007 3:56 am
Location: Esperanza, Santa Fe, Argentina
Contact:

Re: how to block dhcp from my client to me!!

Fri Mar 21, 2008 4:28 am

Add filters in the bridge on the wireless interface

add chain=input mac-protocol=ip src-port=67 ip-protocol=udp action=drop comment="Drop DHCP" disabled=no in-interface=wireless

add chain=forward mac-protocol=ip src-port=67 ip-protocol=udp action=drop comment="Drop DHCP" disabled=no in-interface=wireless

Remember that broadcast working on layer 2
Gabriel J. M. Meyer
CCNA, Red Hat Linux Administrator
 
totalnett
newbie
Posts: 25
Joined: Fri Sep 23, 2005 9:48 am

Re: how to block dhcp from my client to me!!

Tue Mar 25, 2008 2:18 pm

Can't get this to work.
I have routeros 3.4 on a RB192...

Do i have to mark packets in Mangle first? How should i do this?

Who is online

Users browsing this forum: cbpapi, Google [Bot], hanzel619, m86895, shimo and 111 guests