Community discussions

 
InoX
Forum Guru
Forum Guru
Topic Author
Posts: 1962
Joined: Tue Jan 09, 2007 6:44 pm

New proxy

Wed Mar 19, 2008 9:24 am

The new proxy is not working well, not on v.2.9.51 and v.3.4. Http is very slow most of the time, if I try to stop it, look at the picture(is still running), cache is 0 after upgrade.
You do not have the required permissions to view the files attached to this post.
Last edited by InoX on Wed Mar 19, 2008 11:08 am, edited 1 time in total.
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: New proxy is a crap

Wed Mar 19, 2008 9:41 am

in screen shot you can clearly see that proxy is not enabled.
 
InoX
Forum Guru
Forum Guru
Topic Author
Posts: 1962
Joined: Tue Jan 09, 2007 6:44 pm

Re: New proxy is a crap

Wed Mar 19, 2008 9:55 am

If you can read, i say I can't stop it!!! And when is running cache is 0 anyway. No problems in 2.9.51 with old proxy.
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: New proxy is a crap

Wed Mar 19, 2008 10:01 am

so if you un-check "enable" and then push apply it is still running?
 
InoX
Forum Guru
Forum Guru
Topic Author
Posts: 1962
Joined: Tue Jan 09, 2007 6:44 pm

Re: New proxy

Wed Mar 19, 2008 11:00 am

Yes. In both v.2.9 and 3.4. and http was very, very slow.
 
Znuff
Member Candidate
Member Candidate
Posts: 139
Joined: Tue Sep 26, 2006 2:42 am
Contact:

Re: New proxy

Wed Mar 19, 2008 11:03 am

We've already been trough this with support.

The Mikrotik webproxy is slow. Very slow compared to squid.

Even upgraded to 3.4 today and it was STILL slow. Under 2.9.x, the webproxy-test was slow _AND_ buggy.

No issues with the old webproxy. Any chance to have that back in 3.x?
 
WirelessRudy
Forum Guru
Forum Guru
Posts: 3082
Joined: Tue Aug 08, 2006 5:54 pm
Location: Spain

Re: New proxy

Wed Mar 19, 2008 1:17 pm

I have the same settings as Inox (screenshot) but enabled. But my proxy just does not want to work.
All nat and redirect rules in place.
When I disable the proxy all http traffic stops. So this must be a sign the proxy works?
But no cache hits, and data from server is the same as date send to client. But cache hits and hits sends all stay ¨0¨ even after a day with more then 60 users on line.

If I fill in ¨unlimited¨ in Max. Cache Size while ¨cache On Disk¨ ticked on, it stays unlimited (the manual says it should come back with a value)
When I untick the ¨cache On Disk¨ there is a value calculated. But still no hits.
So it looks like the proxy works, but not the cache routine.


rgds

Rudy
Show your appreciation of this post by giving me Karma! Thanks.

Rudy R. Puister

WISP operator based on MT routerboard & ROS.
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: New proxy

Wed Mar 19, 2008 1:58 pm

ok, just install 3.5 when it comes out today.
 
WirelessRudy
Forum Guru
Forum Guru
Posts: 3082
Joined: Tue Aug 08, 2006 5:54 pm
Location: Spain

Re: New proxy

Wed Mar 19, 2008 3:44 pm

Janisk,

Am running 3.5 now.
Proxy started to work now. But not very good.

Initial http pages come in very slowly, the idle http://www.google.com took 10 secs to load, after that the page came from the cache in a split second. (I cleared history and cache etc. in the browser and rebooted the browser)

but one of my clients told me he could not even browse anymore. He used the same pages to try as i did.
I disabled the proxy and the redirect rule and he can browse again, like I can myself.

He is a wireless client in a routed network while I am just on the LAN side for the main router that has the proxy running.
I have all rules in ´web proxy´ ¨Access¨ and ¨Cache¨ disabled.

Also, the ¨Max. cache Size¨ still keeps saying ´unlimited´ in contrary of what the manual would make me expect (a value).

So, 3.5 improved things for proxy here, but still not good.

rgds.
Show your appreciation of this post by giving me Karma! Thanks.

Rudy R. Puister

WISP operator based on MT routerboard & ROS.
 
Znuff
Member Candidate
Member Candidate
Posts: 139
Joined: Tue Sep 26, 2006 2:42 am
Contact:

Re: New proxy

Thu Mar 20, 2008 10:31 am

There:
webproxy-3.4.png
You do not have the required permissions to view the files attached to this post.
 
WirelessRudy
Forum Guru
Forum Guru
Posts: 3082
Joined: Tue Aug 08, 2006 5:54 pm
Location: Spain

Re: New proxy

Thu Mar 20, 2008 11:16 am

So,
Your proxy stopped working now in 3.5 when it is disabled. Good for you.
But how does it work when it is enabled?
Does it work fine? Or with flaws?
Like said, mine doesn't work very good. Initial pages (not in the cache yet) come to the browsing PC veeerrrryyyy slow. After that it is fast.
Some clients can´t even browse anymore. I think the initial page come in so slow they get a timeout.

Very disappointing. I hoped proxy would improve my clients browsing but I am back to direct again. At least that works and much faster then with the proxy. (At least for new pages.)

Rudy
Show your appreciation of this post by giving me Karma! Thanks.

Rudy R. Puister

WISP operator based on MT routerboard & ROS.
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: New proxy

Thu Mar 20, 2008 12:23 pm

i am using routeros proxy myself and i do not experience any slowdowns.\

what pages are slow to open first time, i triet msn.com, yahoo.com, apple.com, hp.com and all of those opened really fast
 
Znuff
Member Candidate
Member Candidate
Posts: 139
Joined: Tue Sep 26, 2006 2:42 am
Contact:

Re: New proxy

Thu Mar 20, 2008 12:28 pm

Can we have old squid back in 3.x?

Thanks.
 
WirelessRudy
Forum Guru
Forum Guru
Posts: 3082
Joined: Tue Aug 08, 2006 5:54 pm
Location: Spain

Re: New proxy

Thu Mar 20, 2008 1:31 pm

i am using routeros proxy myself and i do not experience any slowdowns.\

what pages are slow to open first time, i triet msn.com, yahoo.com, apple.com, hp.com and all of those opened really fast
Janisk:
Proxy enabled: 1st page request 2nd request proxy disabled

msn.com 25s 25s 3s
yahoo.com 8s 19s 3s
apple.com 45s 17s 7s
hp.com 8s 8s 3s
google.com 1s 2s 1s
cnn.com 12s 17s 8s

In between everytime the browser cache and history cleaned and the browser rebooted.
Same test done with two of my clients and they have the same sort of results. One can hardly browse if the proxy is enabled while everything runs fine when it is disabled.
Made these clienst also clear the cache and history everytime.

I have more sites, special the ones with loads of links in them that are really slowed down a lot by the proxy.
Something must be wrong... :( :(
 
User avatar
Dragonmen
Frequent Visitor
Frequent Visitor
Posts: 72
Joined: Thu Jun 16, 2005 6:20 pm
Location: Sabac, Serbia
Contact:

Re: New proxy

Thu Mar 20, 2008 2:24 pm

Why not using the separate machine for proxy and reduce the load on router?
Surely the separate machine with squid can run faster than the ROS's integrated proxy and you'll have many, many more features.
Do not use 3.0 branch (yet) as it is slower than 2.X and more buggy.
 
savage
Forum Guru
Forum Guru
Posts: 1206
Joined: Mon Oct 18, 2004 12:07 am
Location: Cape Town, South Africa
Contact:

Re: New proxy

Thu Mar 20, 2008 3:26 pm

Said it before, will say it again...

A router is a router, a proxy is a proxy :lol: They are fundamentally different. MT does not support the required hardware to make a good proxy to serve a high number of users, nor does the configurations cater for it. If you want a proxy, install one on a dedicated box...
Regards,
Chris
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8308
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: New proxy

Fri Mar 21, 2008 2:45 am

savage, do not mix proxy and cache. I do not use cache in proxy, but I need proxy to log users' web surfing

yesterday I write support twice, but no reply. did Ticket system crashed?.. so, my problem is:
I've just upgraded my ros to 3.5. When trying to go to Internet via web-proxy, it uses my private address (192.168.xxx.xxx) for outgoing connections. When I set my public address (xxx.xxx.xxx.xxx) as proxy Src-Address, I cannot even connect to proxy - telnet to port 80 to any internet site says "Connection refused". Now I found the only workaround: add Src-NAT rule with src-address=192.168.xxx.xxx and out-interface=uplink, action=masquerade. It's working now, but... Please fix that =)
supout.rif were attached. normis, janisk?..
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.

Who is online

Users browsing this forum: No registered users and 9 guests