Community discussions

MUM Europe 2020
 
User avatar
smurphy
Member Candidate
Member Candidate
Topic Author
Posts: 103
Joined: Wed Feb 06, 2008 6:48 pm
Location: Clermont / France
Contact:

pppoe-client setup - stop for 10secs, then try again ?

Mon Mar 24, 2008 2:35 pm

Hia folks,

I am having kind of a little issue.
My provider has setup a protection against pppoe-request storms. Means - every client is only allowed to perform on request all 10secs.
This means - that when for any reason the router wants to get a new IP - it tries to get an IP address, if it doesn't work, the next etc.
However the frequency is way too high..
Any chance - somewhere, to define the IP-Address request frequency ? or does somewhere a script for that exist ?

If I disable the pppoe Interface for 10seconds, ad reenable it after at least 10sec - I get an IP right away.
Only - if I am not onsite - I can't do that ...

Thx for any hint.
 
User avatar
smurphy
Member Candidate
Member Candidate
Topic Author
Posts: 103
Joined: Wed Feb 06, 2008 6:48 pm
Location: Clermont / France
Contact:

Re: pppoe-client setup - stop for 10secs, then try again ?

Fri Mar 28, 2008 10:59 am

Ok - I have circumvented it by using the watchdog functionality - but IMHO - this isn 't clean.
I tend to actually solve issues at their source - however - as this is no FOSS - I can't ...

Could I kindly ask the developers to add a redial-time variable into it ?
E.g. if set - wait that amount of time befor trying to open up another PPPoE Connection ?
That would be really nice.

E.g. I could also imagine this as beeing a DOS protection on the PPPoE Server side in case the router is used as PPPoE Concentrator !

Who is online

Users browsing this forum: antonme, Google [Bot], MSN [Bot] and 94 guests