Community discussions

 
gacopl
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 63
Joined: Sun Jul 29, 2007 5:11 pm
Location: Poland

OSPF broken in v3.6

Thu Mar 27, 2008 10:24 am

Hello everyone

Yesterday i upgraded my RB 411 and RB532r5 to ros 3.6 (before there was 3.3 for rb411 and 2.9.51 for rb532r5), OSPF just gone crazy. I had to change attributes of AREAs to make it work, then when i rebooted one of them, it didn't work (the status of neighbor was changing, like 5 times per 2 seconds, ExStart etc, sometimes status was "full", but nevertheless the routes wasn't transfered).
So in order to make it work again i had to tweak authentication method from simple, none to MD5, sometimes on one end of area, sometimes on the other, sometimes i had to reset interface, anyway it acted really weird. I have to add, that at the same time OSPF between that r532r5 and other MT with 2.9.51 was working ok (reboot of any of those systems didn't cause a trouble to make them work again).
I tried everything, setting from scratch areas with totally different settings, but it didn't work either. When i rolled back r411 to v3.4, everything started to working just fine, reboots didn't cause the problem anymore. I'm wondering now whether it was a problem with 3.6 on rb411, or v3.6 can't cooperate properly with other 3.6 in OSPF. I'll try to upgrade one of the other MT to v3.6 and check if this happens again.

My question is why MT releases ROS with so many bugs, but anyway, why i can't download previous versions from the website, especially if v3.6 has many problems including it don't boots up properly on x86. If anyone has some links or can provide me with all packages for 3.4 for all platforms. I would really appreciate that. ok i just found a torrent for it anyway i think that there should be at least a link to couple of previous versions on site, at least pointing to a torrent files.

Cheers
Michal
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: OSPF broken in v3.6

Thu Mar 27, 2008 10:52 am

use one version over all routers, as there where some major OSPF changes. If you can check if you can successfully upgrade to 3.6 all your routers as this is IMO most stable OSPF ever in routeros.
 
gacopl
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 63
Joined: Sun Jul 29, 2007 5:11 pm
Location: Poland

Re: OSPF broken in v3.6

Thu Mar 27, 2008 11:32 am

i would certainly do that, as i always try to use the ros version on all routers, but i have 3 x86 machines in my network, and i'm too afraid to upgrade them to 3.6 as therewere many reports of crashes on them. And i have pretty hard access to those sites so i can't afford to accidently cut off over 50 users from net :/. But what wonders me is that i had those problems between two 3.6 routers maybe i should try to, turn off OSPF with those 2 others that have 2.9.51 and then check it again between those two that have 3.6.

cheers
Michal
 
User avatar
promind
Member Candidate
Member Candidate
Posts: 153
Joined: Thu Feb 23, 2006 11:26 am
Location: Rousse, Bulgaria
Contact:

Re: OSPF broken in v3.6

Thu Mar 27, 2008 1:00 pm

i would certainly do that, as i always try to use the ros version on all routers, but i have 3 x86 machines in my network, and i'm too afraid to upgrade them to 3.6 as therewere many reports of crashes on them. And i have pretty hard access to those sites so i can't afford to accidently cut off over 50 users from net :/. But what wonders me is that i had those problems between two 3.6 routers maybe i should try to, turn off OSPF with those 2 others that have 2.9.51 and then check it again between those two that have 3.6.

cheers
Michal
Do not warry...3.6 is working just fine on x86.
 
User avatar
magic
Frequent Visitor
Frequent Visitor
Posts: 52
Joined: Fri Mar 04, 2005 9:53 pm
Location: Sopron, Hungary
Contact:

Re: OSPF broken in v3.6

Thu Mar 27, 2008 1:05 pm

The ospf in 3.6 is much more reliable then 2.9.51 (but still has some very small bug). But before you upgrade check that your routers work with 3.6, because it needs more cpu capacity than 2.9.51.
Krisztian Gancs
RLAN Internet Ltd.
http://www.rlan.hu
 
gacopl
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 63
Joined: Sun Jul 29, 2007 5:11 pm
Location: Poland

Re: OSPF broken in v3.6

Thu Mar 27, 2008 1:55 pm

Do not warry...3.6 is working just fine on x86.
So please tell me what is this topic about?: http://forum.mikrotik.com/viewtopic.php?f=2&t=22689
But before you upgrade check that your routers work with 3.6, because it needs more cpu capacity than 2.9.51.
The worst i have is couple RB133, but i think they can survive it, do they?

Best Regards
Michal
 
gacopl
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 63
Joined: Sun Jul 29, 2007 5:11 pm
Location: Poland

Re: OSPF broken in v3.6

Thu Mar 27, 2008 2:02 pm

One thing came up to my mind, i always download all packages and install them onto routers, so even if i don't use say dude package it's nevertheless installed, maybe that's what i'm doing wrong, maybe some additional package causes the problem? Is that possible?

Best Regards
Michal
 
User avatar
promind
Member Candidate
Member Candidate
Posts: 153
Joined: Thu Feb 23, 2006 11:26 am
Location: Rousse, Bulgaria
Contact:

Re: OSPF broken in v3.6

Thu Mar 27, 2008 4:10 pm

One thing came up to my mind, i always download all packages and install them onto routers, so even if i don't use say dude package it's nevertheless installed, maybe that's what i'm doing wrong, maybe some additional package causes the problem? Is that possible?

Best Regards
Michal
I don't think that RouterOS is your problem...
I have 2 x86 machines powered by RouterOS 3.6 with ospf, pppoe-server, radiusclient and firewall running and till now/knock,knock,knock/ I don't have any kind of problems with them.
/ just to remind MT guys that P II on 333Mhz performs better than rb600 :) /
 
User avatar
magic
Frequent Visitor
Frequent Visitor
Posts: 52
Joined: Fri Mar 04, 2005 9:53 pm
Location: Sopron, Hungary
Contact:

Re: OSPF broken in v3.6

Fri Mar 28, 2008 9:54 am

I have a couple of rb133 and rb153. Every of these is for bridging only (wireless to ethernet). No routing on it, no firewall, no connection tracking. Works very well with 2.9.51. After upgrade to v3 most of these works well but don't have enough cpu to let me logging in with winbox. So I take back 2.9.51.
On rb411,rb333 and pc's there was no trouble with v3. There was trouble with 3.4 on some intel pc's for me with the above mentioned booting trouble but these pc's works fine with v3.6.
I only install packages what is needed on the router manually (through auto-upgrade) when needed. You don't have to upgrade a router which works fine. Only when you need a new function or change.
Krisztian Gancs
RLAN Internet Ltd.
http://www.rlan.hu
 
gacopl
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 63
Joined: Sun Jul 29, 2007 5:11 pm
Location: Poland

Re: OSPF broken in v3.6

Fri Mar 28, 2008 11:48 am

Hello

Okay now i say my story, yesterday i upgraded all routers to 3.6, pcs boot up properly and everything was fine but i still encountered some problems with ospf, even when link was down for just a second when it came back, the devices couldn't talk to each other, i again had to fiddle with settings changing back and forth to make it work again, sometimes i had to reboot other end to make ospf talk to each other. but after a couple times i fiddled with the changes, everything cam back to normal and after restarts wireless links hang ups they could easily continue talk to each other I encountered this problem only in other areas than backbone.

Ok everything seemed to work fine, at home i'm connected to pc router, i use pppoe in my network, what i encountered, was whenever i was downloading/uploading something by bittorrent, every i don't know 20-30 seconds there were 2 ping losses. when i was downloading something by normal http transfer everything was fine. i couldn't let that situation stay so i downgraded my pc os to 3.4 And here it came up a problem with booting, i thought great, machine does not wake up, i'm dead (this pc is on the church tower). but after ten minutes it went up i did restart to make sure this wasn't just accident. And again booting took 10 minutes but the problem with torrent (massive packets) disappeared. Nevertheless i decided this cannot stay, i decided F* this and downgraded to 2.9.51. What happened is that machine didn't woke up anymore, today i had to leave my workplace and move my a** to that tower i came in and what turned out is, that all interfaces were disabled except ethernet, and there were many settings defaulted, fortunately i had a backup :), so i restored it and everything went back to normal.

To sum this up v3 of ROS should be still RC if not Beta, there are still many bugs and surprises, yes it may work ok with bridge but if you use advanced options like ospf, pppoe, routing marks, firewall mangle and conntrack there are still many problems out there. I really think that MikroTik should be more careful with next "STABLE" releases. My network is small, i love MT and i won't stop using it, however such things cannot happen in professional WISP equipment, which MT is being called. And there cannot be such a thing, when something works in earlier version and then in another suddenly it just stops to work ( i had that with one NAT rule, however i fixed it after few minutes )

I have to wait for another release, maybe then they'll fix that pppoe problem i still have rest of routers running v3.6, and i'll wait to see what happens. I cannot use 3.4 (which is for now most reasonable release for me), becase it has "find" memory leak which i extensively use in my scripts.


Best Regards
Michal
 
User avatar
magic
Frequent Visitor
Frequent Visitor
Posts: 52
Joined: Fri Mar 04, 2005 9:53 pm
Location: Sopron, Hungary
Contact:

Re: OSPF broken in v3.6

Fri Mar 28, 2008 12:18 pm

The pppoe have bug, but the MT try to fix it in 3.7. You can read about this in other post in the the forum.
I don't know why your ospf didn't worked in v3. Maybe if you post your config and firewall rules we can find something. I upgrade my routers from 2.9 to v3 and didn't changed anything in the ospf config. There were ospf bug which caused to sometimes the osp lost his routes but MT tried to repair it. I have this issue only 1-2 times in a week somewhere in our network on 1 router. The 2.9.51 was worst. In heavy traffic the ospf lost routes every 1-2 hours.

Do not use 3.4 on PC's. There is the known bug about booting. 3.6 seems to work fine.

If you downgrade to 2.9 the wireless settings will be reseted. So you only do that if you have connection on the ethernet port to set the wireless settings again.
Krisztian Gancs
RLAN Internet Ltd.
http://www.rlan.hu
 
gacopl
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 63
Joined: Sun Jul 29, 2007 5:11 pm
Location: Poland

Re: OSPF broken in v3.6

Fri Mar 28, 2008 12:28 pm

Hello

Well, i really don't have any problems with ospf in 2.9.51 and 2.9.50, it really worked spectacular til yestarday (with previous version like 2.9.4x there were problems with ospf you talk about).
I'll try later to post here a config, maybe i really have some shitty conf ;), but anyway when something worked just fine with 2.9 it still should with next version :P

Cheers
Michal
 
User avatar
promind
Member Candidate
Member Candidate
Posts: 153
Joined: Thu Feb 23, 2006 11:26 am
Location: Rousse, Bulgaria
Contact:

Re: OSPF broken in v3.6

Fri Mar 28, 2008 5:41 pm

Hello

Well, i really don't have any problems with ospf in 2.9.51 and 2.9.50, it really worked spectacular til yestarday (with previous version like 2.9.4x there were problems with ospf you talk about).
I'll try later to post here a config, maybe i really have some shitty conf ;), but anyway when something worked just fine with 2.9 it still should with next version :P

Cheers
Michal
My Current configuration which has no problem:
# mar/28/2008 16:40:18 by RouterOS 3.6
# software id = XXXX-XXX
#
/routing ospf area
add area-id=0.0.0.0 authentication=none disabled=no name="backbone" type=default
add area-id=0.0.0.21 authentication=md5 disabled=no name="area21" type=default
/routing ospf
set distribute-default=never metric-bgp=20 metric-connected=20 metric-default=1 metric-rip=20 metric-static=20 \
mpls-te-area=unspecified mpls-te-router-id=unspecified redistribute-bgp=no redistribute-connected=as-type-1 \
redistribute-rip=no redistribute-static=no router-id=Y.Y.Y.Y
/routing ospf area range
add advertise=yes area=area21 cost=default disabled=no range=X.X.X.X/30
/routing ospf interface
add authentication=md5 authentication-key="verysecretkey" cost=10 dead-interval=10s disabled=no hello-interval=3s \
interface=vlan209 network-type=broadcast passive=no priority=1 retransmit-interval=5s transmit-delay=1s
/routing ospf network
add area=area21 disabled=no network=X.X.X.X/30
P.S. Border router is running pure Linux with quagga.
 
gacopl
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 63
Joined: Sun Jul 29, 2007 5:11 pm
Location: Poland

Re: OSPF broken in v3.6

Fri Mar 28, 2008 7:55 pm

Ok now i see hope in you, you see i don't have area ranges specified,i have just area backbone, and between my routers i have 5ghz wireless links each of wireless card has it's own bridge (let say interface is Ni-K and the bride for it is ni-k-br, to this bridge is attached only that one interface) on the other device (other end of link) i have k-ni interface and k-ni-br bridge. I hope you follow :) on those bridge interfaces i have let say ip addresses 10.22.0.1/24 and on the other end 10.22.0.2/24, from the second router i have another link say k-pr to pr-k and on that link i use ip adresses 10.23.0.1/24 and 10.23.0.2/24. And so on, i know i could make it more reasonab le say use on C class and do many small /30 classes. on the network section i always put 10.xx.0.0/24 and add it to area backbone. like i said this all worked so i didn't need to change it. I may also add that i'm distributing static-routes as well.

Please give me light on this, because i always felt that i was doing it wrong, but i never had a chance to talk to somebody that actually done that on MT.

Awaiting for your feedback

B/R
Michal
 
User avatar
promind
Member Candidate
Member Candidate
Posts: 153
Joined: Thu Feb 23, 2006 11:26 am
Location: Rousse, Bulgaria
Contact:

Re: OSPF broken in v3.6

Mon Mar 31, 2008 9:53 am

Ok now i see hope in you, you see i don't have area ranges specified,i have just area backbone, and between my routers i have 5ghz wireless links each of wireless card has it's own bridge (let say interface is Ni-K and the bride for it is ni-k-br, to this bridge is attached only that one interface) on the other device (other end of link) i have k-ni interface and k-ni-br bridge. I hope you follow :) on those bridge interfaces i have let say ip addresses 10.22.0.1/24 and on the other end 10.22.0.2/24, from the second router i have another link say k-pr to pr-k and on that link i use ip adresses 10.23.0.1/24 and 10.23.0.2/24. And so on, i know i could make it more reasonab le say use on C class and do many small /30 classes. on the network section i always put 10.xx.0.0/24 and add it to area backbone. like i said this all worked so i didn't need to change it. I may also add that i'm distributing static-routes as well.

Please give me light on this, because i always felt that i was doing it wrong, but i never had a chance to talk to somebody that actually done that on MT.

Awaiting for your feedback

B/R
Michal
Sorry but I couldn't get it...can you post some configs?
I've specified different areas for each of my RASes which are all connected to my border router.
 
gacopl
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 63
Joined: Sun Jul 29, 2007 5:11 pm
Location: Poland

Re: OSPF broken in v3.6

Mon Mar 31, 2008 11:43 am

Hello

Okay i'll try to present it, below you have a quick draw of my backbone:
ospf.JPG

Now here's the config for A router:

/routing ospf area
add area-id=0.0.0.0 authentication=md5 disabled=no name="backbone" \
type=default
/routing ospf
set distribute-default=never metric-bgp=20 metric-connected=20 \
metric-default=0 metric-rip=20 metric-static=20 mpls-te-area=unspecified \
mpls-te-router-id=unspecified redistribute-bgp=no \
redistribute-connected=as-type-1 redistribute-rip=no \
redistribute-static=as-type-2 router-id=10.100.1.1
/routing ospf interface
add authentication=none authentication-key="verysecretkey" cost=10 \
dead-interval=4s disabled=no hello-interval=1s interface=A-B-BR \
network-type=broadcast passive=no priority=1 retransmit-interval=5s \
transmit-delay=1s
add authentication=none authentication-key="verysecretkey" cost=10 \
dead-interval=4s disabled=no hello-interval=1s interface=A-E-BR \
network-type=broadcast passive=no priority=1 retransmit-interval=5s \
transmit-delay=1s
/routing ospf network
add area=backbone disabled=no network=10.11.0.0/24
add area=backbone disabled=no network=10.17.0.0/24

/ip address
add address=10.11.0.2/24 broadcast=10.11.0.255 comment="" disabled=no \
interface=A-B-BR network=10.11.0.0
add address=10.17.0.2/24 broadcast=10.17.0.255 comment="" disabled=no \
interface=A-E-BR network=10.17.0.0

/interface bridge
add admin-mac=00:00:00:00:00:00 ageing-time=5m arp=enabled auto-mac=yes \
comment="" disabled=no forward-delay=15s max-message-age=20s mtu=1500 \
name="A-B-BR" priority=0x8000 protocol-mode=none transmit-hold-count=6
add admin-mac=00:00:00:00:00:00 ageing-time=5m arp=enabled auto-mac=yes \
comment="" disabled=no forward-delay=15s max-message-age=20s mtu=1500 \
name="A-E-BR" priority=0x8000 protocol-mode=none transmit-hold-count=6
/interface bridge port
add bridge=A-B-BR comment="" disabled=no edge=auto external-fdb=auto \
horizon=none interface=A-B path-cost=10 point-to-point=auto priority=0x80
add bridge=A-E-BR comment="" disabled=no edge=auto external-fdb=auto \
horizon=none interface=A-E path-cost=10 point-to-point=auto priority=0x80


And the conf for the B router:

/routing ospf area
add area-id=0.0.0.0 authentication=md5 disabled=no name="backbone" \
type=default
/routing ospf
set distribute-default=never metric-bgp=20 metric-connected=20 \
metric-default=0 metric-rip=20 metric-static=20 mpls-te-area=unspecified \
mpls-te-router-id=unspecified redistribute-bgp=no \
redistribute-connected=as-type-1 redistribute-rip=no \
redistribute-static=as-type-2 router-id=10.100.2.1
/routing ospf interface
add authentication=none authentication-key="verysecretkey" cost=10 \
dead-interval=4s disabled=no hello-interval=1s interface=B-A-BR \
network-type=broadcast passive=no priority=1 retransmit-interval=5s \
transmit-delay=1s
add authentication=none authentication-key="verysecretkey" cost=10 \
dead-interval=4s disabled=no hello-interval=1s interface=B-C-BR \
network-type=broadcast passive=no priority=1 retransmit-interval=5s \
transmit-delay=1s
/routing ospf network
add area=backbone disabled=no network=10.11.0.0/24
add area=backbone disabled=no network=10.12.0.0/24

/ip address
add address=10.11.0.2/24 broadcast=10.11.0.255 comment="" disabled=no \
interface=B-A-BR network=10.11.0.0
add address=10.12.0.2/24 broadcast=10.12.0.255 comment="" disabled=no \
interface=B-C-BR network=10.12.0.0

/interface bridge
add admin-mac=00:00:00:00:00:00 ageing-time=5m arp=enabled auto-mac=yes \
comment="" disabled=no forward-delay=15s max-message-age=20s mtu=1500 \
name="B-A-BR" priority=0x8000 protocol-mode=none transmit-hold-count=6
add admin-mac=00:00:00:00:00:00 ageing-time=5m arp=enabled auto-mac=yes \
comment="" disabled=no forward-delay=15s max-message-age=20s mtu=1500 \
name="B-C-BR" priority=0x8000 protocol-mode=none transmit-hold-count=6
/interface bridge port
add bridge=B-A-BR comment="" disabled=no edge=auto external-fdb=auto \
horizon=none interface=B-A path-cost=10 point-to-point=auto priority=0x80
add bridge=B-C-BR comment="" disabled=no edge=auto external-fdb=auto \
horizon=none interface=B-C path-cost=10 point-to-point=auto priority=0x80

Those configs looks pretty the same for B-C connection C-D etc. (of course the ip adresses are different but the whole idea stays the same)

Hope now you can understand it. There's another problem that i have met, recently i got ip pool from ripe, and i assign public ips by pppoe (for egz. 88.134.25.100) to some of my end users, i also added an public ips to the routers(88.134.25.50-55), and what i see when i do a traceroute from internet to 88.134.25.100 that the route is traceable only to my gateway, then when it goes say through routers A and B (it shows priavate adresses (for egz. 10.11.0.2) or just "*"). I'm sure there's something trivial in how i do configuration of ospf or interfaces. I would really appreciate your help

Cheers
Michal
You do not have the required permissions to view the files attached to this post.
 
gacopl
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 63
Joined: Sun Jul 29, 2007 5:11 pm
Location: Poland

Re: OSPF broken in v3.6

Tue Apr 01, 2008 11:37 pm

Hello

Please look below, and see this is not something that, i've made up, and this is not something that can be acceptable.
ospf2.jpg

Cheers
Michal
You do not have the required permissions to view the files attached to this post.
 
CarulloS
Member
Member
Posts: 406
Joined: Thu Feb 02, 2006 5:52 am

Re: OSPF broken in v3.6

Wed Apr 02, 2008 7:15 am

Janisk says
use one version over all routers, as there where some major OSPF changes. If you can check if you can successfully upgrade to 3.6 all your routers as this is IMO most stable OSPF ever in routeros.
Are you referring to running v3 on al routers talking together or are you talking about 3.6 specifically... Like were there major changes from 2.9 to 3 or something new in v3.6 not in 3.5/3.4 etc....

Thanks for the clarification...

Scott
 
gacopl
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 63
Joined: Sun Jul 29, 2007 5:11 pm
Location: Poland

Re: OSPF broken in v3.6

Wed Apr 02, 2008 9:16 am

I did like janisk said, i upgraded all my routers to 3.6, but this still remains the issue :/, i never had such a problem before with v2.9

Cheers
Michal
 
ste
Forum Guru
Forum Guru
Posts: 1813
Joined: Sun Feb 13, 2005 11:21 pm

Re: OSPF broken in v3.6

Wed Apr 02, 2008 9:31 am

Hi Michael,

I don't understand why you're using bridges?
Makes things complicated and more likely to run into a bug ;-)).
Or do I miss the point?

Stefan
Hello

Okay i'll try to present it, below you have a quick draw of my backbone:
ospf.JPG

Now here's the config for A router:

/routing ospf area
add area-id=0.0.0.0 authentication=md5 disabled=no name="backbone" \
type=default
/routing ospf
set distribute-default=never metric-bgp=20 metric-connected=20 \
metric-default=0 metric-rip=20 metric-static=20 mpls-te-area=unspecified \
mpls-te-router-id=unspecified redistribute-bgp=no \
redistribute-connected=as-type-1 redistribute-rip=no \
redistribute-static=as-type-2 router-id=10.100.1.1
/routing ospf interface
add authentication=none authentication-key="verysecretkey" cost=10 \
dead-interval=4s disabled=no hello-interval=1s interface=A-B-BR \
network-type=broadcast passive=no priority=1 retransmit-interval=5s \
transmit-delay=1s
add authentication=none authentication-key="verysecretkey" cost=10 \
dead-interval=4s disabled=no hello-interval=1s interface=A-E-BR \
network-type=broadcast passive=no priority=1 retransmit-interval=5s \
transmit-delay=1s
/routing ospf network
add area=backbone disabled=no network=10.11.0.0/24
add area=backbone disabled=no network=10.17.0.0/24

/ip address
add address=10.11.0.2/24 broadcast=10.11.0.255 comment="" disabled=no \
interface=A-B-BR network=10.11.0.0
add address=10.17.0.2/24 broadcast=10.17.0.255 comment="" disabled=no \
interface=A-E-BR network=10.17.0.0

/interface bridge
add admin-mac=00:00:00:00:00:00 ageing-time=5m arp=enabled auto-mac=yes \
comment="" disabled=no forward-delay=15s max-message-age=20s mtu=1500 \
name="A-B-BR" priority=0x8000 protocol-mode=none transmit-hold-count=6
add admin-mac=00:00:00:00:00:00 ageing-time=5m arp=enabled auto-mac=yes \
comment="" disabled=no forward-delay=15s max-message-age=20s mtu=1500 \
name="A-E-BR" priority=0x8000 protocol-mode=none transmit-hold-count=6
/interface bridge port
add bridge=A-B-BR comment="" disabled=no edge=auto external-fdb=auto \
horizon=none interface=A-B path-cost=10 point-to-point=auto priority=0x80
add bridge=A-E-BR comment="" disabled=no edge=auto external-fdb=auto \
horizon=none interface=A-E path-cost=10 point-to-point=auto priority=0x80


And the conf for the B router:

/routing ospf area
add area-id=0.0.0.0 authentication=md5 disabled=no name="backbone" \
type=default
/routing ospf
set distribute-default=never metric-bgp=20 metric-connected=20 \
metric-default=0 metric-rip=20 metric-static=20 mpls-te-area=unspecified \
mpls-te-router-id=unspecified redistribute-bgp=no \
redistribute-connected=as-type-1 redistribute-rip=no \
redistribute-static=as-type-2 router-id=10.100.2.1
/routing ospf interface
add authentication=none authentication-key="verysecretkey" cost=10 \
dead-interval=4s disabled=no hello-interval=1s interface=B-A-BR \
network-type=broadcast passive=no priority=1 retransmit-interval=5s \
transmit-delay=1s
add authentication=none authentication-key="verysecretkey" cost=10 \
dead-interval=4s disabled=no hello-interval=1s interface=B-C-BR \
network-type=broadcast passive=no priority=1 retransmit-interval=5s \
transmit-delay=1s
/routing ospf network
add area=backbone disabled=no network=10.11.0.0/24
add area=backbone disabled=no network=10.12.0.0/24

/ip address
add address=10.11.0.2/24 broadcast=10.11.0.255 comment="" disabled=no \
interface=B-A-BR network=10.11.0.0
add address=10.12.0.2/24 broadcast=10.12.0.255 comment="" disabled=no \
interface=B-C-BR network=10.12.0.0

/interface bridge
add admin-mac=00:00:00:00:00:00 ageing-time=5m arp=enabled auto-mac=yes \
comment="" disabled=no forward-delay=15s max-message-age=20s mtu=1500 \
name="B-A-BR" priority=0x8000 protocol-mode=none transmit-hold-count=6
add admin-mac=00:00:00:00:00:00 ageing-time=5m arp=enabled auto-mac=yes \
comment="" disabled=no forward-delay=15s max-message-age=20s mtu=1500 \
name="B-C-BR" priority=0x8000 protocol-mode=none transmit-hold-count=6
/interface bridge port
add bridge=B-A-BR comment="" disabled=no edge=auto external-fdb=auto \
horizon=none interface=B-A path-cost=10 point-to-point=auto priority=0x80
add bridge=B-C-BR comment="" disabled=no edge=auto external-fdb=auto \
horizon=none interface=B-C path-cost=10 point-to-point=auto priority=0x80

Those configs looks pretty the same for B-C connection C-D etc. (of course the ip adresses are different but the whole idea stays the same)

Hope now you can understand it. There's another problem that i have met, recently i got ip pool from ripe, and i assign public ips by pppoe (for egz. 88.134.25.100) to some of my end users, i also added an public ips to the routers(88.134.25.50-55), and what i see when i do a traceroute from internet to 88.134.25.100 that the route is traceable only to my gateway, then when it goes say through routers A and B (it shows priavate adresses (for egz. 10.11.0.2) or just "*"). I'm sure there's something trivial in how i do configuration of ospf or interfaces. I would really appreciate your help

Cheers
Michal
 
gacopl
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 63
Joined: Sun Jul 29, 2007 5:11 pm
Location: Poland

Re: OSPF broken in v3.6

Wed Apr 02, 2008 9:42 am

Hello

There are 2 reasons, 1st is that whenever somethings f* up, when you have to change your card or whatever, you just do it and just add that card to proper bridge port and everything is setup;)

Other more important reason, is that when i first deployed ospf in my network, somehow this wasthe only way it could run, for every interface(even WAN and 2.4ghz) i have one bridge and on that bridge i'm doing traffic shapings, assign ips etc.

I don't know why it didn't work before, but really w hen i deployed it (i don't know maybe it was version 2.9.3x something) the only way i could deploy it is to make BR interface and on it do ospf.

There's one big reason i realized when i was trying right now to do this without bridges. When u use wireless and try to connect, you vae to use ap bridge or bridge between them, nevertheless always one of them will have to have a wds interface ( i do them dynamic) and therefore you have to add this wds interface to some bridge, and therefore you need to have that bridge and do everything on it :). I'm almost pretty sure that there is another way for it but i am too dumb to see it.

Do you really think this is so relevant ;>?

Cheers
Michal
 
ste
Forum Guru
Forum Guru
Posts: 1813
Joined: Sun Feb 13, 2005 11:21 pm

Re: OSPF broken in v3.6

Wed Apr 02, 2008 10:32 am

Hello

There are 2 reasons, 1st is that whenever somethings f* up, when you have to change your card or whatever, you just do it and just add that card to proper bridge port and everything is setup;)

Other more important reason, is that when i first deployed ospf in my network, somehow this wasthe only way it could run, for every interface(even WAN and 2.4ghz) i have one bridge and on that bridge i'm doing traffic shapings, assign ips etc.

I don't know why it didn't work before, but really w hen i deployed it (i don't know maybe it was version 2.9.3x something) the only way i could deploy it is to make BR interface and on it do ospf.

There's one big reason i realized when i was trying right now to do this without bridges. When u use wireless and try to connect, you vae to use ap bridge or bridge between them, nevertheless always one of them will have to have a wds interface ( i do them dynamic) and therefore you have to add this wds interface to some bridge, and therefore you need to have that bridge and do everything on it :). I'm almost pretty sure that there is another way for it but i am too dumb to see it.

Do you really think this is so relevant ;>?

Cheers
Michal
Hi Michal,

may be it`s relevant but who knows. I do not use bridges and OSPF works quite stable for me.
I`ve a mix of 2.9.xx and 3.xx devices. I do not use WDS. For all wireless-links I have ap/station
combination. No WDS just routing.
Before I had a bridged Proxim Network with some strange problems. So I do not like bridging.
I build network rings wherever possible.
What I've learned that Its no good Idea to have unstable links within the OSPF-Topology.
This makes ROS-OSPF weired. So I use OSPF only when there is redundancy. When there are
Network trees I do static routing. The root of the tree speaks OSPF to the rest of the network.

Stefan
 
gacopl
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 63
Joined: Sun Jul 29, 2007 5:11 pm
Location: Poland

Re: OSPF broken in v3.6

Wed Apr 02, 2008 11:24 am

Ok i'm changing my links according to the scheme you proposed, ap/station without bridge. Maybe you also know answer to my question regarding traceroute ?

cheers
Michal
 
gacopl
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 63
Joined: Sun Jul 29, 2007 5:11 pm
Location: Poland

Re: OSPF broken in v3.6

Wed Apr 02, 2008 3:33 pm

Hello

And like i thought nothing has changed :/, well at least i got rid of those br interfaces :)
Now i'm thinking that maybe there is something with my hell-interval and dead-interval, i always had it respectivily 1s and 4s (to make sure that use won't feel it when some router dies)

Cheers
Michal
 
ste
Forum Guru
Forum Guru
Posts: 1813
Joined: Sun Feb 13, 2005 11:21 pm

Re: OSPF broken in v3.6

Wed Apr 02, 2008 4:11 pm

Hello
And like i thought nothing has changed :/,
You never know befor you trie ;-)
well at least i got rid of those br interfaces :)
I'm sure this saves a lot of CPU-Cycles.

Now i'm thinking that maybe there is something with my hell-interval and dead-interval, i always had it respectivily 1s and 4s (to make sure that use won't feel it when some router dies)
Cheers
Michal
I use default values 10/40. As I use cisco and other devices too, I do not dare to play
with the defaults ;-)).
I think using such low values you get a lot of ospf traffic and very short
outages lead to recalculation of routes.
If the interface goes down the router should see it immediately.

Stefan
 
ste
Forum Guru
Forum Guru
Posts: 1813
Joined: Sun Feb 13, 2005 11:21 pm

Re: OSPF broken in v3.6

Wed Apr 02, 2008 4:15 pm

Ok i'm changing my links according to the scheme you proposed, ap/station without bridge. Maybe you also know answer to my question regarding traceroute ?

cheers
Michal
I cant see how you're exactly using this IPs. Check routing tables of the routers
building the tunnel. Does the traced IP really route to the tunnel.

Stefan
 
gacopl
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 63
Joined: Sun Jul 29, 2007 5:11 pm
Location: Poland

Re: OSPF broken in v3.6

Wed Apr 02, 2008 7:17 pm

I use default values 10/40. As I use cisco and other devices too, I do not dare to play
with the defaults ;-)).
I think using such low values you get a lot of ospf traffic and very short
outages lead to recalculation of routes.
If the interface goes down the router should see it immediately.

Stefan
Again it seems that problem persists i'll deploy those hello-interval values to all my areas and will wait till tomorrow if problem persists, i'll make supout file and send it to support. But i still would like to not bother MT guys

Cheers
Michal
 
gacopl
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 63
Joined: Sun Jul 29, 2007 5:11 pm
Location: Poland

Re: OSPF broken in v3.6

Thu Apr 03, 2008 9:57 am

Ok now i still have problem, thing that has changed, that it seems that i don't have this problem in bavckbone area anymore, however other areas still have this problems, those areas mostly look like this:

area3
E ------ Z

E-router that is part of backbone area and area3, (PC, v3.6)
Z-router that is only part of area3 (RB133, v3.6)

I have two such areas and on this areas problem persists, state changes are often, but not as often as it was before (this is because of changing hello-interval and dead-interval), nevertheless the problem hasn't got better, yes there are less state changes, but now they're taking more time :/.

Now i'm thinking that the only option that hasn't been changed is the router-id, on every ospf node, i manually assign them their router id, please have look:
ospf3.JPG
Maybe i should change it or something?

Nevertheless i'd like to still outline that with v2.9 everything worked perfetly and i never had problems with it.
You do not have the required permissions to view the files attached to this post.

Who is online

Users browsing this forum: No registered users and 107 guests