Community discussions

MUM Europe 2020
 
QpoX
Member
Member
Topic Author
Posts: 387
Joined: Mon Mar 24, 2008 7:42 pm
Location: Lemvig, Denmark

IPv6 and SixXS (6to4)

Tue Apr 15, 2008 1:01 pm

I've gone after this guide http://doc.thewan.net/wiki/index.php/IP ... k_RouterOS
But i can't ping 2001:xxxx:xxxx:xxxx::1 (my IPv6 gateway)

[admin@RB333] > /interface 6to4 add mtu=1280 name=6to4-sixxs disabled=no local-address=<Your IPv4>
[admin@RB333] > /ipv6 address add interface=6to4-sixxs address=<Your IPv6>
[admin@RB333] > /ipv6 route add dst-address=2000::/3 gateway=::<SixXS IPv4>

Has anybody gotten SixXS and RouterOS to work together?
 
User avatar
andrewluck
Forum Veteran
Forum Veteran
Posts: 702
Joined: Fri May 28, 2004 9:05 pm
Location: Norfolk, UK

Re: IPv6 and SixXS (6to4)

Fri Apr 18, 2008 9:36 am

Here's the article I wrote using the Hurricane Electric service.

http://wiki.mikrotik.com/wiki/Setting_u ... nel_broker

I need to look at this again because my tunnel isn't working at the moment.

Regards

Andrew
 
QpoX
Member
Member
Topic Author
Posts: 387
Joined: Mon Mar 24, 2008 7:42 pm
Location: Lemvig, Denmark

Re: IPv6 and SixXS (6to4)

Mon Apr 21, 2008 4:21 am

Hi Andrew

I have try'd your guide, but no luck :(

/Ken
 
User avatar
andrewluck
Forum Veteran
Forum Veteran
Posts: 702
Joined: Fri May 28, 2004 9:05 pm
Location: Norfolk, UK

Re: IPv6 and SixXS (6to4)

Mon Apr 21, 2008 11:14 pm

Ken

Had to rebuild my tunnel on the HE website. Working again now.

Are you pinging the remote gateway ipv6 address from the router or a PC?. Stick to the router at first, it's simpler.

Otherwise, your config looks OK. Double check the values you've entered.

Regards

Andrew
 
QpoX
Member
Member
Topic Author
Posts: 387
Joined: Mon Mar 24, 2008 7:42 pm
Location: Lemvig, Denmark

Re: IPv6 and SixXS (6to4)

Tue Apr 22, 2008 2:44 am

I have another machine running on SixXS it can't ping the IP setup in RouterOS.
And the Box with RouterOS can't ping it's GW but can ping it's own IP...

Is there maybe some firewall rules that i need?
right now i have block'd ALL trafic to my main IPv4 where the IPv6 is routed to.
 
User avatar
andrewluck
Forum Veteran
Forum Veteran
Posts: 702
Joined: Fri May 28, 2004 9:05 pm
Location: Norfolk, UK

Re: IPv6 and SixXS (6to4)

Wed Apr 23, 2008 7:24 pm

Ken
right now i have block'd ALL trafic to my main IPv4 where the IPv6 is routed to
But this is an ipv6 in ipv4 tunnel. You need to allow the tunnel traffic.

Regards

Andrew
 
QpoX
Member
Member
Topic Author
Posts: 387
Joined: Mon Mar 24, 2008 7:42 pm
Location: Lemvig, Denmark

Re: IPv6 and SixXS (6to4)

Fri Apr 25, 2008 2:00 am

How do i find and allow the traffic?
 
Vaelen
just joined
Posts: 18
Joined: Fri Aug 24, 2007 3:35 am

Re: IPv6 and SixXS (6to4)

Sat Apr 26, 2008 3:09 am

So I've tried this with my tunnel information and it doesn't work. the thing that I don't get is that a 6to4 interface is not what should be used, what should be used is something like a cisco ipv6ip tunnel which is not the same. So i don't even know how yours worked to begin with.
Ryan Carter
Network Engineer C4ISR
MTCNA, MTCRE, MTCWE, MTCTCE
CCNA
 
User avatar
andrewluck
Forum Veteran
Forum Veteran
Posts: 702
Joined: Fri May 28, 2004 9:05 pm
Location: Norfolk, UK

Re: IPv6 and SixXS (6to4)

Sat Apr 26, 2008 8:58 pm

You're right, it's not the same, it's way cheaper than the Cisco. If your ISP doesn't provide an ipv6 service then you need to tunnel ipv6 inside an ipv4 tunnel, which is what a 6to4 tunnel is. Mine's working fine since I hit the rebuild tunnel button on the tunnel brokers web page.

Tunnel traffic is carried by IP protocol 41.

Regards

Andrew
 
QpoX
Member
Member
Topic Author
Posts: 387
Joined: Mon Mar 24, 2008 7:42 pm
Location: Lemvig, Denmark

Re: IPv6 and SixXS (6to4)

Sun Apr 27, 2008 4:46 pm

Andrew, What do you have of firewall rules?
 
User avatar
andrewluck
Forum Veteran
Forum Veteran
Posts: 702
Joined: Fri May 28, 2004 9:05 pm
Location: Norfolk, UK

Re: IPv6 and SixXS (6to4)

Mon Apr 28, 2008 8:17 pm

This in the output chain:
chain=output action=accept protocol=41
This in the input:
chain=input action=accept src-address=216.66.80.26 protocol=41
216.66.80.26 is the providers endpoint address.

Regards

Andrew
 
QpoX
Member
Member
Topic Author
Posts: 387
Joined: Mon Mar 24, 2008 7:42 pm
Location: Lemvig, Denmark

Re: IPv6 and SixXS (6to4)

Tue Apr 29, 2008 1:34 am

Here is the thing, i can't find the protocol named 41...
I've got the IPv6 package installed.
 
User avatar
andrewluck
Forum Veteran
Forum Veteran
Posts: 702
Joined: Fri May 28, 2004 9:05 pm
Location: Norfolk, UK

Re: IPv6 and SixXS (6to4)

Tue Apr 29, 2008 8:13 pm

You don't need to find it. Just manually type it in the IPv4 firewall rule.

Regards

Andrew
 
QpoX
Member
Member
Topic Author
Posts: 387
Joined: Mon Mar 24, 2008 7:42 pm
Location: Lemvig, Denmark

Re: IPv6 and SixXS (6to4)

Wed Apr 30, 2008 8:04 pm

\o/ it work'd... So thank you Andrew

But why has protocol 41 (RFC2893) not been added to Winbox...
 
User avatar
polokus
newbie
Posts: 35
Joined: Fri Dec 23, 2005 7:04 am

Re: IPv6 and SixXS (6to4)

Mon Jul 21, 2008 11:55 am

i have an error while adding this command 209.197.5.66 is my tunnel broker ip please shed me a light what is wrong

thankyou
/ipv6 route add dst-address=2000::/3 gateway=::209.197.5.66
                           
failure: Invalid route configuration: Each link-local or IPv4-compatible nextho
p address must have interface index
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 5950
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: IPv6 and SixXS (6to4)

Mon Jul 21, 2008 11:57 am

You have to specify which interface to use:
for example:
/ipv6 route add dst-address=2000::/3 gateway=::209.197.5.66,ether1
 
jerryroy1
Frequent Visitor
Frequent Visitor
Posts: 85
Joined: Sat Mar 17, 2007 4:55 am
Location: LA and OC USA
Contact:

Re: IPv6 and SixXS (6to4)

Sat Apr 07, 2012 2:37 am

Can someone please clear up this doc. What a mess.

http://wiki.mikrotik.com/wiki/Setting_u ... nel_broker

THIS DOES NOT work on 5.14

/ipv6 route add dst-address=2000::/3 gateway=::216.66.80.26

THIS works on 5.14

/ipv6 route add dst-address=2000::/3 gateway=::209.197.5.66%sixbone

Who is online

Users browsing this forum: MSN [Bot] and 79 guests