Community discussions

MikroTik App
 
WirelessRudy
Forum Guru
Forum Guru
Topic Author
Posts: 3094
Joined: Tue Aug 08, 2006 5:54 pm
Location: Spain

rosv.3.7 still giving problems

Mon Apr 28, 2008 3:03 pm

I have a x386 running as my main gateway router with basically all ros3.x families so far.
We came across scripting problems several times after an update and apart from webproxy all the rest functioned fine. The router has some 30 routes in the table, the firewall about 100 filters, two WAN interfaces (ehter) and one LAN (ether to wireless unit) and all my devices are MT and basically that's it.

Only webproxy couldn´t made to work under 3.x so far. It just didn´t do it while properly configured. I updated last week to ros.3.7 since I saw not too many or alarming issues about it in this forum and finally webproxy worked fine! I was delighted!
It worked fine for several days (90 clients browsing on a daily base) and it certainly increased the browsing.

But this Saturday it crashed. The webproxy crashed completely. The cache was gone, the harddisk (which is also the system disk) couldn't be seen by the webproxy any more and max. limit of client connections was set to 1. I had to disable the redirect rule in firewall nat and we were all back on line. But what a disappointment....

I didn't dare to reboot the machine because if the hd really failed it wouldn't start up anymore! And I have no fast available backup machine yet.

But only 6 hours later, the machine itself crashed! The whole system tumbled down and my network connectivity to the internet was down! I couldn't log in anymore and all connections to it were gone! Even the console of the PC itself wasn't functioning anymore.. This is the first time in 13 months this happened!
So I was forced to do a hard reboot now anyway to see how my luck was that day. And luckily the machine booted normally and even webproxy works again... what a relief!

The HD is checked and nothing is being reported to be wrong.

In my humble opinion it means that in ros3.7 webproxy is still not 100% OK. I leaf it off now to see how long my machine stays alive now with 3.7

But obviously I am not happy with this! Specially since I found that again the script that worked fine under 3.6 is again not working any more!

Again I have to spend time to fix all this. Maybe I have to buy MT rb1000 to work around the problems. I hope at least their own hardware will perform with their own ros like it should. But what a way to promote their own stuff.... :shock:

Rudy
Show your appreciation of this post by giving me Karma! Thanks.

Rudy R. Puister

WISP operator based on MT routerboard & ROS.
 
npbrasil
Frequent Visitor
Frequent Visitor
Posts: 83
Joined: Wed Jun 02, 2004 8:50 am

Re: rosv.3.7 still giving problems

Tue Apr 29, 2008 6:53 am

webproxy is still not 100% OK
You is very generous, the webproxy in 3.7 is a really disaster. I have changed to external squid, but i still with 3.2 because the redirect don't work in 3.7 (many ips in wan and lan) and in versions prior to the 3.6 my router don't boot. With the webproxy disabled the router is stable. But the greatest difference in squid is the very low cpu usage... Because the mikrotik webproxy uses so much cpu time?
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: rosv.3.7 still giving problems

Tue Apr 29, 2008 8:13 am

what you mean by
redirect don't work in 3.7
if you set NAT rule everything is working as expected
 
npbrasil
Frequent Visitor
Frequent Visitor
Posts: 83
Joined: Wed Jun 02, 2004 8:50 am

Re: rosv.3.7 still giving problems

Tue Apr 29, 2008 12:17 pm

Just upgrade from 3.2 to 3.7 (nat rule set) = don't work. Back to 3.2 and the webproxy work just fine. If i configure just one ip in the wan and one ip in the lan the proxy work, with many ips it don't work. Please, look this post: http://forum.mikrotik.com/viewtopic.php?f=2&t=23307
Hi chupaka!! Can you help here?

Who is online

Users browsing this forum: Egert143, jvanhambelgium and 131 guests